在线检测未来函数

通达信BS波段买卖点主图及选股指标公式

来源:Internet,编辑:股旁网,2018-11-20

MA5:MA(C,5),COLORF00FF0;
MA10:MA(C,10),COLORYELLOW;
MA20:MA(C,20),COLORE66878;
MA30:MA(C,30),COLORWHITE;
MA120:MA(C,120),COLORGREEN,POINTDOT;
MA240:MA(C,240),COLORRED,POINTDOT;
A1:=IF(C>=MA5,1,-1);
A2:=IF(C>=MA10,1,-1);
A3:=IF(C>=MA20,1,-1);
A4:=IF(MA5>=REF(MA5,1),1,-1);
A5:=IF(MA10>=REF(MA10,1),1,-1);
A6:=IF(MA20>=REF(MA20,1),1,-1);
趋势:=(A1+A2+A3+A4+A5+A6)/6*100,COLORCYAN,LINETHICK3;
X1:=(C+L+H)/3;
X2:=EMA(X1,6);
X3:=EMA(X2,5);
DRAWTEXT(CROSS(X2,X3),L*0.98,'B');
DRAWTEXT(CROSS(X3,X2),H*1.02,'S');
STICKLINE(X2>=X3,LOW,HIGH,1,0),COLORRED;
STICKLINE(X2>=X3,CLOSE,OPEN,3,1),COLORRED;
STICKLINE(X2>=X3,CLOSE,OPEN,2,0),COLORBROWN;
STICKLINE(X2<X3,LOW,HIGH,1,0),COLORGREEN;
STICKLINE(X2<X3,CLOSE,OPEN,3,1),COLORGREEN;
STICKLINE(CROSS(X2,X3),OPEN,CLOSE,2.5,0),COLORYELLOW;
STICKLINE(CROSS(X3,X2),OPEN,CLOSE,2.5,0),COLORBLUE;
DRAWTEXT(趋势>=100 AND MA5>REF(MA5,1) AND (CLOSE-OPEN)/OPEN*100>5 AND CLOSE>MA5,L*0.99,'★'),COLORMAGENTA;

{
选股公式:

X1:=(C+L+H)/3;
X2:=EMA(X1,6);
X3:=EMA(X2,5);
XG:CROSS(X2,X3);
}

通达信BS波段买卖点主图及选股指标公式

 

相关文章