在线检测未来函数

同花顺天门阵主图指标公式

来源:Internet,编辑:股旁网,2018-12-17

N:=75;
M:=2;
L1:=LLV(HIGH,N);
H1:=HHV(L,N);
C1:=(H1+L1)/2;
D1:=LLV(HIGH,M);
穆桂英:EMA((2*C+H+L)/4,M),COLOR6633FF,LINETHICK2;
穆柯寨:L1,COLORFF00FF,LINETHICK2;
杨宗保:C1,COLOR33FF33,LINETHICK2;
天门阵:H1,COLORFFFF00,LINETHICK2;
RC:=DYNAINFO(3);
S2:=SMA(C,3,1);
S6:=SMA(C,5,1);
DK:=2*(S2-S6);
STICKLINE(DK>0,RC,RC+DK,0,1),colorred;
STICKLINE(DK<0,RC,RC+DK,0,1),COLORFFFF00;
RC,COLOR333399;
DRAWTEXT(FILTER(EMA(CLOSE,60)-EMA(CLOSE,12)>0 AND EMA(CLOSE,12)/LOW>1.15,5),
LOW,'●'),COLORFF00FF;
DRAWTEXT(FILTER(EMA(CLOSE,12)-EMA(CLOSE,60)>0 AND HIGH/EMA(CLOSE,12)>1.15,5),
HIGH,'●'),coloryellow;
MA1:MA(CLOSE,6),COLORFFFFFF;
MA2:MA(CLOSE,13),coloryellow;
X:=EMA(((SLOPE(CLOSE,21) * 20) + CLOSE),68);
Y:=EMA(CLOSE,10);
LL:=REF(CLOSE,2);
MM:=((SMA(MAX((CLOSE - LL),0),6,1) / SMA(ABS((CLOSE - LL)),6,1)) * 100);
DB:=IF(((MM < REF(MM,1)) AND (MM > 79)),MM,0);
DRAWTEXT(CROSS(Y,X),(LOW * 0.985),'▲买'),colorred;
DRAWTEXT(CROSS(X,Y),(HIGH * 1.02),'◆卖'),COLORFF6699;
DRAWTEXT(DB,(HIGH * 1.02),'○'),COLOR00FF00;
VAR1:=LLV(LOW,21);
VAR2:=HHV(HIGH,21);
AK1:=EMA((((CLOSE - VAR1) / (VAR2 - VAR1)) * 100),5);
AK:=EMA((((CLOSE - VAR1) / (VAR2 - VAR1)) * 50),13);
DD:=EMA(((0.667 * REF(AK1,1)) + (0.333 * AK1)),2);
VAR3:=LLV(LOW,55);
VAR4:=HHV(HIGH,34);
VAR5:=EMA((((CLOSE - VAR3) / (VAR4 - VAR3)) * 100),3);
VAR6:=((AK + VAR5) / 2);
VAR7:=EMA(((0.667 * REF(VAR5,1)) + (0.333 * AK1)),2);
VAR8:=EMA(VAR6,5);
BB:=EMA(((0.667 * REF(VAR8,1)) + (0.333 * VAR8)),2);
AB:=CROSS(AK1,AK);
BB1:=(CROSS(AK1,BB) AND (BB < 30));
CD:=(BB1 * 0.6);
DRAWTEXT((CD = 0.6),(LOW * 0.99),'□'),COLOR33CC99;
DRAWTEXT((AB = 1),(LOW * 0.99),'□'),colorwhite;

同花顺天门阵主图指标公式

 

相关文章