在线检测未来函数

通达信MACDKDJ叠加指标公式

来源:Internet,编辑:股旁网,2018-12-25

DIFF:EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:EMA(DIFF,9);
DRAWBAND(DIFF,RGB(150,30,80),DEA,RGB(0,100,0));
MACD:(DIFF-DEA)*2,COLORCYAN,COLORSTICK;
STICKLINE(MACD>=0,MACD,0,0.5,1),COLORF00FF0;
STICKLINE(MACD<0,MACD,0,0.2,1),COLORWHITE;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,0.1,0 ),COLOR00AAFF;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,0.1,0 ),COLOR00BBFF;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,0.1,0 ),COLOR00CCFF;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,0.1,0 ),COLOR00DDFF;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,0.1,0 ),COLOR00EEFF;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,0.1,0 ),COLOR00FFFF;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,0.0.1,0 ),COLOR0000AA;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,0.1,0 ),COLOR0011BB;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,0.1,0 ),COLOR0022CC;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,0.1,0 ),COLOR0033DD;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,0.1,0 ),COLOR0044EE;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,0.0.1,0 ),COLOR0055FF;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,0.1,0 ),COLORAA00BB;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,0.1,0 ),COLORBB11BB;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,0.1,0 ),COLORCC22BB;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,0.1,0 ),COLORDD33BB;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,0.1,0 ),COLOREE44BB;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,0.1,0 ),COLORFF55BB;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,0.1,0 ),COLORFFAA00;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,0.1,0 ),COLORFFBB11;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,0.1,0 ),COLORFFCC22;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,0.1,0 ),COLORFFDD33;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,0.1,0 ),COLORFFEE44;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,0.1,0 ),COLORFFFF55;AX1:=MAX(MAX(DIFF,DEA),MACD);
AX2:=MIN(MIN(DIFF,DEA),MACD);
AA1:REFDATE(HHV(AX1,120),DATE)COLORGRAY,DOTLINE;
AA2:REFDATE(LLV(AX2,120),DATE)COLORGRAY,DOTLINE;
AA3:=(0+AA1)+(0-AA2);
AA4:REFDATE((AA1+AA2)/2,DATE)COLORGRAY,DOTLINE;
{}
RSV:=(CLOSE-LLV(LOW,6))/(HHV(HIGH,6)-LLV(LOW,6))*AA3;
假K:SMA(RSV,3,1)+AA2,COLORWHITE;
假D:SMA(SMA(RSV,3,1)+AA2,3,1),COLORYELLOW;
假J:(3*SMA(RSV,3,1)-2*SMA(SMA(RSV,3,1),3,1))+AA2,COLORMAGENTA;
{}
ZRSV:=(CLOSE-LLV(LOW,6))/(HHV(HIGH,6)-LLV(LOW,6))*100;
真K:SMA(ZRSV,3,1)COLORCYAN,NODRAW;
真D:SMA(真K,3,1)COLORBROWN,NODRAW;
真J:3*真K-2*真D,COLORLIRED,NODRAW;
{}
DRAWTEXT_FIX(ISLASTBAR,0.01,0.02,0,'上中下虚线分别是KDJ的100,50,0轴')COLORYELLOW;

通达信MACDKDJ叠加指标公式

 

相关文章