在线检测未来函数

通达信飓风眼副图指标公式

来源:Internet,编辑:股旁网,2019-01-11

{趋势转强}
VAR5X:=(CLOSE-LLV(LOW, 100))/(HHV(HIGH, 100)-LLV(LOW, 100))*200;
VAR6X:=SMA(VAR5X, 3, 1);
VAR7X:=SMA(VAR6X, 3, 1);
VAR8X:=3*VAR6X-2*VAR7X;
VAR11:=EMA((CLOSE-LLV(LOW, 5))/(HHV(HIGH, 5)-LLV(LOW, 5))*100, 4)*2;
VAR12:=EMA(0.667*REF(VAR11, 1)+0.333*VAR11, 2);
VAR13:=3*VAR11-2*VAR12;
VAR14:=POW(MA(CLOSE, 5), 2)+MA(CLOSE, 5);
VAR15:=POW(MA(LOW, 5), 2)+MA(LOW, 5);
VAR16:=POW(MA(HIGH, 5), 2)+MA(HIGH, 5);
VAR17:=(VAR14-LLV(VAR15, 64))/(HHV(VAR16, 64)-LLV(VAR15, 64))*150+65-10;
VAR18:=SMA(VAR17, 3, 1)*1.5-100;
VAR19:=SMA(VAR18, 3, 1);
VAR20:=3*VAR18-2*VAR19;
VAR21:=(HIGH+LOW+CLOSE*2)/4;
VAR22:=EMA(VAR21, 13);
VAR23:=STD(VAR21, 13);
VAR24:=(VAR21-VAR22)*100/VAR23;
VAR25:=EMA(VAR24, 5);
VAR26:=EMA(VAR25, 13);
VAR27:=EMA(VAR25, 13)+200-100;
VAR28:=EMA(VAR27, 10);
VAR29:=3*VAR27-2*VAR28;
VAR30:=VAR6X+VAR11+VAR18+VAR27;
VAR31:=VAR7X+VAR12+VAR19+VAR28;
VAR32:=VAR8X+VAR13+VAR20+VAR29;
VAR33:=(HIGH+LOW+CLOSE)/3;
VAR34:=AMOUNT/VOL/100;
VAR35:=SUM(AMOUNT, 5)/SUM(VOL, 5)/100;
VAR36:=(VAR33-MA(VAR33, 34))/(0.015*AVEDEV(VAR33, 34));
VAR41:=(VAR33-EMA(VAR33, 24))/STD(VAR33, 24)*100;
VAR42:=(VAR33-MA(VAR33, 24))/(0.015*AVEDEV(VAR33, 24));
VAR43:=EMA(VAR41, 5);
VAR44:=(VAR34-MA(VAR34, 21))/(0.015*AVEDEV(VAR34, 21));
VAR45:=(VAR35-MA(VAR35, 90))/(0.015*AVEDEV(VAR35, 90));
VAR46:=((VAR45+VAR44+VAR43+VAR42+VAR36)/5+165)/4;
VAR47:=(EMA(EMA(EMA(VAR46, 15), 10), 5)-25)*2+DMA(AMOUNT/VOL/100, VOL/CAPITAL);
VAR48:=(VAR30+VAR31+VAR32*30)/32/5-15;
VAR49:=EMA(VAR48, 13);
VAR51:=(VAR47+VAR49)/2;
VAR52:=EMA(VAR51, 1);
ZX:EMA(VAR52, 2),LINETHICK0, COLORFF7710;
{STICKLINE(ZX-REF(ZX, 2)<0, ZX, 10, 9, 0),COLORBROWN;{COLOR9CA010;}
STICKLINE(ZX-REF(ZX, 2)>0, ZX, 10, 9, 0),COLORLIRED;{LINETHICK0, COLOREEEEEE;}
VAR1:=IF(YEAR>=2038 AND MONTH>=1,0,1);
VAR2:=REF(LOW,1)*VAR1;
VAR3:=SMA(ABS(LOW-VAR2),3,1)/SMA(MAX(LOW-VAR2,0),3,1)*100*VAR1;
GG:=100*(1-WINNER(C))>99.8 AND V/CAPITAL*100<5 AND 100*(WINNER(1.1*C)-WINNER(0.9*C))<3.9;
最佳建仓点:=C>REF(C,1) AND REF(GG,1)>0 AND VAR3,COLORRED;
STICKLINE(C>REF(C,1) AND REF(GG,1)>0 AND VAR3,0,80,4,0),COLORRED;
{DRAWTEXT(C>REF(C,1) AND REF(GG,1)>0 AND VAR3,85,'★低位建仓'),COLORYELLOW;}
{1指.能量线}
能量线:=EMA(100*(C-LLV(L,34))/(HHV(H,34)-LLV(L,34)),3),LINETHICK0;
{2指.RSI} RSI:=SMA(MAX(CLOSE-REF(CLOSE,1),0),6,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),6,1)*100,LINETHICK0;
{3指.KDJ} RSVF:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100,LINETHICK0;
KF:=SMA(RSVF,3,1);
DF:=SMA(KF,3,1);
JF:=3*KF-2*DF,LINETHICK0;
{4指.W&R} 威廉WR:=(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14))*100,LINETHICK0;
{5指.CCI} TYP := (HIGH + LOW + CLOSE)/3; }
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14)),LINETHICK0;
五指A:WMA((能量线+RSI+JF-威廉WR+CCI)/2.5,5);{调节高低位置}
五指B:WMA((能量线+RSI+JF-威廉WR+CCI)/4,13);
KC:=FORCAST(((2*C+H+L)/4*0.618+C*0.382),3);
AAX:=(KC-MA(KC,9))/MA(KC,9)*100; VAR0:=MIN(EXIST(KC,55),9);
AAX1:=EMA(AAX,VAR0)*VAR0; AAX2:=MA(AAX1,3);
AAX3:=MA(AAX1,5); 卖:=AAX3>3 AND AAX1<REF(AAX1,1) AND CROSS(AAX2,AAX1);
VBA:=FILTER(卖,5);
{DRAWTEXT(VBA,五指A*1.08,'★顶背离警惕'),COLORGREEN;}
VB2:=EMA(EMA(C-REF(C,1),6),6)/EMA(EMA(ABS(C-REF(C,1)),6),6)*100;
VB3:=IF(LLV(VB2,3)=LLV(VB2,11) AND COUNT(VB2<0,2) AND CROSS(VB2,MA(VB2,2)),1,0);
VB4:=FILTER(VB3=1,5);
{DRAWTEXT(VB4,五指A*0.97,'★买入'),COLOR00FFFF;}
DRAWBAND(五指A,RGB(255,200,0),五指B,RGB(0,40,55));{亮度}
{MA((能量线+RSI+JF-威廉WR+CCI)/5,5),COLORLICYAN,LINETHICK3;{淡青色线}
IF(五指A>REF(五指A,1),五指A,DRAWNULL),COLORRED,LINETHICK4;{红色线};
DRAWTEXT_FIX(1,0.02,0,0,'◆能量线,RSI3.KDJ,W&R,CCI,
【五个指标共振线.[红].[绿].变化是买卖信号.颜色及标记是配合信号】'),COLOR00FFFF,LINETHICK3;
DRAWTEXT(VB4,五指A*0.97,'★低买'),COLOR00FFFF;
{飓风眼,红色下叉带}
VAR11F:=(HHV(HIGH,8)-CLOSE)/(HHV(HIGH,20)-LLV(LOW,20))*100;
VAR33F:=100-3*SMA((CLOSE-LLV(LOW,72))/(HHV(HIGH,72)-LLV(LOW,72))*100,20,1)
+2*SMA(SMA((CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100,20,1),15,1);{72}
冷气OAMV:=EMA(VAR33,2),COLORRED;
冷气南下:=EMA(EMA(SMA(VAR11,6,1)-7,2),2);
WR线:=EMA(EMA(100*(HHV(HIGH,42)-CLOSE)/(HHV(HIGH,42)-LLV(LOW,42)),3),3),COLORWHITE,DOTLINE;
SBZLPA1:=BARSLAST(L=HHV(L,7));
SBZLPA2:=EMA(SBZLPA1*SBZLPA1,13);
暖气北上:=IF(SBZLPA2>88,88+SQRT(SBZLPA2-88),SBZLPA2);
TPV:=(暖气北上+冷气南下+冷气OAMV)/3;
T冷气南下:=(暖气北上+TPV)/2+8,COLORWHITE,DOTLINE;
T暖气北上:=(冷气南下+TPV)/2+8,COLORBLUE,DOTLINE;
T飓风形成:=(T暖气北上+T冷气南下)/2,COLORGRAY,DOTLINE;
WR慢:=EMA(EMA(100*(HHV(HIGH,42)-CLOSE)/(HHV(HIGH,42)-LLV(LOW,42)),2),2);
ZLCQ:=EMA((WINNER(CLOSE) * 69),3);
SHCQ:=EMA(((WINNER((CLOSE * 1.1)) - WINNER((CLOSE * 0.93))) * 80),3);
主力控盘Q:=EMA(((ZLCQ / (ZLCQ+ SHCQ)) * 110),2),COLORFF11FF,LINETHICK2;
上限Q:=HHV(主力控盘Q,20),COLORGRAY,LINETHICK3;
下限Q:=LLV(主力控盘Q,20),COLORGRAY,LINETHICK3;
圈Q:=100*(HHV(HIGH,42)-C)/(HHV(HIGH,42)-LLV(LOW,42));
M圈Q:=EMA(EMA(圈Q,3),2);
MM圈Q:=EMA(EMA(EMA(圈Q,4),3),2);
控盘主升Q:=EMA(主力控盘Q,2);
KONGQ0:=(上限Q/控盘主升Q)*(下限Q/控盘主升Q)*50;
KONGQ:=IF(KONGQ0>100,100,IF(KONGQ0<1,1,KONGQ0));
MAXV:=MAX(T冷气南下,T暖气北上);
MINV:=MIN(T冷气南下,T暖气北上);
MMV0:=MAXV/MINV;
MMV1:=T冷气南下/REF(T冷气南下,1);
MMV2:=T暖气北上/REF(T暖气北上,1);
散筹集中度Q:=EMA(EMA((WINNER(C*1.1)-WINNER(C*0.9))*50/(WR慢/MM圈Q)/MMV0/MMV1/MMV2,3),2);
KKONG0:=KONGQ*KONGQ*5/SQRT(散筹集中度Q)/控盘主升Q;
KKONG:=IF(KKONG0>100,100,KKONG0);
KV0:=KKONG/KONGQ;
KV1:=KONGQ/REF(KONGQ,1);
KV2:=KKONG/REF(KKONG,1);
KV3:=EMA(KV0*KV0*KV1*KV2*30,2);
OKV:=IF(KV3>100,100,IF(KV3<0,0,KV3));
WVQ0:=1.18*(上限Q*下限Q+5)/(KONGQ+2)/SQRT(SQRT((OKV+2)/(KONGQ+5)));
WVQ1:=100-IF(WVQ0>70,70+SQRT(WVQ0-1),IF(WVQ0<1,1,WVQ0));{90}
WVVQ:=(IF(WVQ1<05,0.5,WVQ1));
EVVQ:=EMA(EMA(WVVQ*0.97,3),3);
DRAWBAND(WVVQ,RGB(11,60,55),EVVQ,RGB(240,11,33));{红色下叉变色}
{要拉一波}
VAR1A:=DMA(AMOUNT/VOL/100,VOL/CAPITAL);
VAR4AA:=CLOSE/(REF(CLOSE,1))>1.05 AND (HIGH/CLOSE<1.01);{1.05;1.01}
游资进场:=(FILTER(VAR4AA>0,34)AND DYNAINFO(4)>0)*8,COLORYELLOW;
A10:10,COLORYELLOW;
{STICKLINE(XYSHSL>2.1 AND CYS13>5,53,86,5,0 ),COLOR000055;}
STICKLINE(游资进场,10,66,6,0),COLORBLUE;
LS:=C/REF(C,1)>1.048 AND C=H AND BETWEEN(FORCAST(V,4),0.2*FORCAST(V,12),2.1*FORCAST(V,12));
拉升:=FILTER(LS,28);
M:=10;
N:=9;
散户线:100*(HHV(HIGH,M)-CLOSE)/(HHV(HIGH,M)-LLV(LOW,M)),COLORGREEN,LINETHICK2;{COLORFFFF00青线}
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
庄筹线:EMA(J,6),COLORRED,LINETHICK3;{粉线COLORFF00FF}
IF(散户线<庄筹线,散户线,DRAWNULL),COLORRED,LINETHICK3;
IF(庄筹线<散户线,庄筹线,DRAWNULL),COLORCYAN,LINETHICK2;
IF(散户线>A10,散户线,DRAWNULL),COLORCYAN,LINETHICK2;
XG1P:=CROSS(散户线,A10);
{DRAWICON(XG1,OPEN+1,18);}
{STICKLINE(XG1P,L*4.40,L*1.05,1,0),COLORWHITE;
DRAWTEXT(XG1P,L*3.89,'--主图空仓'),COLORBLUE;}
STICKLINE(拉升,10,58,0.5,0)COLORGREEN;
DRAWTEXT(拉升,40,' 芝麻开花'),COLORGREEN;
DRAWICON(拉升,66,9);
DRAWICON(游资进场=8,44,34);
DRAWICON(游资进场=8,30,33);
DRAWICON(游资进场=8,14,18);
DRAWTEXT(游资进场=8,66,' 要拉一波'),COLORCYAN;
DRAWTEXT(C>REF(C,1) AND REF(GG,1)>0 AND VAR3,85,'★低位建仓'),COLORYELLOW;
DRAWTEXT(VBA,五指A*1.08,'★顶背离警惕'),COLORGREEN;

通达信飓风眼副图指标公式

 

相关文章