在线检测未来函数

通达信飓风眼主图指标公式

来源:Internet,编辑:股旁网,2019-01-11

NN:=21;
MM:=8;
显示均线:=1;
P:=4;
K:=12;
K2:=1;
K3:=8;
{参数:NN:1、99、21;MM:1、99、8;显示均线:0、1、1;
P:1、100、4;K:1、999、12;K2:1、2、1;K3:1、999、8;}
{卖出------------------------}
VAR55:=EMA(EMA(EMA(CLOSE,8),13),62);
VAR56:=((REF(HIGH,1) + REF(LOW,1)) / 2);
VAR57:=(MA(CLOSE,20) + (2 * STD(CLOSE,20)));
VAR58:=((SMA(MAX((CLOSE - REF(CLOSE,1)),0),7,1) / SMA(ABS((CLOSE - REF(CLOSE,1))),7,1)) * 100);
卖出1:=FILTER(CROSS(79,VAR58),4);
MA21:=REF(CLOSE,1);
ZX:=((SMA(MAX((CLOSE - MA21),0),6,1) / SMA(ABS((CLOSE - MA21)),6,1)) * 100);
卖出2:=CROSS(84,ZX);
卖出3:=CROSS(90,RSI);
卖出:=卖出1 OR 卖出2 OR 卖出3;
DRAWICON(卖出,(LOW * 1.15),15);
{买入------------------------}
MA3:=MA(CLOSE,3);
ZVAR4:=(((HIGH + LOW) + CLOSE) / 3);
QQ2:=(CLOSE-LLV(LOW, 18))/(HHV(HIGH, 18)-LLV(LOW, 18))*100;
QQ3:=SMA(QQ2, 9, 1);
QQ4:=SMA(QQ3, 3, 1);
趋势:=3*QQ3-2*QQ4,COLORWHITE,LINETHICK3;
趋势线1:=EMA(QQ3, 3),COLORRED,LINETHICK3;
金叉:= CROSS(长趋势,趋势线1);
AAAA1:=AMOUNT/V;
BBB1:=L<AAAA1*0.9;
CCC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DDD1:=L<MA(C,5)*0.921;
EEE1:=V<MA(V,5)*1.5;
老鼠仓:=BBB1 AND CCC1 AND DDD1 AND EEE1,,NODRAW;
X1:=(C+L+H)/3;
BB5:=ATAN(EMA(X1,7)-REF(EMA(X1,7),1))*3.1416*10;
VAR1:=(MA(CLOSE,80)-MA(CLOSE,13)/3);
VAR2:=( MA((CLOSE-VAR1)/VAR1,1));
VVAR3:=(CLOSE-LLV(LOW,28))/(HHV(HIGH,28)-LLV(LOW,28))*100;
{VVAR4:=SMA(VVAR3,4,1);}
MMA:=EMA(VAR2,12)*0.7;
MMB:=EMA(VAR2,3);
快到底:=IF(LLV(MMB-MMA,12)>0,0,-20),LINETHICK2,COLORGREEN;
DIFF:=( EMA(CLOSE,12) - EMA(CLOSE,26))*100;
DEA:=EMA(DIFF,9);
MACD:= 2*(DIFF-DEA);
抄底:=IF(快到底<0 AND CROSS(MACD,0) AND ZVAR4<18,1,0);
AVAR2:=(2*CLOSE+HIGH+LOW)/4;
AVAR3:=IF(YEAR>=2099 AND MONTH>2,0,1);
AVAR4:=LLV(LOW,5);
AVAR5:=HHV(HIGH,4);
散户:= EMA((AVAR2-AVAR4)/(AVAR5-AVAR4)*100,4)*AVAR3;
庄家:= EMA(0.667*REF(散户,1)+0.333*散户,2)*AVAR3;
试买:=(((CROSS(散户,庄家) AND 散户<50 AND 29<散户)) NOT 大雪)
OR (CROSS(散户,庄家) AND 散户<30 { AND 角1>0}) OR 抄底;
AA05:=MA(C,5),COLOR0099CC;
五日乖离率:=(C-AA05)/AA05*100;
BB05:=ATAN((AA05/REF(AA05,1)-1)*100)*180/3.1416;
速度5:=SMA(EMA((AA05-REF(AA05,1))/REF(AA05,1),3)*100,3,1);
加速度5:=EMA((速度5-REF(速度5,1)),3),NODRAW;
AA10:=MA(C,10);
AA20:=MA(C,20);
BB10:=ATAN((AA10/REF(AA10,1)-1)*100)*180/3.1416;
AA30:=MA(C,30);
三拾日乖离率:=(C-AA30)/AA30*100;
加仓:=FILTER(COUNT(CROSS(BB05,30),5)>=1 AND
AA05>REF(AA05,1) AND 三拾日乖离率>REF(三拾日乖离率,1) AND
AA10>REF(AA10,1)
AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1) ,10) ;
MV3:=EMA(V,3);
MV3角度:=ATAN((MV3/REF(MV3,1)-1)*100)*180/3.1416;
MA3角度:=ATAN((MA3/REF(MA3,1)-1)*100)*180/3.1416;
MV5:=EMA(V,5);
MA5:=EMA(C,5);
MV5角度:=ATAN((MV5/REF(MV5,1)-1)*100)*180/3.1416;
MA5角度:=ATAN((MA5/REF(MA5,1)-1)*100)*180/3.1416;
MV10:=EMA(V,10);
MA10:=EMA(C,10);
MV10角度:=ATAN((MV10/REF(MV10,1)-1)*100)*180/3.1416;
MA10角度:=ATAN((MA10/REF(MA10,1)-1)*100)*180/3.1416;
强弱度:=(MV3角度+MA3角度+MV5角度+MA5角度+MV10角度+MA10角度)/6,COLORFFFFFF;
QBD:=CROSS(强弱度,50) AND COUNT(强弱度>50,7)<=3;
启爆点:=IF(K=0 AND QBD AND COUNT(QBD,4)=1,50,0),COLOR00FFFF;
半月相对价位:=(C-LLV(L,13))/(HHV(H,13)-LLV(L,13))*10;
半月相对价位M:=SMA(半月相对价位,3,2);
半月相对价位MM:=SMA(半月相对价位M,10,6);
K13:=MA(半月相对价位MM,3);
福缘:=半月相对价位MM>=K13,COLORRED;
启爆福缘:=K=0 AND 启爆点 AND 福缘;
HD:=HIGH-REF(HIGH,1);
LLD:=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LLD,HD,0),14);
DMM:=EXPMEMA(IF(LLD>0&&LLD>HD,LLD,0),14);
AK:=EMA((DMP-DMM)*1,3)*100+50,COLORFFFFFF;
AD:=EMA((MA(DMP,3)-MA(DMM,3))*1,3)*100+50,COLORFFFFFF;
{DRAWICON(CROSS(AK,AD) AND 启爆点 AND 福缘,L*0.99 ,9);}
{DRAWICON(老鼠仓 OR 金叉,(LOW - (LOW * 0.01)),1);}
MH:=K*10;
MK:=K3*10;
HH:=CONST(HHV(H,MH));
LH:=CONST(LLV(H,MH));
LC:=CONST(LLV(L,MK));
HC:=CONST(HHV(H,MK));
幅1:=(L-LC)/LC*100;
AAA:=IF(L=LC,1,0);
AAB:=BARSLAST(AAA),NODRAW;
幅2:=(H-HC)/HC*100;
BBA:=IF(H=HC,1,0);
BBB:=BARSLAST(BBA),NODRAW;
R1:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));
R2:=(REF(R1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
R3:=(REF(R2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
R4:=(REF(R3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
R5:=(REF(R4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
R6:=(REF(R5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
R7:=(REF(R6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
R8:=(REF(R7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
R9:=(REF(R8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
RA:=(REF(R9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
RB:=(REF(RA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
RC:=(REF(RB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
RD:=(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2));
RE:=(REF(RD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
RF:=(REF(RE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
R10:=(REF(RF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
R11:=(REF(R10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
R12:=(REF(R11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
R13:=(REF(R12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
R14:=(REF(R13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
R15:=(REF(R14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
R16:=(REF(R15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
R17:=(REF(R16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
R18:=(REF(R17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
R19:=REF(RD OR RE OR RF OR R10 OR R11 OR R12 OR R13 OR R14 OR R15 OR R16 OR R17 OR R18,1) AND R1;
R1A:=((REF(R1 OR R2 OR R3 OR R4 OR R5 OR R6 OR R7 OR R8 OR R9 OR RA OR RB OR RC,1)) AND RD);
VAR3:=IF(C<200 ,MA(COST(80),3),2500),NODRAW;
VAR4:=(((HIGH + LOW) + CLOSE) / 3);
VAR5:=EMA(((((OPEN + HIGH) + LOW) + CLOSE) / 4),2330);
VAR6:=(VAR5 + ((VAR5 * 6) / 100));
{短买春:=R19,NODRAW,COLOR00DD00;
秋离场:=R1A,NODRAW,COLOR2288DD;}
持股:=R1 OR R2 OR R3 OR R4 OR R5 OR R6 OR R7 OR R8 OR R9 OR RA OR RB OR RC,NODRAW,COLOR0000FF;
阴观望:=RD OR RE OR RF OR R10 OR R11 OR R12 OR R13 OR R14 OR R15 OR R16 OR R17 OR R18,NODRAW,COLOR999999;
{急速超跌关注:=(CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100<-14,COLORBBBBBB,NODRAW;
Q1:=CONST(IF(短买春,0,IF(秋离场,100,IF(红持股,100,IF(急速超跌关注,50,50))))),NODRAW;
Q2:=CONST(IF(短买春,80,IF(秋离场,100,IF(红持股,0,IF(急速超跌关注,50,50))))),NODRAW;
Q3:=CONST(IF(短买春,0,IF(秋离场,20,IF(红持股,50,IF(急速超跌关注,50,50))))),NODRAW;
DRAWRECTREL(970,0,1000,990,RGB(Q1,Q2,Q3));
DRAWRECTREL(970,189,1000,807,RGB(0,55,5));
DRAWRECTREL(970,374,1000,610,RGB(0,5,55));
DRAWRECTREL(970,495,1000,495,RGB(255,00,00));}
A:=EMA((EMA(C,29)+EMA(C,31)+EMA(C,33))/3,3);
A1:=EMA((EMA(C,1)+EMA(C,3)+EMA(C,5))/3,3),COLOR1010FF;
A2:=EMA((EMA(C,3)+EMA(C,5)+EMA( C,7))/3,3),COLOR1020FF;
MT1:=IF(ISLASTBAR,REF((C*2-REF(C,3)),1),DRAWNULL);
MT2:=IF(ISLASTBAR,REF((C*2-REF(C,3)),2),DRAWNULL);
MT3:=IF(ISLASTBAR,C*2-REF(C,3),DRAWNULL);
JRH:=HHV(C,2);
JRL:=LLV(C,2);
离场:=IF(红持股,JRL,DRAWNULL);
今离场价:=REF(离场,1)COLOR0000FF,NODRAW;
进:=IF(阴观望,JRH,DRAWNULL);
今进场价:=REF(进,1),COLOR00FF00,NODRAW;
下档线:=(((CLOSE - LLV(LOW,13)) / (HHV(HIGH,13) - LLV(LOW,13))) * 100);
RRRSV:=SMA(下档线,3,1);
KKK:=SMA(RRRSV,3,1);
DDDDD:=((3 * RRRSV) - (2 * KKK));
JJ12:=(((CLOSE - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100);
RSV24:=SMA(JJ12,3,1);
K24:=SMA(RSV24,3,1);
D24:=((3 * RSV24) - (2 * K24));
压力2:=IF(CROSS(D24,DDDDD),HIGH,REF(HIGH,BARSLAST(CROSS(D24,DDDDD)))),COLORFFFFFF;
底部:=LLV(HIGH,30),COLOR00FF00;
压力位:=IF(ISLASTBAR,压力2,DRAWNULL),NODRAW;
底部位:=IF(ISLASTBAR,底部,DRAWNULL),NODRAW;
AA1:=IF(ISLASTBAR AND (红持股 OR REF(红持股,1)=1),1,0),NODRAW;
AA2:=IF(ISLASTBAR AND (阴观望 OR REF(阴观望,1)=1),1,0),NODRAW;
A99:=EMA((EMA(C,17)+EMA(C,19)+EMA( C,21))/3,3),COLOR1090FF;
A233:=A-(A99-A),COLORFF9010;
中轴:=MA(C,21),COLORFFCC33;
压力1:=IF(K2=1 AND (中轴 + 2*STD(C,34))<=HH,中轴 + 2*STD(C,34),DRAWNULL);
支撑1:=IF(K2=1 AND (中轴 - 2*STD(C,21))>=LH,中轴 - 2*STD(C,21),DRAWNULL);
压力3:=中轴 + 2*STD(C,34);
支撑3:=中轴 - 2*STD(C,21);
压力:=IF(K2=1,压力1,压力3),COLOR0055CC,LINETHICK3;
支撑:=IF(K2=1,支撑1,支撑3),COLORLICYAN,LINETHICK3;
{5日变色线}
越过成仙M240:=MA(C,240),COLORGRAY,LINETHICK1;
M144:=MA(C,144),COLORWHITE,LINETHICK1;
M88:=MA(C,88),COLORLIGRAY,LINETHICK1;
越过有道M120:=MA(C,120),COLORMAGENTA,LINETHICK1;
{越过强势M60:MA(C,60),COLORGREEN,LINETHICK3;}
M30:=MA(C,27),COLORGREEN,LINETHICK2;
M20:=MA(C,17),COLORMAGENTA,LINETHICK2;
M10:=MA(C,10),COLORWHITE,LINETHICK1;
M5:MA(C,3),COLORRED,LINETHICK3;
BB55:=ATAN((M5/REF(M5,1)-1)*100)*180/3.1416;
IF(BB55>30 AND M5>REF(M5,1), M5,DRAWNULL),COLORRED,LINETHICK3;
BB100:=ATAN((M10/REF(M10,1)-1)*100)*180/3.1416;
IF(BB55<0 AND M5<REF(M5,1), M5,DRAWNULL),COLORCYAN,LINETHICK3;
V1:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
V2:=(1-7/100)*(DMA(CLOSE,V1));
A3:IF(K2!=2, EMA((EMA(C,5)+EMA(C,6)+EMA( C,7))/3,3),DRAWNULL),COLORCYAN,LINETHICK3;{COLOR1030FF;}
A4:=IF(K2!=2, EMA((EMA(C,7)+EMA(C,9)+EMA( C,11))/3,3),DRAWNULL),COLOR1040FF;
A5:=IF(K2!=2, EMA((EMA(C,9)+EMA(C,11)+EMA( C,13))/3,3),DRAWNULL)COLOR1050FF;
A6:=IF(K2!=2, EMA((EMA(C,11)+EMA(C,13)+EMA( C,15))/3,3),DRAWNULL)COLOR1060FF;
A7:=IF(K2!=2, EMA((EMA(C,13)+EMA(C,15)+EMA( C,17))/3,3),DRAWNULL)COLOR1070FF;
A8:=IF(K2!=2, EMA((EMA(C,15)+EMA(C,17)+EMA( C,19))/3,3),DRAWNULL)COLOR1080FF;
A9:=IF(K2!=2, EMA((EMA(C,17)+EMA(C,19)+EMA( C,21))/3,3),DRAWNULL),COLORLIMAGENTA;{COLOR1080EF;}
A10D:=IF(K2!=2, EMA((EMA(C,19)+EMA(C,21)+EMA( C,23))/3,3),DRAWNULL),COLORLIMAGENTA;{COLOR10C0FF;}
{A11D:IF(K2!=2, EMA((EMA(C,21)+EMA(C,23)+EMA( C,25))/3,3),DRAWNULL),COLORWHITE,LINETHICK2;
A15D:IF(K2!=2, A-(A1-A*0.987),DRAWNULL),COLORWHITE,LINETHICK2;{COLORFF0000;原997}
A16D:=IF(K2!=2, A-(A2-A),DRAWNULL)COLORFE2525;{A16D--A23D隐去。}
A17D:=IF(K2!=2, A-(A3-A),DRAWNULL)COLORFD3030;
A18D:=IF(K2!=2, A-(A4-A),DRAWNULL)COLORFC4030;
A19D:=IF(K2!=2, A-(A5-A),DRAWNULL)COLORFB5030;
A20D:=IF(K2!=2, A-(A6-A),DRAWNULL)COLORFA6030;
A21D:=IF(K2!=2, A-(A7-A),DRAWNULL)COLORF97030;
A22D:=IF(K2!=2, A-(A8-A),DRAWNULL)COLORF88030;
A23D:=IF(K2!=2, A-(A9-A),DRAWNULL)COLORF7A030;
A11D:=IF(K2!=2, EMA((EMA(C,21)+EMA(C,23)+EMA( C,25))/3,3),DRAWNULL),COLORWHITE,LINETHICK2;
A15D:IF(K2!=2, A-(A1-A*0.977),DRAWNULL),COLORCYAN,LINETHICK2;{COLORFF0000;原997}
A24D:=IF(K2!=2, A-(A10D-A),DRAWNULL)COLORF6D030;
A25D:=IF(K2!=2, A-(A11D-A*0.987),DRAWNULL)COLORF5F030;{原997}
AK2:=IF(K2=2,EMA((EMA(C,5)+EMA(C,7)+EMA( C,9))/3,3),DRAWNULL);
AK1:=IF(K2=2,A-(A1-A*0.987),DRAWNULL);{原997}
DRAWBAND(AK2,RGB(250,250,250),EMA((EMA(C,1)+EMA(C,3)+EMA(C,5))/3,3),RGB(250,00,00));
DRAWBAND(AK1,RGB(250,250,0),A-(A2-A),RGB(00,00,250));
DRAWNUMBER(ISLASTBAR AND BBB>3,HC,幅2);
DRAWNUMBER(ISLASTBAR AND AAB>3,LC+(HC-LC)*0.05,幅1);
{古道西风主图 K=12 P=4 K2=0(0-2) K3=8}
{DRAWGBK(CLOSE>0,RGB(20,58,120),RGB(1,2,3),0,61,0);}
YM:=EMA(SLOPE((CLOSE+HIGH+LOW)/3,24)*20+(CLOSE+HIGH+LOW)/3,40);
YM1:=EMA(YM,1),NODRAW;{3}
YM2:=EMA(YM1,2),NODRAW;{7}
DRAWBAND(YM1,RGB(240,120,80),YM2,RGB(40,240,50));{变色条。原参数:200,80,50;压力+支撑线}
{下插操作线}
B:=SMA(CLOSE,17,1)*2-REF(SMA(CLOSE,17,1),1);
分水岭:=SMA(IF(MA(CLOSE,17)<B,B,MA(CLOSE,17)),3,1);
操作线:SMA(分水岭-(MA(C,3)-分水岭),2,1),COLOR66FF16,LINETHICK2;
{M5上穿操作线变黄色}
OUTF:=CROSS(M5,操作线);
IF(M5>REF(操作线,1),操作线,DRAWNULL),COLORYELLOW,LINETHICK3;
DRAWICON(OUTF,L*1.1,19);
OUT1:=CROSS(M5,A15D);
IF(M5>REF(A3,1),A3,DRAWNULL),COLORYELLOW,LINETHICK3;{黄金支撑线}
DRAWICON(OUT1,L*1.1,13);
越过强势M60:=MA(C,60),COLORWHITE,LINETHICK1;{60日均线};

通达信飓风眼主图指标公式

 

相关文章