在线检测未来函数

通达信飞龙智能牛线指标公式

来源:Internet,编辑:股旁网,2019-02-20

80,COLOR996699;
20,COLORGREEN;
10,COLORCC6633,LINETHICK2;
90,COLOR9966FF,LINETHICK2;
30,COLOR9966FF,LINETHICK2;
{
50,COLORRED;
FILLRGN(1,20,80),COLOR222222;
FILLRGN(1,90,100),COLOR000068;
FILLRGN(1,79,90),COLOR663366;
FILLRGN(1,10,20),COLOR666600;
FILLRGN(1, 0,10),COLOR663300;
}
A:=MA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),19),COLORRED;
B:=-100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14));
D:=EMA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),4),LINETHICK2;
牛市线:A+100,LINETHICK2,COLORMAGENTA;
短期线:B+100,COLORBLACK;
中期线:D+100,COLORBLACK,LINETHICK1;
{见顶:(牛市线>85 OR REF(牛市线,1)>85 ) AND (CROSS(中期线,短期线) OR CROSS(REF(中期线,1),REF(短期线,1)) )AND CROSS(牛市线,短期线);
}
见顶:(REF(中期线,1)>85 AND REF(短期线,1)>85 AND REF(牛市线,1)>65) AND CROSS(牛市线,短期线) ;
顶部区域:(中期线<REF(中期线,1) AND REF(中期线,1)>80) AND (REF(短期线,1)>95 OR REF(短期线,2)>95 ) AND 牛市线>60 AND 短期线<83.5
AND 短期线<中期线 AND 短期线<牛市线+4;
顶部:=FILTER(顶部区域,4);
{DRAWICON( 见顶, 108, 2 );}
底部区域:(牛市线<12 AND 中期线<8 AND (短期线<7.2 OR REF(短期线,1)<5) AND (中期线>REF(中期线,1) OR 短期线>REF(短期线,1)))
OR (牛市线<8 AND 中期线<7 AND 短期线<15 AND 短期线>REF(短期线,1)) OR (牛市线<10 AND 中期线<7 AND 短期线<1) ;
STICKLINE( {见顶 OR} 顶部,99,103,10,1 ),COLORRED,LINETHICK2;
STICKLINE( 底部区域,-4,0,22,0 ),COLORGREEN;
低位金叉:牛市线<15 AND REF(牛市线,1)<15 AND 中期线<18 AND 短期线>REF(短期线,1) AND CROSS(短期线,牛市线) AND 短期线>中期线
AND (REF(短期线,1)<5 OR REF(短期线,2)<5 ) AND (中期线>=牛市线 OR REF( 短期线,1)<1 );
STICKLINE( 低位金叉,0,5,11,0 ),COLORRED;
DRAWTEXT(CROSS(牛市线,90),90,'风险区'),COLOR00FFFF;
DRAWTEXT(CROSS(牛市线,10),10,'建仓区'),COLORFF00FF;
DRAWTEXT(CROSS(牛市线,20),20,'低吸区'),COLORFF00FF;
DRAWTEXT(CROSS(牛市线,20),30,'强势区'),COLORFF00FF;

通达信飞龙智能牛线指标公式

 

相关文章