在线检测未来函数

通达信过均必牛主图指标公式

来源:Internet,编辑:股旁网,2019-02-21

DRAWTEXT_FIX(ISLASTBAR ,0.11,0.01,1,'所属地域板块------------'),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR ,0.16,0.01,1,DYBLOCK),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR ,0.11,0.06,1,'所属行业------------'),COLORCYAN;
DRAWTEXT_FIX(ISLASTBAR ,0.14,0.06,1,HYBLOCK),COLORCYAN;
DRAWTEXT_FIX(ISLASTBAR ,0.11,0.11,1,'所属概念------------'),COLORBLUE;
DRAWTEXT_FIX(ISLASTBAR ,0.24,0.11,1,GNBLOCK),COLORWHITE;
黄金线:EMA(C,18),COLORMAGENTA;
【有金矿】:=COUNT(CLOSE<黄金线,5)=4 AND CLOSE/黄金线>1.004 AND
CROSS(CLOSE,黄金线) AND 黄金线>=REF(黄金线,1),LINETHICK,COLORRED;
DRAWTEXT(【有金矿】,LOW*0.99,'↖【挖金子】'),COLORRED;
STICKLINE(【有金矿】,OPEN,CLOSE,3,0),COLORRED;
STICKLINE(【有金矿】,OPEN,CLOSE,1.1,0),COLORFF00FF;
STICKLINE(【有金矿】,OPEN,CLOSE,0.001,0),COLORWHITE;
A:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>=9.8/100;
STICKLINE(A,C,O,3,0),COLORYELLOW,LINETHICK2;
STICKLINE(A,H,L,0,0),COLORYELLOW,LINETHICK2;
STICKLINE(A AND CLOSE=OPEN AND HIGH=LOW,REF(CLOSE,1),H,0,0),COLORGREEN,LINETHICK1;
B:=(REF(CLOSE,1)-CLOSE)/CLOSE>=9.8/100;
STICKLINE(B,C,O,3,0),COLORWHITE,LINETHICK2;
STICKLINE(B,H,L,0,0),COLORWHITE,LINETHICK2;
STICKLINE(B AND CLOSE=OPEN AND HIGH=LOW,REF(CLOSE,1),H,0,0),COLORGREEN,LINETHICK1;
VAR1:=(2*CLOSE+HIGH+LOW+OPEN)/5;
A1:=(EMA(VAR1,14)+EMA(VAR1,14)+EMA(VAR1,14)+EMA(VAR1,14))/4;
IF(A1>=REF(A1,1),A1,DRAWNULL),COLORLIRED;
IF(A1<=REF(A1,1),A1,DRAWNULL),COLORGREEN,LINETHICK1;
A2:=EMA(A1,3);
IF(A2>=REF(A2,1),A2,DRAWNULL),COLORLIRED,LINETHICK2;
IF(A2<=REF(A2,1),A2,DRAWNULL),COLORGREEN,LINETHICK2;
A3:=EMA(A2,4);
IF(A3>=REF(A3,1),A3,DRAWNULL),COLORLIRED;
IF(A3<=REF(A3,1),A3,DRAWNULL),COLORGREEN;
MA1:=EMA(CLOSE,4);
IF(MA1>=REF(MA1,1),MA1,DRAWNULL ),COLORC0C0C0,LINETHICK1;
IF(MA1<=REF(MA1,1),MA1,DRAWNULL ),COLORBLUE,LINETHICK1;
MA2:=EMA(CLOSE,5);
IF(MA2>=REF(MA2,1),MA2,DRAWNULL ),COLORC0C0C0,LINETHICK3;
IF(MA2<=REF(MA2,1),MA2,DRAWNULL ),COLORBLUE,LINETHICK3;
MA3:=EMA(CLOSE,6);
IF(MA3>=REF(MA3,1),MA3,DRAWNULL ),COLORC0C0C0,LINETHICK1;
IF(MA2<=REF(MA3,1),MA3,DRAWNULL ),COLORBLUE,LINETHICK1;
A55:=EMA(A1,18);
IF(A55>=REF(A55,1),A55,DRAWNULL),COLORRED,LINETHICK1;
IF(A55<=REF(A55,1),A55,DRAWNULL),COLORFF00FF,LINETHICK1;
A56:=EMA(A55,3);
IF(A56>=REF(A56,1),A56,DRAWNULL),COLORRED,LINETHICK3;
IF(A56<=REF(A56,1),A56,DRAWNULL),COLORFF00FF,LINETHICK3;
A57:EMA(A55,5);
IF(A57>=REF(A57,1),A57,DRAWNULL),COLORRED,LINETHICK1;
IF(A57<=REF(A57,1),A57,DRAWNULL),COLORFF00FF,LINETHICK1;
STICKLINE(MA3>=A56 AND A56>=A2,A2,A56,4,0),COLORYELLOW;
STICKLINE(MA3>=A2 AND MA3<=A56,MA3,A2,4,0),COLORYELLOW;
DRAWTEXT(FILTER(MA3>=A2 AND MA3<=A56,10),L,' ↖【黄金堆】'),COLORYELLOW;
STICKLINE(MA3<=A56 AND A56<=A2,A2,A56,4,0),COLORWHITE;
STICKLINE(MA3<=A2 AND MA3>=A56,MA3,A2,4,0),COLORWHITE;
DRAWTEXT(FILTER(MA3<=A2 AND MA3>=A56,5),H,'【瓦斯坑】'),COLORGREEN;
过均必牛:SUM(CLOSE*VOL,FROMOPEN)/SUM(VOL,FROMOPEN),COLORYELLOW,DOTLINE;

通达信过均必牛主图指标公式

 

相关文章