在线检测未来函数

通达信干净又详实的主图指标公式

来源:Internet,编辑:股旁网,2019-03-04

DRAWKLINE(H,O,L,C);
MA5:MA(CLOSE,5);
MA10:MA(CLOSE,10);
MA20:MA(CLOSE,20);
MA60:MA(CLOSE,60);
MA120:=MA(CLOSE,120);
AA05:=MA(C,5);
WRGLL:=(C-AA05)/AA05*100;
BB05:=ATAN((AA05/REF(AA05,1)-1)*100)*180/3.1416;
SD5:=SMA(EMA((AA05-REF(AA05,1))/REF(AA05,1),3)*100,3,1);
JSD5:=EMA((SD5-REF(SD5,1)),3);
AA10:=MA(C,10);
AA30:=MA(C,30);
SXRGLL:=(C-AA30)/AA30*100;
JC:=CROSS(0,WRGLL) AND SXRGLL<REF(SXRGLL,1) AND AA10>REF(AA10,1);
MR:=COUNT(CROSS(WRGLL,0),3)>=1 AND SXRGLL>REF(SXRGLL,1) AND
AA05>REF(AA05,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<AA30;
MT1:=FILTER(MR,10);
MT2:=FILTER(COUNT(CROSS(BB05,30),5)>=1 AND AA05>REF(AA05,1) AND SXRGLL>REF(SXRGLL,1)
AND AA10>REF(AA10,1) AND JSD5>REF(JSD5,1) AND SD5>REF(SD5,1) ,10);
CT1:=FILTER(JC,10);
MT3:=CROSS(LOW,MA60);
QCUF:=NOT(MT3);
DRAWTEXT((MT1 OR MT2) AND QCUF,LOW*0.99,'←买'),COLORYELLOW;
DRAWTEXT((MT1 OR MT2) AND MT3,LOW*0.99,'←买'),COLORRED;
DRAWTEXT(CT1,HIGH*1.012,'←卖'),COLORCYAN;
ZT:=IF((C+0.005-REF(C,1))/REF(C,1)*100>=10 AND C=H,1,0);
MAN:=SUM(AMOUNT,1)/SUM(V,1)/100;
AA:=V/CAPITAL*100;A1:=REF(AA,1);A2:=REF(AA,2);A3:=REF(AA,3);
DJZ:=IF((C/REF(C,1)*100-100<=-4),1,0) AND IF((C/REF(C,1)*100-100>=-9.96),1,0) AND IF(MAN/REF(C,1)<-1.02,1,0) ;
STICKLINE(DJZ,OPEN,CLOSE,-1,0),,COLORGREEN;
STICKLINE(ZT,OPEN,CLOSE,-1,0),,COLORMAGENTA;
STICKLINE(ZT,H,L,0,0),COLORMAGENTA;
高:H,COLORWHITE,NODRAW;
低:L,COLORWHITE,NODRAW;
开:O,COLORWHITE,NODRAW;
收:C,COLORWHITE,NODRAW;
所属地域:DRAWTEXT_FIX(ISLASTBAR ,0.93,0,1,DYBLOCK),COLORWHITE;
所属行业:DRAWTEXT_FIX(ISLASTBAR ,0.88,0,1,HYBLOCK),COLORWHITE;
所属概念:DRAWTEXT_FIX(ISLASTBAR ,0.83,0,1,GNBLOCK),COLORWHITE;
SSTS:=STRCAT(CON2STR(FINANCE(42)/1,0),'天');
LTSZ:=STRCAT(CON2STR(FINANCE(40)/100000000,0),'亿');
YSTB:=STRCAT(CON2STR(FINANCE(44)/1,2),'%');
LRTB:=STRCAT(CON2STR(FINANCE(43)/1,2),'%');
DRAWTEXT_FIX(1,0.02,0,0,'上市:'),COLORWHITE;
DRAWTEXT_FIX(1,0.04,0,0,SSTS),COLORWHITE;
DRAWTEXT_FIX(1,0.08,0,0,'流通市值:'),COLORWHITE;
DRAWTEXT_FIX(1,0.115,0,0,LTSZ),COLORWHITE;
DRAWTEXT_FIX(1,0.15,0,0,'营收同比:'),COLORWHITE;
DRAWTEXT_FIX(1,0.185,0,0,YSTB),COLORWHITE;
DRAWTEXT_FIX(1,0.22,0,0,'利润同比:'),COLORWHITE;
DRAWTEXT_FIX(1,0.255,0,0,LRTB),COLORWHITE;
净资收益率:=(FINANCE(33)/FINANCE(34)*100);
主营利润率:=(FINANCE(23)/FINANCE(20)*100);
主营业增长率:=FINANCE(44);
每股净资产:=CONST(FINANCE(34));
每股收益:=CONST(FINANCE(38));
净利润增长率:=FINANCE(43);
市销率:=CONST(FINANCE(1)*DYNAINFO(7)/FINANCE(20));
现金负债比:=(FINANCE(25)/FINANCE(15));
每股未分配:=CONST(FINANCE(32));
每股公积金:=CONST(FINANCE(18));
SY01:=净资收益率>3;
SY02:=净资收益率>0.01 AND 净资收益率<=3;
SY03:=主营利润率>2;
SY04:=主营利润率>0;
SY05:=主营业增长率>1;
SY06:=主营业增长率>0;
SY07:=净利润增长率>2;
SY08:=净利润增长率>0.2;
SY09:=每股收益>0.01;
SY10:= 每股收益>0.001;
SY11:=每股净资产>2;
SY12:=每股净资产>0.01;
SY13:=每股未分配>0.5;
SY14:=每股未分配>0.001;
SY15:=每股公积金>0.5;
SY16:=每股公积金>0.002;
SY17:=每股未分配>=2 AND 每股公积金>=2;
SY18:=每股未分配<2 OR 每股公积金<2;
优秀:=SY01 AND SY03 AND SY05 AND SY07 AND SY09 AND SY11
AND SY13 AND SY15;
较好:=SY02 AND SY04 AND SY06 AND SY08 AND SY10 AND SY12
AND SY14 AND SY16;
一般:=NOT(优秀) AND NOT(较好);
DRAWTEXT_FIX(优秀 AND 较好=0,0.45,0,0,'综合评估基本面:优秀!'),COLORMAGENTA;
DRAWTEXT_FIX(较好,0.45,0,0,'综合评估基本面:较好!'),COLORRED;
DRAWTEXT_FIX(一般,0.45,0,0,'综合评估基本面:一般!'),COLORGREEN;
DRAWTEXT_FIX(SY17,0.55,0,0,'是否具备高送转潜力:是!'),COLORMAGENTA;
DRAWTEXT_FIX(SY18,0.55,0,0,'是否具备高送转潜力:否!'),COLORGREEN;

通达信干净又详实的主图指标公式

 

相关文章