在线检测未来函数

通达信多头出击主图及选股指标公式

来源:Internet,编辑:股旁网,2019-04-10

MA5:MA(C,5);
MA24:MA(C,24);
MA72:MA(C,72);
MA133:MA(C,133);
MA200:MA(C,200);
SAT:=(AMOUNT/C)/HHV((AMOUNT/C),30);
HSL:=IF((SETCODE==0||SETCODE==1),100*VOL,VOL)/(FINANCE(7)/100);
A1:=MAX(MAX(MAX(MA24,MA72),MA133),MA200);
A2:=MIN(MIN(MIN(MA24,MA72),MA133),MA200);
A3:=(MA24+MA72+MA133+MA200)/4;
A4:=(CROSS(C,A1)) OR (CROSS(C,MA5) AND MA5>A1) OR (CROSS(MA5,A1)) OR
(O<A1 AND C>A1 AND C>MA5) OR (O<MA5 AND C>MA5 AND MA5>A1);
A5:=REF(COUNT(NOT(C/REF(C,1)>1.09),5)=5,1) AND HSL>9 AND C/REF(C,1)>=1.098;
多头出击:=A1/A2<1.09 AND COUNT(A3>REF(A3,1),2)=2 AND MA5/A1<=1.02 AND (L/MA5<1.01 OR L/A1<1.01) AND
C/O>1.07 AND C>=O AND A4 AND SAT>0.99 AND V/REF(V,1)>1.93 AND
((COUNT(CROSS(MA5,A2),2)) OR (COUNT(CROSS(MA5,A2),9) AND MA(V,5)>MA(V,35) AND MA(V,35)>MA(V,135)));
STICKLINE(多头出击=1 ,A1,A2,1,0),COLORRED;
STICKLINE(A5 ,O,C,2,0),COLORYELLOW;

{
选股公式:

MA5:=MA(C,5);
MA24:=MA(C,24);
MA72:=MA(C,72);
MA133:=MA(C,133);
MA200:=MA(C,200);
SAT:=(AMOUNT/C)/HHV((AMOUNT/C),30);
A1:=MAX(MAX(MAX(MA24,MA72),MA133),MA200);
A2:=MIN(MIN(MIN(MA24,MA72),MA133),MA200);
A3:=(MA24+MA72+MA133+MA200)/4;
A4:=(CROSS(C,A1)) OR (CROSS(C,MA5) AND MA5>A1) OR (CROSS(MA5,A1)) OR
(O<A1 AND C>A1 AND C>MA5) OR (O<MA5 AND C>MA5 AND MA5>A1);
多头出击:A1/A2<1.09 AND COUNT(A3>REF(A3,1),2)=2 AND MA5/A1<=1.02 AND (L/MA5<1.01 OR L/A1<1.01) AND
C/O>1.07 AND C>=O AND A4 AND SAT>0.99 AND V/REF(V,1)>1.93 AND
((COUNT(CROSS(MA5,A2),2)) OR (COUNT(CROSS(MA5,A2),9) AND MA(V,5)>MA(V,35) AND MA(V,35)>MA(V,135)));
}

通达信多头出击主图及选股指标公式

 

相关文章