在线检测未来函数

通达信均线集中度指标公式

来源:Internet,编辑:股旁网,2019-04-12

{用法:市场行情趋向明显时,指标效果理想。PDI(上升方向线) MDI(下降方向线) ADX(趋向平均值)1.PDI线从下向上突破MDI线,显示有新多头进场,为买进信号;2.PDI线从上向下跌破MDI线,显示有新空头进场,为卖出信号;3.ADX值持续高于前一日时,市场行情将维持原趋势;4.ADX值递减,降到20以下,且横向行进时,市场气氛为盘整;5.ADX值从上升倾向转为下降时,表明行情即将反转。}

N:=14;
M:=6;
JX4:=MA(C,4);
JX8:=MA(C,8);
JX13:=MA(C,13);
JX20:=MA(C,20);
JX30:=MA(C,30);
JX34:=MA(C,34);
JX47:=MA(C,47);
JX55:=MA(C,55);
JX89:=MA(C,89);
JX144:=MA(C,144);
JX245:=MA(C,245);
JX318:=MA(C,318);
MAXJX144:=MAX(MAX(MAX(MAX(MAX(MAX(MAX(JX4,JX8),JX13),JX20),JX30),JX47),JX89),JX144);
MINJX144:=MIN(MIN(MIN(MIN(MIN(MIN(MIN(JX4,JX8),JX13),JX20),JX30),JX47),JX89),JX144);
MAXJX89:=MAX(MAX(MAX(MAX(MAX(MAX(JX4,JX8),JX13),JX20),JX30),JX47),JX89);
MINJX89:=MIN(MIN(MIN(MIN(MIN(MIN(JX4,JX8),JX13),JX20),JX30),JX47),JX89);
MAXJX47:=MAX(MAX(MAX(MAX(MAX(JX4,JX8),JX13),JX20),JX30),JX47);
MINJX47:=MIN(MIN(MIN(MIN(MIN(JX4,JX8),JX13),JX20),JX30),JX47);
MAXJX30:=MAX(MAX(MAX(MAX(JX4,JX8),JX13),JX20),JX30);
MINJX30:=MIN(MIN(MIN(MIN(JX4,JX8),JX13),JX20),JX30);
MAXJX20:=MAX(MAX(MAX(JX4,JX8),JX13),JX20);
MINJX20:=MIN(MIN(MIN(JX4,JX8),JX13),JX20);
MAXJX13:=MAX(MAX(JX4,JX8),JX13);
MINJX13:=MIN(MIN(JX4,JX8),JX13);
MAXJXCH144:=(MAXJX144-MINJX144)/MINJX144*100,COLORLIBLUE;
MAXJXCH89:=(MAXJX89-MINJX89)/MINJX89*100,COLORMAGENTA;
MAXJXCH47:=(MAXJX47-MINJX47)/MINJX47*100,COLORLIRED;
MAXJXCH30:=(MAXJX30-MINJX30)/MINJX30*100,COLORGREEN;
MAXJXCH13:=(MAXJX13-MINJX13)/MINJX13*100,COLORYELLOW;
MAXJXCH20:=(MAXJX20-MINJX20)/MINJX20*100,COLORYELLOW;
QMAXJXCH144:=IF(JX4>=JX144,MAXJXCH144,-MAXJXCH144),COLORLIBLUE;
QMAXJXCH89:=IF(JX4>=JX89,MAXJXCH89,-MAXJXCH89),COLORMAGENTA;
QMAXJXCH47:=IF(JX4>=JX47,MAXJXCH47,-MAXJXCH47),COLORLIRED;
QMAXJXCH30:=IF(JX4>=JX30,MAXJXCH30,-MAXJXCH30),COLORGREEN;
QMAXJXCH13:=IF(JX4>=JX13,MAXJXCH13,-MAXJXCH13),COLORYELLOW;
QMAXJXCH20:=IF(JX4>=JX20,MAXJXCH20,-MAXJXCH20),COLORLIBLUE;
JXJZDCH:QMAXJXCH13-QMAXJXCH30,COLORRED;
MAJXJZDCH:MA(JXJZDCH,N),COLORLIBLUE;
{STICKLINE(NDAY(MA8,MA55,1),25,27,4,0),COLORLIRED;
STICKLINE(NDAY(MA8,MA89,1),32,34,4,0),COLORMAGENTA;
STICKLINE(NDAY(MA8,MA144,1),39,41,4,0),COLORLIBLUE;
STICKLINE(NDAY(MA8,MA245,1),46,48,4,0),COLORBLUE;
STICKLINE(NDAY(MA8,MA318,1),53,55,4,0),COLORWHITE;
STICKLINE(NDAY(MA8,MA30,1),-5,-6,4,0),COLORGREEN;
STICKLINE(NDAY(MA4,MA30,1),-10,-11,4,0),COLORRED};
A:0,COLORWHITE;
A1:10,COLORGREEN;

通达信均线集中度指标公式

 

相关文章