在线检测未来函数

最终合成MACD之柱底背离选股指标公式

来源:Internet,编辑:股旁网,2020-09-16

本文选股公式根据以下股票公式改编:
http://www.gupang.com/202009/091A29112020.html

DIF:=100*(EMA(CLOSE,12)-EMA(CLOSE,26));
DEA:=EMA(DIF,9);
JC:=DEA-DIF;
绿柱:=IF(MACD<0,SUM(MACD,BARSLAST(JC<0)),0);
红柱:=IF(MACD>0,SUM(MACD,BARSLAST(JC>0)),0);
本次最低价:=LLV(L,BARSLAST(JC<0));
本次最高价:=HHV(H,BARSLAST(JC>0));
X1:=IF (MACD<0,BARSLAST(CROSS(DIF,DEA)),0);
前次绿柱:=REF(绿柱,X1+1);
前次最低价:=REF(本次最低价,X1+1);
Y1:=IF((绿柱<0 AND ABS(绿柱)<ABS(前次绿柱) AND 本次最低价<前次最低价),1,0);
底背驰:=IF (CROSS(DIF,DEA),REF(Y1,1),0);
柱底背离:底背驰;

最终合成MACD之柱底背离选股指标公式

 

相关文章