在线检测未来函数

通达信深海宝塔主图指标公式

来源:Internet,编辑:股旁网,2021-01-12

K:=2;
S:=2;
深海1:=EXPMA(CLOSE,6),COLORWHITE,LINETHICK1;
深海2:EXPMA(CLOSE,12),COLORWHITE,LINETHICK2;
深海3:EXPMA(CLOSE,50)COLORMAGENTA,LINETHICK4;
海:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4,COLORGREEN,LINETHICK2;
猎户:=(EMA(C,6)+EMA(C,18)+EMA(C,54)+EMA(C,162))/4,COLORMAGENTA,LINETHICK2;
深海:=MA(CLOSE,17)+ABS(MA(CLOSE,17)-REF(MA(CLOSE,17),1)),COLORLIMAGENTA,LINETHICK2;
幸福:=MA(CLOSE,17)+MA(CLOSE,17)-REF(MA(CLOSE,17),1),COLORGREEN,LINETHICK2;
快乐:=IF(MA(CLOSE,17)<幸福,幸福,MA(CLOSE,17)),COLORRED,LINETHICK2;
VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR3:=REF(VAR2,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR5:=REF(VAR4,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR7:=REF(VAR6,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR9:=REF(VAR8,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARA:=REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VARB:=REF(VARA,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VARD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
VARE:=REF(VARD,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR10:=REF(VARF,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR12:=REF(VAR11,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR14:=REF(VAR13,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR16:=REF(VAR15,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR18:=REF(VAR17,1) AND CLOSE>REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;
STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),3,1),COLORYELLOW;
VAR1A:=REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1) AND VARD;
STICKLINE(VAR1A,H,O,4,2),COLORWHITE{98FD};
健康:=LLV(LOW,34),LINETHICK1,COLORLIMAGENTA,NODRAW;
如意:IF(VAR19>0,MA(健康,4)*1.06,MA(健康,4)),LINETHICK1,COLORYELLOW;
DRAWBAND(健康,RGB(255,0,0),REF(健康*0.993,1),RGB(0,0,224));
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),4.1,1)/SMA(ABS(CLOSE-LC),4.1,1)*100;
VAR27:=REF(CLOSE,1);
VAR28:=SMA(MAX(CLOSE-VAR27,0),5.5,1)/SMA(ABS(CLOSE-VAR27),6,1)*100;
DRAWICON((IF(CROSS(76,VAR28),1,0)) OR CROSS(84,RSI),H*1.01,2);
VARA1:=((AMOUNT)/(VOL))/(100);
VARB1:=((3)*(HIGH)+LOW+OPEN+(2)*(CLOSE))/(7);
VARC1:=((SUM(AMOUNT,7))/(VARA1))/(100);
VARD1:=DMA(VARB1,(VOL)/(VARC1));
VARE1:=((CLOSE-VARD1)/(VARD1))*(100);
VARF1:=((CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)))*(100);
VARJ1:=MA(VARE1,20)+STD(VARE,20);
BIAS18:=((CLOSE-MA(CLOSE,18))/(MA(CLOSE,18)))*(100);
AA:=SMA(VARF1,3,1);
SS:=(REF(BIAS18,1)>=5) AND CROSS(VARJ1,VARE1) AND (AA>79);
TT:=240/FROMOPEN;
比:=TT;
促进指数MFL:=(HIGH-LOW)*1000000/(VOL*比),COLORRED;
AY2:=EMA(CLOSE,12)-EMA(CLOSE,26);
AZ2:=EMA(AY2,9);
LT2:=(AY2-AZ2);
L211:=IF(LT2,LLV(L,21),DRAWNULL),COLOR217158,CIRCLEDOT;
ZGD:=HHV(H,80)*0.99;
ZGD2:=CONST(ZGD);
ZDD:=LLV(L211,80);
ZDD2:=CONST(ZDD);
YYA4:=MA(CLOSE,20);
YYA5:=(CLOSE > MA(CLOSE,5));
YYA6:=(MA(CLOSE,5) > MA(CLOSE,10));
YYA7:=(CLOSE > MA(CLOSE,10));
YYA8:=(MA(CLOSE,5) > MA(CLOSE,20));
YYA9:=(CLOSE > MA(CLOSE,20));
YYA10:=REF(YYA4,1);
YYA11:=(YYA4 > YYA10);
YYAVX:=(((((IF(YYA5,10,(0 - 10)) + IF(YYA6,10,(0 - 10))) + IF(YYA7,10,(0 - 10))) + IF(YYA8,10,(0 - 10))) + IF(YYA9,10,(0 - 10))) + IF(YYA11,10,(0 - 10)));
DSLX:=(CLOSE / INDEXC);
DSLX1:=MA(DSLX,5);
DSLX2:=MA(DSLX,10);
YYV1:=MA(VOL,5);
YYV2:=MA(VOL,10);
J1:=CONST(IF( YYAVX > 0,200,100));
J2:=CONST(IF( YYAVX > 0,00,100));
J3:=CONST(IF( YYAVX > 0,100,100));
ZGD3:=IF(K=0,ZGD2,DRAWNULL);
ZDD3:=IF(K=0,ZDD2,DRAWNULL);
ZGD4:=IF(K=1,ZGD2,DRAWNULL);
情况1:=CONST(IF(((CROSS(YYAVX,1) AND (YYV1 >= YYV2)) AND (DSLX >= DSLX1)),1,0));
情况2:=CONST(IF(((CROSS(YYAVX,1) AND (YYV1 < YYV2)) AND (DSLX >= DSLX1)),1,0));
情况3:=CONST(IF(((CROSS(YYAVX,1) AND (YYV1 > YYV2)) AND (DSLX < DSLX1)),1,0));
情况4:=CONST(IF(((CROSS(YYAVX,1) AND (YYV1 <= YYV2)) AND (DSLX < DSLX1)),1,0));
情况5:=CONST(IF(((CROSS(1,YYAVX) AND (YYV1 >= YYV2)) AND (DSLX >= DSLX1)),1,0));
情况6:=CONST(IF(((CROSS(1,YYAVX) AND (YYV1 < YYV2)) AND (DSLX >= DSLX1)),1,0));
情况7:=CONST(IF(((CROSS(1,YYAVX) AND (YYV1 >= YYV2)) AND (DSLX < DSLX1)),1,0));
情况8:=CONST(IF(((CROSS(1,YYAVX) AND (YYV1 < YYV2)) AND (DSLX < DSLX1)),1,0));
情况9:=CONST(IF(((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 >= YYV2)) AND (DSLX >= DSLX1)),1,0));
情况10:=CONST(IF(((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 < YYV2)) AND (DSLX >= DSLX1)),1,0));
情况11:=CONST(IF(((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 >= YYV2)) AND (DSLX < DSLX1)),1,0)),NODRAW;
情况12:=CONST(IF(((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 < YYV2)) AND (DSLX < DSLX1)),1,0));
情况13:=CONST(IF(((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 >= YYV2)) AND (DSLX >= DSLX1)),1,0));
情况14:=CONST(IF(((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 < YYV2)) AND (DSLX >= DSLX1)),1,0));
情况15:=CONST(IF(((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 >= YYV2)) AND (DSLX < DSLX1)),1,0));
情况16:=CONST(IF(((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 < YYV2)) AND (DSLX < DSLX1)),1,0));
大盘1:=CONST(IF((CROSS(YYAVX,1) AND (YYV1 >= YYV2)),1,0));
大盘2:=CONST(IF((CROSS(YYAVX,1) AND (YYV1 < YYV2)),1,0));
大盘3:=CONST(IF((CROSS(1,YYAVX) AND (YYV1 >= YYV2)),1,0));
大盘4:=CONST(IF((CROSS(1,YYAVX) AND (YYV1 < YYV2)),1,0));
大盘5:=CONST(IF((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 >= YYV2)),1,0));
大盘6:=CONST(IF((((YYAVX >= 1) AND (REF(YYAVX,1) > 0)) AND (YYV1 < YYV2)),1,0));
大盘7:=CONST(IF((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 >= YYV2)),1,0));
大盘8:=CONST(IF((((YYAVX < 1) AND (REF(YYAVX,1) < 0)) AND (YYV1 < YYV2)),1,0));
WJ:=(H+L+C)/3;
V1:=IF(H=L,1,H-MAX(O,C));
V2:=IF(H=L,1,MAX(C,O)-WJ);
V3:=IF(H=L,1,MIN(O,C)-L);
V4:=IF(H=L,1,WJ-MIN(C,O));
V5:=VOL/IF(H=L,4,H-L);
V6:=(V1*V5);
V7:=(V2*V5);
V8:=(V3*V5);
V9:=(V4*V5);
买盘1:=DYNAINFO(23)*比;
卖盘1:=DYNAINFO(22)*比;
买盘2:=IF(ISLASTBAR AND C>300,(V9+V8)*TT,(V9+V8));
卖盘2:=IF(ISLASTBAR AND C>300,(V6+V7)*TT,(V6+V7));
买盘:=IF(ISLASTBAR AND PERIOD=5 AND C<300,买盘1,买盘2);
卖盘:=IF(ISLASTBAR AND PERIOD=5 AND C<300,卖盘1,卖盘2);
MFI:=(HIGH-LOW)*1000000/(VOL*比);
绿灯:=MFI>=REF(MFI,1)AND VOL*比>=REF(VOL,1);
M1:=CONST(绿灯);
衰退:=MFI<REF(MFI,1)AND VOL*比<REF(VOL,1);
M2:=CONST(衰退);
伪装:=MFI>=REF(MFI,1)AND VOL*比<REF(VOL,1);
M3:=CONST(伪装);
蛰伏:=MFI<REF(MFI,1)AND VOL*比>=REF(VOL,1);
M4:=CONST(蛰伏);
量大:=(卖盘+买盘)/REF(VOL,1)>2;
M5:=CONST(量大);
量缩:=REF(VOL,1)/(卖盘+买盘)>1.5;
M6:=CONST(量缩);
卖量大:=(卖盘-买盘)/买盘>0.4;
M7:=CONST(卖量大);
买量大:=(买盘-卖盘)/卖盘>0.4;
M8:=CONST(买量大);
TS1:=IF(M1=1,0.03+0.03,0.03);
TS2:=IF(M2=1,TS1+0.03,TS1);
TS3:=IF(M3=1,TS2+0.03,TS2);
TS4:=IF(M4=1,TS3+0.03,TS3);
TS5:=IF(M5=1,TS4+0.03,TS4);
TS6:=IF(M6=1,TS5+0.03,TS5);
TS7:=IF(M7=1,TS6+0.03,TS6);
TS8:=IF(M8=1,TS7+0.03,TS7);
VAR1Z:=EMA(CLOSE,4)-EMA(CLOSE,13);
AAZ:=VAR1Z>=REF(VAR1Z,1);
BB:=VAR1Z<REF(VAR1Z,1);
买入:=DRAWICON(CROSS(AAZ,BB),L,1);
卖出:=DRAWICON(CROSS(BB,AAZ),H,2);
STICKLINE(买入,O,(C-O)/2+O,3.5,0),COLOR335555;
STICKLINE(买入,O,(C-O)/2+O,2.2,0),COLOR338888;
STICKLINE(买入,O,(C-O)/2+O,1.5,0),COLOR33AAAA;
STICKLINE(买入,O,(C-O)/2+O,1,0),COLOR33CCCC;
STICKLINE(买入,O,(C-O)/2+O,0,0),COLOR33EEEE;
STICKLINE(卖出,O,(C-O)/2+O,3.5,0),COLOR550055;
STICKLINE(卖出,O,(C-O)/2+O,2.2,0),COLOR880088;
STICKLINE(卖出,O,(C-O)/2+O,1.5,0),COLORAA00AA;
STICKLINE(卖出,O,(C-O)/2+O,1,0),COLORCC00CC;
STICKLINE(卖出,O,(C-O)/2+O,0.5,0),COLOREE00EE;
DRAWTEXT(情况1=1 AND (CLOSE < 200) AND CURRBARSCOUNT=15,ZGD2-(ZGD2*0.03),'量能理想,明显走强,中线参与,仓位在2/3左右'),COLORFF00FF;
DRAWTEXT(情况2=1 AND (CLOSE < 200) AND CURRBARSCOUNT=15,ZGD2-(ZGD2*0.03),'走势趋强量能不足,短线进场,仓位在1/2左右'),COLORFF00FF;
DRAWTEXT(情况3=1 AND (CLOSE < 200) AND CURRBARSCOUNT=15,ZGD2-(ZGD2*0.03),'量价良好,并没有明显走强,短线进场,仓位1/2左右。'),COLORFF00FF;
DRAWTEXT(情况4=1 AND (CLOSE < 200) AND CURRBARSCOUNT=15,ZGD2-(ZGD2*0.03),'形态尚可,量能不足,未完全走强,短线参与,仓位1/3左右。'),COLORFF00FF;
DRAWTEXT(情况5=1 AND (CLOSE < 200) AND CURRBARSCOUNT=15,ZGD2-(ZGD2*0.03),'形态变坏,走势尚可,重仓减大半,清仓者观望。'),COLORFF0000;
DRAWTEXT(情况6=1 AND (CLOSE < 200) AND CURRBARSCOUNT=15,ZGD2-(ZGD2*0.03),'随大盘一起下跌,明显缩量走势,考虑大盘风险,减持或清仓。'),COLORFF0000;
DRAWTEXT(情况7=1 AND (CLOSE < 200) AND CURRBARSCOUNT=15,ZGD2-(ZGD2*0.03),'该股放量下跌,走势明显偏弱,离场观望。'),COLORFF0000;
DRAWTEXT(情况8=1 AND (CLOSE < 200) AND CURRBARSCOUNT=15,ZGD2-(ZGD2*0.03),'该股缩量下跌,走势偏弱,离场观望。'),COLORFFFF00;
DRAWTEXT(情况9=1 AND (CLOSE < 200) AND CURRBARSCOUNT=15,ZGD2-(ZGD2*0.03),'该股形态良好,强势明显,量能充足,可以继续持有。'),COLOR00FFFF;
DRAWTEXT(情况10=1 AND (CLOSE < 200) AND CURRBARSCOUNT=15,ZGD2-(ZGD2*0.03),'该股上行趋势不变,强势依然,但量能开始转弱,注意风险'),COLOR00FFFF;
DRAWTEXT(情况11=1 AND (CLOSE < 200) AND CURRBARSCOUNT=15,ZGD2-(ZGD2*0.03),'该股仍然具备上涨潜力,但股性偏弱,可考虑减仓。'),COLORFFFFFF;
DRAWTEXT(情况12=1 AND (CLOSE < 200) AND CURRBARSCOUNT=15,ZGD2-(ZGD2*0.03),'该股走势趋弱,量能不足,减持大部分筹码'),COLORFFFF00;
DRAWTEXT(情况13=1 AND (CLOSE < 200) AND CURRBARSCOUNT=15,ZGD2-(ZGD2*0.03),'该股形态不佳,注意成交量的变化,但目前不适合参与。'),COLORFFFF00;
DRAWTEXT(情况14=1 AND (CLOSE < 200) AND CURRBARSCOUNT=15,ZGD2-(ZGD2*0.03),'该股趋势不明,股价偏弱,注意量能变化,目前不宜参与。'),COLORFFFF00;
DRAWTEXT(情况15=1 AND (CLOSE < 200) AND CURRBARSCOUNT=15,ZGD2-(ZGD2*0.03),'有走强迹象,但量能不足,趋势不明,不适合操作'),COLORFFFF00;
DRAWTEXT(情况16=1 AND (CLOSE < 200) AND CURRBARSCOUNT=15,ZGD2-(ZGD2*0.03),'该股走势太弱,没有参与价值。'),COLORFFFFFF;
{DRAWTEXT(大盘1 AND (CLOSE >200) AND CURRBARSCOUNT=70,ZGD2-(ZGD2*0.03),'量能理想,2/3仓位, 前一轮下跌,最佳买点,否则谨慎介入。'),COLOR00FF00;
DRAWTEXT(大盘2 AND (CLOSE >200) AND CURRBARSCOUNT=70,ZGD2-(ZGD2*0.03),'趋强,量能不足,若前一轮下跌,短线进场1/2,量能放大加仓。'),COLORFF00FF;
DRAWTEXT(大盘3 AND (CLOSE >200) AND CURRBARSCOUNT=70,ZGD2-(ZGD2*0.03),'大盘形态走坏,重仓者可以减去大部分仓位。'),COLORAAAAAA;}
DRAWTEXT(大盘4 AND (CLOSE >200) AND CURRBARSCOUNT=15,ZGD2-(ZGD2*0.03),'大盘缩量调整,注意风险,短线清仓观望。'),COLORFF0000;
DRAWTEXT(大盘5 AND (CLOSE >200) AND CURRBARSCOUNT=15,ZGD2-(ZGD2*0.03),'大盘走势良好,量能理想,可以继续持有强势股。'),COLOR00FFFF;
{DRAWTEXT(大盘6 AND (CLOSE >200) AND CURRBARSCOUNT=70,ZGD2-(ZGD2*0.03),'大盘形态良好,但量能稍显不足,随时准备减仓'),COLOR00FF00;
DRAWTEXT(大盘7 AND (CLOSE >200) AND CURRBARSCOUNT=70,ZGD2-(ZGD2*0.03),'大盘趋势不明,注意成交量变化,目前不适宜进场。'),COLORFFFFFF;}
DRAWTEXT(大盘8 AND (CLOSE >200) AND CURRBARSCOUNT=15,ZGD2-(ZGD2*0.03),'大盘趋势向下,量能萎缩,不适合进场。'),COLORFFFFFF;
DRAWTEXT(M1 AND CURRBARSCOUNT=15,ZGD2-(ZGD2*TS1),'[绿灯]实际交易量增加。MFI促进指数增加。'),COLORFFFFFF;
DRAWTEXT(M2 AND CURRBARSCOUNT=15,ZGD2-(ZGD2*TS2),'[衰退]实际交易量减少。MFI促进指数减少。'),COLORGREEN;
DRAWTEXT(M3 AND CURRBARSCOUNT=15,ZGD2-(ZGD2*TS3),'[伪装]实际交易量减少。MFI促进指数增加。'),COLORGREEN;
DRAWTEXT(M4 AND CURRBARSCOUNT=15,ZGD2-(ZGD2*TS4),'[蛰伏]实际交易量增加。MFI促进指数减少。'),COLORYELLOW;
DRAWTEXT(M5 AND CURRBARSCOUNT=15,ZGD2-(ZGD2*TS5),'★预比昨量放大一倍以上;'),COLORGREEN;
DRAWTEXT(M6 AND CURRBARSCOUNT=15,ZGD2-(ZGD2*TS6),'★预比昨缩量一半以上;'),COLORYELLOW;
DRAWTEXT(M7 AND CURRBARSCOUNT=15,ZGD2-(ZGD2*TS7),'☆卖出量大于买入量40%以上;'),COLORGREEN;
DRAWTEXT(M8 AND CURRBARSCOUNT=15,ZGD2-(ZGD2*TS8),'☆买入量大于卖出量40%以上;'),COLORYELLOW;
DRAWICON(CROSS(RSI,11) ,L*0.99,1);
收盘价:=IF(C,CONST(C),DRAWNULL),COLORWHITE;
AAA2:=SUM(IF( CLOSE>REF(CLOSE,1),VOL*C,0),0);
AAA3:=SUM(IF( CLOSE<REF(CLOSE,1),VOL*C,0),0);
AAA4:=SUM(IF( CLOSE=REF(CLOSE,1),VOL*C,0),0);
BB1:=0;
B1万元:=DVOL*DCLOSE/100;
B1差:=B1万元-REF(B1万元,1);
B2万元:=DVOL*DCLOSE/100;
B2比:=B2万元/REF(B2万元,1);
净流入万元:=(AAA2-AAA3-0.5*AAA4);
PM:=MA(净流入万元,1);
PMA:=PM/REF(PM,1)>1;
PMB:=REF(PMA,1)<1 AND PMA;
密码:=(EMA(MA(B1万元,2),2))/100000,COLORYELLOW,NODRAW;
二日比:=密码/REF(密码,1);
选股:=PMB AND 密码>REF(密码,1) AND 二日比>1,COLORRED,NODRAW;
DRAWNUMBER(选股=1 ,L,密码),COLORYELLOW;
AA17:=EMA(C,14)COLORWHITE,LINETHICK1;
A17X:=(AA17-REF(AA17,1))/REF(AA17,1)*100,NODRAW;
参考线试买:IF(A17X>=0,REF(EMA(C,14),BARSLAST(CROSS(A17X,0))+1),DRAWNULL)COLORRED,LINETHICK2;
DRAWTEXT(ISLASTBAR,参考线试买,'----参考线试买------'),COLORYELLOW,LINETHICK4;
Y:=(H+L)/2;
AO:=MA(Y ,5 )-MA(Y ,34 );
DU0:=CROSS(AO,0);
UD0:=CROSS(0,AO);
TDU0:=BARSLAST(DU0);
TUD0:=BARSLAST(UD0);
DU3:=REF(DU0,1);
UD3:=REF(UD0,1);
TDU3:=BARSLAST(DU3);
TUD3:=BARSLAST(UD3);
年:=YEAR,NODRAW;
月:=MONTH,NODRAW;
星期:=WEEKDAY,NODRAW;
日:=DATETODAY(DATE);
上市日:=REF(DATE,TOTALBARSCOUNT-CURRBARSCOUNT);
自然日:=日-DATETODAY(上市日)+1;
ZB:=(自然日-REF(自然日,1))!=星期-REF(星期,1)
OR TOTALBARSCOUNT-CURRBARSCOUNT=0;
本周第几天:=BARSLAST(ZB)+1;
本月第几天:=BARSLAST(年*100+月!=REF(年*100+月,1))+1;
MA1:=REF(C,本周第几天);
MA2:=REF(MA1,本周第几天);
MA3:=REF(MA2,本周第几天);
MA4:=REF(MA3,本周第几天);
MA5:=REF(MA4,本周第几天);
MA6:=REF(MA5,本周第几天);
MA7:=REF(MA6,本周第几天);
MA8:=REF(MA7,本周第几天);
MA9:=REF(MA8,本周第几天);
十周价:=(C+MA1+MA2+MA3+MA4+MA5+MA6+MA7+MA8+MA9)/10;
出击突破:REFDATE(十周价,DATE),COLORFF0080,DOTLINE;
DRAWTEXT(ISLASTBAR,出击突破,'------------------- 出击突破'),COLORFF0080;
【0】:=MA(L+(H-L)/2,5),CIRCLEDOT,COLORMAGENTA;
【1】:=DRAWLINE(CURRBARSCOUNT=3,【0】,CURRBARSCOUNT=2,【0】,0),COLORYELLOW,LINETHICK2;
【2】:=DRAWLINE(CURRBARSCOUNT=2,【0】,CURRBARSCOUNT=1,【0】,0),COLORRED,LINETHICK2;
【3】:=DRAWLINE(CURRBARSCOUNT=3,【0】,CURRBARSCOUNT=1,【0】,0),COLORRED,LINETHICK2;
DRAWBAND(【1】,RGB(155,50,50),【3】,RGB(250,250,0));
DRAWBAND(【2】,RGB(100,50,50),【3】,RGB(250,100,0));
【4】:=REF(【0】,1);【5】:=REF(【0】,2);
DRAWTEXT(【0】>【4】 AND 【0】<【5】,【2】,'转强'),COLOR33FFCC;
DRAWTEXT(【0】>【4】 AND 【0】>【5】,【2】,'强市'),COLOR33FFCC;
DRAWTEXT(【0】<【4】 AND 【0】>【5】,【2】,'转弱'),COLOR33FFCC;
DRAWTEXT(【0】<【4】 AND 【0】<【5】,【2】,'弱市'),COLOR33FFCC;
PH:=TROUGHBARS(2,5,1);
LL:=HHV(H,PH);
TJ11:=LL=HIGH AND LL<REF(LL,1);{//=1}
TS:=SUMBARS(TJ11,2);
TJ:=PEAKBARS(2,5,1)=1 AND TS>=PH;
DRAWICON(TJ,HIGH*1.01+0.02,2);
PL:=BARSLAST(TJ);
HLCO:=(C+H+L+O)/4;
MAHC:=MA((CLOSE*2+H)/3,5),COLOR0000FF;
MAHO:=MA((O*2+H)/3,5),COLOR00FF00;
MALC:=MA((C+L*2)/3,5),COLORFFFFFF;
MALO:=MA((O+L*2)/3,5),COLOR00FFFF;
CO:=O+(C-O)/2;
STICKLINE(MAHC<MAHO AND (CROSS(C,MALO) OR CROSS(HLCO,MALO)),C,O,2.8,0),COLORWHITE;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.00,0.12,0,'--------------------白K关注,黄K买入,红K持股');
白色:= SMA(HIGH,21,2)*1.05,COLORWHITE;
突破1:=REF(EMA(C,14),1);
下轨:=SMA(LOW,21,2)*0.95,CIRCLEDOT,COLORFF6600;
SQS:=IF(MA(VOL,3)>MA(VOL,5)>MA(VOL,9),SMA(CLOSE,3,1),SMA(CLOSE,5,1)),COLORFF99FF,LINETHICK3;
做:=CROSS(SQS,突破1);
STICKLINE(做,H,L,1,0),COLORWHITE;
DRAWTEXT(CROSS(SQS,突破1) AND 白色>REF(白色,1),下轨,'加买'),COLORYELLOW;
A1:=(CLOSE+HIGH+LOW)/3;
A2:=EMA(A1,3);
A3:=REF(A2,1);
A4:=IF(A2>A3,A2,DRAWNULL);
A5:=IF(A2<=A3,A2,DRAWNULL);
STICKLINE(CROSS(C,REF(A5,1)),REF(A5,1)*1.002,REF(A5,1),20,0),COLORRED;
DRAWTEXT(CROSS(REF(A4,1),C) AND A4,H,'↓开跌'),COLORGREEN;
QW1:=(H+L+C*2)/4;
QW3:=EMA(QW1,10);
QW4:=STD(QW1,10);
QW5:=(QW1-QW3)*100/QW4;
QW6:=EMA(QW5,5);
RK7:=EMA(QW6,10);
{黑棒佳丽战法-牛股洗盘}
假阴线:DRAWTEXT(O>MA(C,20) AND (O-C)/O*100>0.01 AND VOL/CAPITAL*100 >=3 AND C>REF(C,1),L-0.08,'←洗'),COLORWHITE;
XA:=REF(C,1)/REF(C,3)>=1.2 AND O/REF(C,1)<=1.01 AND L<REF(C,1) AND C/REF(C,1)>1.05;
启动1:=XA AND COUNT(XA,4)=1;
STICKLINE(启动1,O,C,2.5,0),COLORYELLOW;
DRAWICON(启动1,L,24);
DRAWICON(启动1,L*0.97,25);
DRAWICON(启动1,L*0.94,26);
DRAWTEXT(启动1,L*0.92,'↖涨停风暴'),COLORYELLOW;
{N字霸气多空博弈能量潮拐点主图}
CY:=BARSLAST(CURRBARSCOUNT=100);
DD:=CONST(IF(ISLASTBAR=1,LLV(L,CY),0));
SAT:=IF((AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100>100,100,(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100);
AA10:MA(CLOSE,0),COLOR0000FF;
AA12:MA(CLOSE,0),COLOR0000FF;
BB10:=((ATAN((AA10 - REF(AA10,1))) * 3.1416) * 10);
BB12:=((ATAN((AA12 - REF(AA12,1))) * 3.1416) * 10);
MA13:=MA(CLOSE,13);
X1:=(C+L+H)/3;BB13:=ATAN(EMA(X1,13)-REF(EMA(X1,13),1))*3.1416*10;
EMA8:=EMA(C,8);
DRAWTEXT(FILTER(BB13>1 AND EMA(X1,13)>REF(EMA(X1,8),1),10),EMA8,'能量潮拐点'),COLOR007FFF;
DRAWBAND(IF(CURRBARSCOUNT<=100,DD+MACD*1.5,DRAWNULL),RGB(230,12,12),DD,RGB(10,30,230));
DRAWBAND(IF(CURRBARSCOUNT<=100,DD+MACD*1.5,DRAWNULL),RGB(230,30,12),DD,RGB(10,200,30));
IF(CURRBARSCOUNT<100,DD+MACD*1.5,DRAWNULL),COLORYELLOW;

通达信深海宝塔主图指标公式

 

相关文章