在线检测未来函数

同花顺桃花五线谱指标公式

来源:Internet,编辑:股旁网,2021-06-17

顶:100;
警:80,color000000;
示:90,color000000;
ZLCM:=EMA(WINNER(C)*70,3);
SHCM:=EMA((WINNER(C*1.1)-WINNER(C*0.9))*80,3);
ZSHTL:=EMA(SHCM/(ZLCM+SHCM)*100,2);
ZZLKP:=EMA(ZLCM/(ZLCM+SHCM)*100,2);
ZZLKP3:=EMA(EMA(ZZLKP,2),2);
ZZLKP5:=MA(ZZLKP,7);
ZCMZL:=MA(ZLCM+SHCM,13);
ZCMZL3:=MA(ZCMZL,5);
ZZNTS:=BARSLAST(ZSHTL<90 AND REF(ZSHTL,1)>90);
ZSHJJ:=EMA(ZSHTL,89);
SH8:=EMA(ZSHJJ,8);
ZZLJJ:=EMA(ZZLKP,89);
ZJLRQD:=INTPART(ZZLKP-ZZLJJ);
ZJLRQD3:=EMA(ZJLRQD,3);
DKB:=IF(ZZLKP-REF(ZZLKP,1)>ZSHTL-REF(ZSHTL,1),1,0);
DIFF:=(ZZLKP-ZSHTL)/10;
资金:= MA(ZZLKP-REF(ZZLKP,1),2)-MA(ZSHTL-REF(ZSHTL,1),2);
ZZL:=EMA(ZZLKP-ZZLKP5,2);
强:=EMA((C-REF(C,1))/C*10,2);
差A:=3*EMA(EMA(EMA(EMA(强,2),2),2),2),NODRAW;
参数:=IF(C>500,25,5);
净流:=3* EMA(EMA(EMA(EMA(差A,1),2),2),2)*参数;
净流3:=EMA(净流,3);
STICKLINE(C>MA(C,25) AND ZZL>REF(ZZL,1) AND ZJLRQD>0 AND 净流3>0,90,80,9,0),color1111FF;
STICKLINE(C>MA(C,25) AND ZZL>0 AND 净流>REF(净流,1) AND 净流>0 AND ZZLJJ>REF(ZZLJJ,1),90,80,9,0),COLOR0000BB;
STICKLINE(ZZL>REF(ZZL,1) AND 资金>0,95,91,9,0),color1111FF;
STICKLINE(DKB AND ZZL>REF(ZZL,1) AND 资金>0,95,91,9,0),COLOR0000BB;
RHL:=(O+H+L+3*C+REF(C,1))/7;
RLC:=REF(RHL,1);
RSI1:=SMA(MAX(RHL-RLC,0),9,1)/SMA(ABS(RHL-RLC),9,1)*100,colorred;
RSI2:=SMA(MAX(RHL-RLC,0),12,1)/SMA(ABS(RHL-RLC),12,1)*100,colorgreen;
RSI3:=SMA(MAX(RHL-RLC,0),24,1)/SMA(ABS(RHL-RLC),24,1)*100,colorblue;
STICKLINE(RSI1>RSI2,100,96,9,0),color1111FF;
STICKLINE(RSI1>RSI2 AND RSI2>RSI3,100,96,9,0),color0000BB;
半:50,colorgray;
界:30,colorwhite;
介入平台:=0;
//STICKLINE(C,介入平台,介入平台+净流,8,0),colorgreen;
//{绿}
STICKLINE(C,介入平台,介入平台+净流,9,0),COLOR00AA00;
STICKLINE(C,介入平台,介入平台+净流,5,0),COLOR00CE00;
STICKLINE(C,介入平台,介入平台+净流,3,0),COLOR00F700;
STICKLINE(C,介入平台,介入平台+净流,1,0),COLOR2DFF2D;
//STICKLINE(净流>0,介入平台,介入平台+净流,8,0),coloryellow;
//{黄}
STICKLINE(净流>0,介入平台,介入平台+净流,9,0 ),COLOR00C4C4;
STICKLINE(净流>0,介入平台,介入平台+净流,5,0 ),COLOR00EAEA;
STICKLINE(净流>0,介入平台,介入平台+净流,3,0 ),COLOR0BFFFF;
STICKLINE(净流>0,介入平台,介入平台+净流,1,0 ),COLOR46FFFF;
//STICKLINE(净流>REF(净流,1)AND 净流<0,介入平台,介入平台+净流,8,0),colorred;
//{红}
STICKLINE(净流>REF(净流,1)AND 净流<0,介入平台,介入平台+净流,9 ,0 ),COLOR0000BB;
STICKLINE(净流>REF(净流,1)AND 净流<0,介入平台,介入平台+净流,5 ,0 ),COLOR0000F0;
STICKLINE(净流>REF(净流,1)AND 净流<0,介入平台,介入平台+净流,3,0 ),COLOR1111FF;
STICKLINE(净流>REF(净流,1)AND 净流<0,介入平台,介入平台+净流,1 ,0 ),COLOR3535FF;
//STICKLINE(净流>REF(净流,1)AND 净流>0,介入平台,介入平台+净流,8,0),colormagenta;
//{紫}
STICKLINE(净流>REF(净流,1)AND 净流>0,介入平台,介入平台+净流,9,0 ),COLOR9B009B;
STICKLINE(净流>REF(净流,1)AND 净流>0,介入平台,介入平台+净流,5,0 ),COLORCA00CA;
STICKLINE(净流>REF(净流,1)AND 净流>0,介入平台,介入平台+净流,3,0 ),COLORF000F0;
STICKLINE(净流>REF(净流,1)AND 净流>0,介入平台,介入平台+净流,1,0 ),COLORFF28FF;
主力:ZZLKP,colorred;
散户:ZSHTL,colorwhite;
XG1:= ZJLRQD>ZJLRQD3 AND ZZLJJ>REF(ZZLJJ,1);
XG2:=(ZZL>0 AND ZZL>REF(ZZL,1)) OR(ZJLRQD>0 AND ZZL>0 AND ZZL>REF(ZZL,1));
XG3:= 净流>REF(净流,1)AND 净流>0;
XG4:=DIFF>REF(DIFF,1) AND DIFF>0;
XG5:= 净流> 0 AND EMA(资金,3)>0;
STICKLINE(ZSHTL>=90,-10,-5,9,0),COLOR66FFCC;
STICKLINE(ZZLJJ>REF(ZZLJJ,1),ZZLKP,ZZLJJ,4,0),color0000BB;
STICKLINE(ZJLRQD-ZJLRQD3>0 AND ZZLJJ>REF(ZZLJJ,1),ZZLKP,ZZLJJ,8,0),color0000BB;
STICKLINE(ZZLJJ<REF(ZZLJJ,1),ZSHTL,ZSHJJ,4,0),colorblue;
STICKLINE((ZJLRQD>ZJLRQD3 OR 净流>REF(净流,1)) AND ZZL>0 AND ZZLJJ<REF(ZZLJJ,1),ZSHTL,ZSHJJ,8,0),color00AA00;
STICKLINE(DIFF>0 AND ZZLJJ>REF(ZZLJJ,1),ZZLKP,ZZLJJ,4,0),colorgray;
MADIFF:=EMA(EMA(DIFF,2),2);
//STICKLINE(MADIFF>REF(MADIFF,1) AND DIFF>0 AND ZZLJJ>REF(ZZLJJ,1),ZZLKP,ZZLJJ,4,0),colormagenta;
//STICKLINE(MADIFF>REF(MADIFF,1) AND DIFF>0 AND ZZLJJ>REF(ZZLJJ,1),ZZLKP,ZZLJJ,7,0),colormagenta;
STICKLINE((MADIFF>REF(MADIFF,1) OR MADIFF>REF(MADIFF,1)) AND DIFF>0 AND ZZLJJ>REF(ZZLJJ,1),ZZLKP,ZZLJJ,9,0 ),COLOR9B009B;
STICKLINE((MADIFF>REF(MADIFF,1) OR MADIFF>REF(MADIFF,1)) AND DIFF>0 AND ZZLJJ>REF(ZZLJJ,1),ZZLKP,ZZLJJ,5,0 ),COLORCA00CA;
STICKLINE((MADIFF>REF(MADIFF,1) OR MADIFF>REF(MADIFF,1)) AND DIFF>0 AND ZZLJJ>REF(ZZLJJ,1),ZZLKP,ZZLJJ,3,0 ),COLORF000F0;
STICKLINE((MADIFF>REF(MADIFF,1) OR MADIFF>REF(MADIFF,1)) AND DIFF>0 AND ZZLJJ>REF(ZZLJJ,1),ZZLKP,ZZLJJ,1,0 ),COLORFF28FF;
LOWV:=LLV(L,9);
HIGHV:=HHV(H,9);
RSV:=EMA((C-LOWV)/(HIGHV-LOWV)*100,3);
K:=EMA(RSV,3),coloryellow;
D:=MA(K,3),colorblue;
STICKLINE(K>D , K,D ,8,0),colorcyan;
//STICKLINE(ZJLRQD>0 AND ZJLRQD>ZJLRQD3 AND K>D , K,D ,8,0),coloryellow;
STICKLINE(ZJLRQD>0 AND ZJLRQD>ZJLRQD3 AND K>D , K,D,9,0 ),COLOR00C4C4;
STICKLINE(ZJLRQD>0 AND ZJLRQD>ZJLRQD3 AND K>D , K,D,5,0 ),COLOR00EAEA;
STICKLINE(ZJLRQD>0 AND ZJLRQD>ZJLRQD3 AND K>D , K,D,3,0 ),COLOR0BFFFF;
STICKLINE(ZJLRQD>0 AND ZJLRQD>ZJLRQD3 AND K>D , K,D,1,0 ),COLOR46FFFF;
STICKLINE(D>K,K,D,8,0),colorblue;
老兵:IF(C>MA(C,25) AND ZZLKP>ZSHTL AND K>D AND 净流>REF(净流,1),70,0),colorwhite;
LC:=REF(C,1);
RSI5:=((SMA(MAX((C - LC),0),5,1) / SMA(ABS((C - LC)),5,1)) * 100);
TR1:=SUM(MAX(MAX((H - L),ABS((H - REF(C,1)))),ABS((L - REF(C,1)))),10);
HD:=(H - REF(H,1));
LD:=(REF(L,1) - L);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);
PDI:=((DMP * 100) / TR1);
MDI:=((DMM * 100) / TR1);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);
AV:=(RSI5 + ADX);
DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);
0,COLORFF00FF;
WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,13) - LLV(LOW,13)));
NEWVOL:=(RSI5 - WR10);
阶段底部:=(AV + NEWVOL);
趋势线:=LLV(阶段底部,1),colorwhite,LINETHICK0;
STICKLINE(CROSS(阶段底部,0),0,20,10,1),LINETHICK6,colorred;
STICKLINE((趋势线 >230 ),100,80,10,1),LINETHICK6,colorgreen;

同花顺桃花五线谱指标公式

 

相关文章