在线检测未来函数

同花顺RSI黄金分割指标公式

来源:Internet,编辑:股旁网,2021-08-23

RSV:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
K:=SMA(RSV,3,1);
D:=Sma(K,3,1);
J:=3*K-2*D;
RSV24:=(CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100;
K24:=SMA(RSV24,3,1);
D24:=SMA(K24,3,1);
J24:=3*K24-2*D24;
压力位:IF(crOSS(J24,J),H,REF(H,BArslAst(CROSS(J24,J)))),colorliblue,LINETHICK1;
支撑位:IF(CROSS(J,J24),L,REF(L,BARSLAST(CROSS(J,J24)))),coloryellow ,LINETHICK1;
阻力价:HHV(HIGH,34),COLORFF9900,COLOR00FF33,LINETHICK2;
支撑价:LLV(LOW,34) ,COLOR7FFF00,colorred,LINETHICK2;
DRAWTEXT(C-O>0AND O/L>1.05AND L<=LLV(L,76),L,'★<--极品绝底'), LINETHICK1;
分时浪:zig(3,5),colorwhite, LINETHICK2;
GG:=ema(分时浪,2);
趋势浪:ZIG(3,10),colorblue, LINETHICK2;
HH:=EMA(趋势浪,2);
DRAWTEXT(CROSS(HH,趋势浪),H,'~卖'),COLOR00FF00;
DRAWTEXT(CROSS(趋势浪,HH),L,'~买'),COLOR0000FF;
DRAWICON(CROSS(分时浪,GG),L,"BUY" );
DRAWICON(CROSS(GG,分时浪),H,"SELL");
LC:=REF(CLOSE,1);
rsi:SMA(MAX(CLOSE-LC,0),14,1)/SMA(Abs(CLOSE-LC),14,1)*100;
压力:=HHV(MA(RSI,3),10),colorred;
支撑:=LLV(MA(RSI,3),10),coloryellow;
DRAWLINE(RSI=HHV(RSI,60),HHV(RSI,3),RSI=HHV(RSI,30) AND RSI<HHV(RSI,45),HHV(RSI,3),1),coloryellow;
DRAWLINE(RSI>=HHV(RSI,30),RSI,RSI<=LLV(RSI,10),HHV(RSI,6),1),colorred;
AB:DRAWLINE(RSI>=HHV(RSI,10),RSI,RSI<=LLV(RSI,3),HHV(RSI,3),1),coloryellow;
DRAWLINE(RSI<=LLV(RSI,120),RSI,HHV(RSI,6)<=HHV(RSI,10),LLV(RSI,6),1),colorblue;
VA11:=RSI>=HHV(RSI,20);
CRSI:="RSI.RSI3#WEEK",COLOR77EE00;
HRSI:=HHV("RSI.RSI1#WEEK",2);
金叉RSI:=STICKLINE(CROSS("RSI.RSI2#WEEK","RSI.RSI3#WEEK"),88,12,0.6,0);
VARA:=REF(CLOSE,1);
VARE:=SMA(MAX(CLOSE-VARA,0),6,1)/SMA(ABS(CLOSE-VARA),6,1)*100;
ARSI下:=STICKLINE(HRSI<=CRSI,HRSI,CRSI,0.1,1),COLOR00CC00,LINETHICK1;
VAR1:=(CLOSE*2+HIGH+LOW)/4;
SK:=EMA(VAR1,13)-EMA(VAR1,73);
SD:=EMA(SK,2);
XG:=((CROSS(SK,SD) AND SK<-0.04 AND (C-REF(C,1))/REF(C,1)>=0.03) OR (CROSS(SK,SD) AND SK<=-0.14 )
OR (CROSS(SK,SD) AND SK<=0.05 AND (V/MA(V,5)>2 OR C/REF(C,1)>0.035)) OR 金叉RSI);
STICKLINE(XG,88,12,0.6,0),COLOR0000FF;
DRAWTEXT(XG,38,'突破'),COLOR00FFBB;
折线:ZIG(3,20);
前波峰值:=PEAK(3,20,1);
前波谷值:=TROUGH(3,20,1);
DRAWNUMBER(折线>REF(折线,1) AND REF(折线,1)<REF(折线,2),REF(C,1),-(前波峰值-REF(C,1))/前波峰值*100);
DRAWNUMBER(折线<REF(折线,1) AND REF(折线,1)>REF(折线,2),REF(C,1),(REF(C,1)-前波谷值)/前波谷值*100);

同花顺RSI黄金分割指标公式

相关文章