在线检测未来函数

超实用波段之B选股指标公式

来源:Internet,编辑:股旁网,2021-10-21

本文选股公式根据以下股票公式改编:

https://www.gupang.com/202110/59076.html

X_1:=ema(CLOSE,12)-Ema(CLOSE,26);
X_2:=EMA(X_1,9);
X_3:=X_1>X_2;
X_4:=(CLOSE-LLV(LOW,12))/(HHV(HIGH,12)-LLV(LOW,12))*100;
X_5:=SMA(X_4,3,1);
X_6:=SMA(X_5,3,1);
X_7:=X_5>X_6;
X_8:=REF(CLOSE,1);
X_9:=SMA(MAX(CLOSE-X_8,0),9,1)/SMA(Abs(CLOSE-X_8),9,1)*100;
X_10:=SMA(MAX(CLOSE-X_8,0),26,1)/SMA(ABS(CLOSE-X_8),26,1)*100;
X_11:=X_9>X_10;
X_12:=SMA(X_4,3,1);
X_13:=SMA(X_12,3,1);
X_14:=X_12>X_13;
X_15:=(MA(CLOSE,3)+MA(CLOSE,9)+MA(CLOSE,12)+MA(CLOSE,26))/4;
X_16:=CLOSE>X_15;
X_17:=CLOSE-REF(CLOSE,1);
X_18:=100*EMA(EMA(X_17,9),9)/EMA(EMA(ABS(X_17),9),3);
X_19:=100*EMA(EMA(X_17,26),12)/EMA(EMA(ABS(X_17),26),12);
X_20:=X_18>X_19;
X_21:=dma((HIGH+LOW+CLOSE*2)/4,0.9);
X_22:=REF(EMA(X_21,3),1);
X_23:=vol/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
X_24:=IF(CLOSE>OPEN,X_23*(HIGH-LOW),IF(CLOSE<OPEN,X_23*(HIGH-OPEN+CLOSE-LOW),VOL/2))+IF(CLOSE>OPEN,0-X_23*(HIGH-CLOSE+OPEN-LOW),IF(CLOSE<OPEN,0-X_23*(HIGH-LOW),0-VOL/2));
X_25:=X_24/20/1.15;
X_26:=X_25*0.55+REF(X_25,1)*0.33+REF(X_25,2)*0.22;
X_27:=EMA(X_26,8);
X_28:=EMA(X_26,3);
X_29:=X_28;
X_30:=VOL;
X_31:=MA(X_30,5);
X_32:=MA(X_30,10);
X_33:=X_31>=X_32;
X_34:=X_29>=0;
X_35:=X_34 AND X_33;
X_36:=MA(kdj.K#WEEK(9,3,3),5);
X_37:=EMA(CLOSE,12/2)-EMA(CLOSE,26/2);
X_38:=EMA(X_37,9/2);
X_39:=X_36>=REF(X_36,1) AND X_37>=X_38;
X_40:=X_39 OR X_35;
X_41:=X_3 AND X_7 AND X_11 AND X_14 AND X_16 AND X_20;
X_42:=COst(50)*COST(50)/COST(80);
X_43:=COST(40)*COST(40)/COST(60);
X_44:=X_43-X_42;
X_45:=X_44>0 AND CLOSE>X_43;
X_46:=X_44<0 AND CLOSE>X_42;
X_47:=X_45 OR X_46 OR (X_45 AND X_46);
X_48:=X_47=0 OR (X_44>0 AND CLOSE>X_43 AND CLOSE<MA(CLOSE,10)) OR (X_44<0 AND CLOSE>X_42 AND CLOSE<MA(CLOSE,5));
X_49:=X_47 AND REF(X_48,1);
X_50:=X_48 AND REF(X_47,1);
B:X_47 OR X_41 AND REF(X_47 OR X_41,1)=0 AND X_40;

超实用波段之B选股指标公式

相关文章