在线检测未来函数

集合多种指标共振之一阳穿三线选股指标公式

来源:Internet,编辑:股旁网,2021-12-08

本文选股公式根据以下股票公式改编:

股旁网此处内容已被隐藏,请输入验证码查看内容。
验证码:
请关注本站微信公众号,回复“1005”,获取验证码。
提示:在微信里搜索“股旁网”或者微信扫描右侧二维码。

VAR1B := (100 * (ema(Ema(C - REF(C,1),6),6))) / (EMA(EMA(Abs(C - REF(C,1)),6),6));
抄底红箭 := ((LLV(VAR1B,2) = LLV(VAR1B,7)) AND (COUNT(VAR1B < 0,2))) AND crOSS(VAR1B,MA(VAR1B,2));
量能 := IF((MA((vol - REF(VOL,1)) / REF(VOL,1),10)) = DRAWNULL,EMA((VOL - REF(VOL,1)) / REF(VOL,1),10),MA((VOL - REF(VOL,1)) / REF(VOL,1),10));
股价 := IF(((CLOSE - MA(CLOSE,22)) / MA(CLOSE,22)) = DRAWNULL,(CLOSE - EMA(CLOSE,22)) / EMA(CLOSE,22),(CLOSE - MA(CLOSE,22)) / MA(CLOSE,22));
主力量能 := IF(((股价 * (100 + 量能)) - (MA(股价 * (100 + 量能),7))) = DRAWNULL,(股价 * (100 + 量能)) - (EMA(股价 * (100 + 量能),7)),(股价 * (100 + 量能)) - (MA(股价 * (100 + 量能),7)));
量能金叉 := CROSS(主力量能,0);
TYP := ((HIGH + LOW) + CLOSE) / 3;
cci := (TYP - MA(TYP,14)) / (0.015 * AVEDEV(TYP,14));
CCI金叉 := CROSS(CCI,-100);
A1 := EMA(C,14);
A1X := ((A1 - REF(A1,1)) / REF(A1,1)) * 100;
出击A := IF(A1X >= 0,REF(EMA(C,14),BArslAst(CROSS(A1X,0)) + 1),DRAWNULL);
出击A金叉 := CROSS(A1X,0);
difF := EMA(CLOSE,12) - EMA(CLOSE,26);
DEA := EMA(DIFF,9);
macd金叉 := CROSS(DIFF,DEA);
MTR := EXPMEMA(MAX(MAX(HIGH - LOW,ABS(HIGH - REF(CLOSE,1))),ABS(REF(CLOSE,1) - LOW)),14);
HD := HIGH - REF(HIGH,1);
LD := REF(LOW,1) - LOW;
DMP := EXPMEMA(IF((HD > 0) AND (HD > LD),HD,0),14);
DMM := EXPMEMA(IF((LD > 0) AND (LD > HD),LD,0),14);
pdi := (DMP * 100) / MTR;
mdi := (DMM * 100) / MTR;
ADX := EXPMEMA(((ABS(MDI - PDI)) / (MDI + PDI)) * 100,6);
ADXR := EXPMEMA(ADX,6);
X1 := MAX(C,O);
X2 := MIN(C,O);
X := ((REF(C > O,2)) AND (REF(X1,2) >= HHV(X1,2))) AND (REF(X2,2) <= LLV(X2,2));
B := BARSLAST(X) + 2;
A := ((REF(X1,B) >= HHV(X1,B)) AND (REF(X2,B) <= LLV(X2,B))) AND (EVERY(V <= REF(V,1),B));
肉夹馍 := (((REF(A,1) AND (C > O)) AND (C > REF(HHV(H,B),1))) AND (V > REF(HHV(V,B),1))) AND (EVERY(MA(C,5) > MA(C,10),B + 1));
平台起飞 :=IF(((LAST(((H - L) / REF(C,1)) < 0.1,5,0)) AND (VOL > (REF(VOL,1) * 2))) AND (C > (REF(C,1) * 1.05)),1,DRAWNULL),COLOR6060A0;
NH := 18;
LOWV := LLV(LOW,NH);
HIGHV := HHV(HIGH,NH);
MAV := MA(V,3);
横盘 := ((HIGHV - LOWV) / NH) < 0.15;
放量1 := V >= (1.8 * MAV);
今天大阳 := ((C - REF(C,1)) / REF(C,1)) >= 0.05;
启动 :=IF((横盘 AND 放量1) AND 今天大阳,1,DRAWNULL),COLOR4080FF;
A☆ := dma(((H + L) + (C * 2)) / 4,0.9);
B☆ := VOL / (((H - L) * 2) - (ABS(C - O)));
C☆☆ := (IF(C > O,B☆ * (H - L),IF(C < O,B☆ * ((H - O) + (C - L)),VOL / 2))) + (IF(C > O,0 - (B☆ * ((H - C) + (O - L))),IF(C < O,0 - (B☆ * (H - L)),0 - (VOL / 2))));
A☆☆ := (C☆☆ / 20) / 1.15;
攻击流量 := ((A☆☆ * 0.618) + (REF(A☆☆,1) * 0.382)) + (REF(HSL.HSL,2) * 0.168);
B☆☆ := EMA(攻击流量,3);
流量 := IF(B☆☆ > REF(B☆☆,1),1,0);
AA☆ := ((MAX(C,O) - MIN(C,O)) / MIN(C,O)) < 0.00618;
BB☆ := ((H - MAX(C,O)) / MAX(C,O)) > 0.00382;
DD☆ := ((MIN(C,O) - L) / L) > 0.00382;
EE☆ := ((ABS(BB☆ - DD☆)) / C) < 0.00618;
星☆星 := ((AA☆ AND BB☆) AND DD☆) AND EE☆;
星线选 := ((((星☆星 = 1) AND (流量 = 1)) AND (C > O)) AND ((ABS((C - MA(C,20)) / MA(C,20))) > 0.0382)) AND ((H - MAX(C,O)) <= (MIN(C,O) - L));
星线确认 := IF(((IF((REF(星线选,1) = 1) AND (C >= REF(C,1)),1,0)) AND (C > O)) AND (((C - REF(C,1)) / REF(C,1)) > 0.00618),1,DRAWNULL),COLORFF3399;
一阳穿三线 :=IF(((((CROSS(PDI,MDI) AND CROSS(PDI,ADX)) AND CROSS(PDI,ADXR)) AND (CLOSE > OPEN)) AND ((C / REF(C,1)) > 0.5)) AND (VOL > (MA(VOL,5) * 1.5)),1,DRAWNULL),COLOR800080;
STICKLINE(一阳穿三线,0,2.5,1.8,0),COLORB040B0;

集合多种指标共振之一阳穿三线选股指标公式

相关文章