在线检测未来函数

同花顺龙头操盘主图指标公式

来源:Internet,编辑:股旁网,2022-01-05

A:=(3*CLOSE+LOW+OPEN+HIGH)/6;
HJX21:=(21*A+20*REF(A,1)+19*REF(A,2)+18*REF(A,3)+17*REF(A,4)+16*REF(A,5)+
15*REF(A,6)+14*REF(A,7)+13*REF(A,8)+12*REF(A,9)+11*REF(A,10)+
10*REF(A,11)+9*REF(A,12)+8*REF(A,13)+7*REF(A,14)+6*REF(A,15)+
5*REF(A,16)+4*REF(A,17)+3*REF(A,18)+2*REF(A,19)+
REF(A,21))/231;
HJX3:=(3*A+2*REF(A,1)+REF(A,2))/6;
DC1:Ema(HJX3,4),colorlimagenta;
DC2:EMA(DC1,3),colorred;
DC3:EMA(DC1,7),colorred;
K1:=BacKSET(DC1<REF(DC1,1),2);
IF(K1,DC1,DRAWNULL)colorred,LINETHICK2;
K2:=BACKSET(DC2<REF(DC2,1),2);
IF(K2,DC2,DRAWNULL)colorred,LINETHICK2;
K3:=BACKSET(DC3<REF(DC3,1),2);
IF(K3,DC3,DRAWNULL)colorred,LINETHICK2;
DC4:EMA(HJX21,6),coloryellow,LINETHICK2;
DC5:EMA(HJX21,16),colorgreen,LINETHICK2;
DC6:EMA(HJX21,34),colorblue,LINETHICK2;
RSV:=(CLOSE-LLV(LOW,6))/(HHV(HIGH,6)-LLV(LOW,6))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
YX2:=D>REF(D,1);
YX3:=DC4>DC6 AND DC5>DC6;
YX4:=CLOSE>DC4 AND CLOSE/DC4<1.1;
YX5:=DC1>DC2 AND DC2>DC3;
XG:=YX2 AND YX3 AND YX4;
神彩飞扬培训:=XG AND COUNT(XG,10)=1 AND COUNT(YX5,10)<5;
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
macd:=2*(DIFF-DEA);
XG0:=crOSS(MACD,0);
XG1:=CROSS(CLOSE,DC1) AND CROSS(CLOSE,DC2) AND CROSS(CLOSE,DC3) AND BArslAst(XG0)<=5
AND CLOSE<DC4 ;
HJX:=EMA(HJX21,12);
ZF:=100*(CLOSE-REF(CLOSE,1))/REF(CLOSE,1);
TTUP:=HJX+2*STD(CLOSE,20);
TTDOWN:=HJX-2*STD(CLOSE,20);
HUP:=EMA(TTUP,3);
HDOWN:=EMA(TTDOWN,3);
LBRISE:=HUP/REF(HUP,1)>1.0035;
MIDRISE:=HJX>REF(HJX,1);
LBDOWN:=HDOWN<REF(HDOWN,1);
CLB1:=LOW/HUP<1.01 AND CLOSE/HUP>0.99 AND (OPEN+LOW)/2.1<HUP ;
KXT:=CLOSE>OPEN AND ((HIGH-CLOSE)+(OPEN-LOW))/(CLOSE-OPEN)<1.2 AND HIGH/CLOSE<1.035;
TDkd:=100*(HUP-HDOWN)/HJX;
TDXT:=TDKD<15 AND LLV(TDKD,8)<10;
XGG:=LBRISE AND MIDRISE AND CLB1 AND KXT AND TDXT;
CXG:=COUNT(XGG,20);
喇叭开口:=XGG AND CXG=1 AND COUNT(LBRISE,10)<10 AND HIGH/HHV(HIGH,5)>0.98;
DRAWTEXT(喇叭开口,LOW*0.99,'喇叭'),COLORFFFF00;
DRAWICON(CROSS(DC1,DC2),LOW*0.99,0);
DRAWICON(神彩飞扬培训,LOW*0.970,0);
DRAWICON(喇叭开口,LOW,0),COLORFFFF00;
VAR3:=LLV(HIGH,240);
VAR4:=100*(CLOSE-VAR3)/VAR3;
VAR5:=(CLOSE-LLV(LOW,528))/(HHV(HIGH,528)-LLV(LOW,528))*100;
VAR6:=(CLOSE-LLV(CLOSE,530))/(HHV(CLOSE,530)-LLV(CLOSE,530))*100;
VAR7:=0;
VAR8:=SMA(MAX(CLOSE-REF(CLOSE,1),0),34,1)/SMA(Abs(CLOSE-REF(CLOSE,1)),7,1)*100;
VAR9:=SMA(MAX(CLOSE-REF(CLOSE,1),0),13,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),13,1)*100;
VAR10:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0);
VAR11:=zig(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);
VAR12:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);
VAR13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);
VAR14:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);
VAR15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);
VAR16:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);
VAR17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);
VAR18:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);
VAR19:=EMA(CLOSE,2)-EMA(CLOSE,150);
买1:=VAR10;
买2:=(VAR11+VAR13+VAR15+VAR17);
卖1:=(VAR12+VAR14+VAR16+VAR18);
B:IF(买1>0 OR 买2>0,LOW*0.99,DRAWNULL),CROSSDOT,LINETHICK3,coloryellow;
DRAWTEXT(买1>0 OR 买2>0,LOW*0.99,'小仓位买入'),colorred;
S:IF(卖1>0,HIGH*1.01,DRAWNULL),CROSSDOT,LINETHICK3,colorgreen;
DRAWTEXT(卖1>0,HIGH*1.02,'庄家出货'),colorgreen;
涨停:=IF((C-REF(C,1))*100/REF(C,1)>=(10-0.01*100/REF(O,1)),1,0);
STICKLINE(涨停,O,C,1,0),coloryellow;
ZDF:=(C-REF(C,1))/REF(C,1)*100;
STICKLINE(ZDF<-9.9,O,C,1,0),colorblue;
AQ1:=REF(V,1);AQ2:=Dvol;AQ3:=AQ2/AQ1;
LNX:=AQ3-REF(AQ3,1);
E1:=REF(C,1);E2:=DCLOSE;E3:=(E2-E1)/E1*100;
QMX:=E3-REF(E3,1);
XXG:=CROSS(LNX,500) AND CROSS(QMX,10);
DRAWTEXT(XXG=1,L*0.955,'飞龙启动'),,colormagenta;
DRAWICON(XXG=1,L*0.993,25);
A0:=((L+H+C*2)/4);
LA:=BARSLAST(C>REF(C,1)*1.098);
LC:=REF(CLOSE,LA);
LO:=REF(OPEN,LA);
LAL:=REF(L,LA);
LAH:=REF(H,LA);
一涨停:=EVERY(C/REF(C,1)>=1.097 AND C=H,1);
双涨停:=EVERY(C/REF(C,1)>=1.097 AND C=H,2);
三涨停:=EVERY(C/REF(C,1)>=1.097 AND C=H,3) AND H>L;
策略1A:=EXIST((C/REF(C,2)-1)*100>20,2) AND COUNT(LC>LO,3)>=1 AND O<REF(C,1) AND C<REF(C,1) AND C>O AND C>REF(O,1) AND REF(C,1)>REF(C,2) ;
策略1B:=EXIST(双涨停,3) AND COUNT(LC>LO,4)>=1 AND O<REF(C,1) AND C<REF(C,1) AND C>O AND C>REF(O,1) AND REF(C,1)>REF(C,2) ;
DRAWTEXT(策略1A,LOW,'①'),coloryellow;
DRAWTEXT(策略1B,LOW,'①'),coloryellow;
角度:=ATAN((MA(C,5)/REF(MA(C,5),1)-1)*100)*57.3;
持有:=EXIST(一涨停,5) AND 角度>75 AND C>REF(C,1);
DRAWTEXT(持有,LOW,'龙'),coloryellow;
C2:=REF(C,1);
涨停:=IF((C-C2)*100/C2>=(10-0.01*100/C2),1,0);
STICKLINE(涨停,OPEN,CLOSE,8,0),colormagenta;
STICKLINE(涨停,H,L,0,0),colormagenta;
跌停:=IF((C2-C)*100/C2>=(10-0.01*100/C2),1,0);
STICKLINE(跌停,OPEN,CLOSE,8,0),colorgreen;
STICKLINE(跌停,H,L,0,1),colorgreen;
A7:=(2*C+H+L)/4;
VAR1:LLV(A7,21);
VAR2:HHV(A7,30);
波段:=EMA(C,18), colorred,LINETHICK2;
PARTLINE(波段,波段>REF(波段,1),RGB(250,10,10),波段<=REF(波段,1),RGB(250,250,250)),LINETHICK3;
K:=EMA(波段,5);
D:=EMA(K,5);
PARTLINE(K,K>D,colorred,K<D,colorgreen),LINETHICK2;

同花顺龙头操盘主图指标公式

相关文章