在线检测未来函数

同花顺金三角死三角指标公式

来源:Internet,编辑:股旁网,2022-01-12

VA1:=HHV(HIGH,12)-LLV(LOW,26);
VA2:=HHV(HIGH,9)-CLOSE;
VA3:=CLOSE-LLV(LOW,9);
VA4:=VA2/VA1*100-70;
VA5:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
VA6:=(2*CLOSE+HIGH+LOW)/4;
VA7:=SMA(VA3/VA1*100,3,1);
VA8:=LLV(LOW,34);
VA9:=SMA(VA7,3,1)-SMA(VA4,9,1);
VARA:=IF(VA9>100,VA9-100,0);
VARB:=HHV(HIGH,34);
VARC:=EMA((VA6-VA8)/(VARB-VA8)*100,13);
VARD:=EMA(0.667*REF(VARC,1)+0.333*VARC,2);
VARE:=SMA(MAX(CLOSE-REF(CLOSE,1),0)/CLOSE,8,1)/SMA(Abs(INDEXC-REF(INDEXC,1))/INDEXC,8,1)*100-25;
VARF:=MA(VARE,3);
生命线:EMA(VARD,1),COLORFF00FF;
VAR1:=HHV(HIGH,9)-LLV(LOW,9);
VAR2:=HHV(HIGH,9)-CLOSE;
VAR3:=CLOSE-LLV(LOW,9);
VAR4:=((VAR2)/(VAR1))*(100)-70;
VAR5:=((CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60)))*(100);
VAR6:=((2)*(CLOSE)+HIGH+LOW)/(4);
VAR7:=SMA(((VAR3)/(VAR1))*(100),3,1);
VAR8:=LLV(LOW,34);
VAR9:=SMA(VAR7,3,1)-SMA(VAR4,9,1);
VAR10:=IF((VAR9>100),VAR9-100,0);
VAR11:=HHV(HIGH,34);
B1:=EMA(((VAR6-VAR8)/(VAR11-VAR8))*(100),8);
B2:EMA(B1,5),COLORFF7000;
stICKLINE(B1-B2>0,B1,B2,2,0),colorred;
STICKLINE(B1-B2<0,B1,B2,2,0),colorgreen;
V1:=MA(C,5)=HHV(MA(C,5),20);
V2:=MA(C,5)>MA(C,10);
V3:=MA(V,5)>MA(V,40)*1.01;
V4:=COUNT(MA(C,1)>REF(C,1),2)=2;
VV:=V1 AND V2 AND V3 AND V4;
A1:=EMA(CLOSE,8);
A2:=EMA(A1,20);
A3:=crOSS(A1,A2);
A4:=A1<EMA(CLOSE,120);
A5:=3*SMA((CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*100,21,1)-2*SMA(SMA((CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*100,20,1),8,1);
S5=MA(CLOSE,5,1);
S10=MA(CLOSE,10,1);
S20=MA(CLOSE,20,1);
IF((S5-CLOSE) < 0)
MAI=0;
IF((S5-CLOSE) > 0 AND (S5-CLOSE) < 5)
MAI=(S5-CLOSE)*2 + 8;
IF((S5-CLOSE) > 5 AND (S5-CLOSE)<15)
MAI=(S5-CLOSE)*2+ 8;
IF((S5-CLOSE > 15))
MAI=(S5-CLOSE)*1.5;
金叉 :IF(CROSS(S5,S10),15,0),colorred,NODRAW;
STICKLINE(CROSS(S5,S10),0,15,3,0 ),colorred;
三角 :IF(CROSS(S10,S20),25,0),colorred,NODRAW;
STICKLINE(CROSS(S10,S20),0,25,7,0 ),colorred;
减仓:IF(CLOSE < S5,MAI,0),colorgreen,NODRAW;
STICKLINE(CLOSE < S5,0,MAI,3,0 ),colorgreen;
死叉 :IF(CROSS(S10,S5),20,0),colorred,NODRAW;
STICKLINE(CROSS(S10,S5),0,20,7,0 ),colorgreen;

同花顺金三角死三角指标公式

相关文章