在线检测未来函数

同花顺黑牛K线指标公式

来源:Internet,编辑:股旁网,2022-07-13

买线:=Ema(CLOSE,2);
卖线:=EMA(SLOPE(CLOSE,21) * 20 + CLOSE,42);
BU:=crOSS(买线,卖线);
SEL:=CROSS(卖线,买线);
DRAWTEXT(BU,(LOW * 0.97),'▲'),COLOR0000FF;
DRAWTEXT(BU,(LOW * 0.95),'▲'),COLOR0000FF;
DRAWTEXT(BU,(LOW * 0.93),'▲'),COLOR0000FF;
DRAWTEXT(SEL,(HIGH * 1.03),'▼'),COLORFF6600;
DRAWTEXT(SEL,(HIGH * 1.045),'▼'),COLORFF6600;
DRAWTEXT(SEL,(HIGH * 1.065),'▼'),COLORFF6600;
stICKLINE(买线 >= 卖线,LOW,HIGH,0.0,1),COLOR0000FF;
STICKLINE(买线 >= 卖线,CLOSE,OPEN,2,1),COLOR0000FF;
STICKLINE(买线 < 卖线,LOW,HIGH,0.0,1),COLOR009900;
STICKLINE(买线 < 卖线,CLOSE,OPEN,2,1),COLOR009900;
STICKLINE(BU,OPEN,CLOSE,2,0),COLOR00FFFF;
STICKLINE(SEL,OPEN,CLOSE,2,0),COLORFF3300;
主力:EMA(CLOSE,10),COLOR0000FF;
散户:EMA(CLOSE,5),COLORFFFFFF;
绿降:(46.18 * EMA(CLOSE,10) - 31.82 * EMA(CLOSE,4)) / 14.36,COLOR33FF00,LINETHICK1;
操盘:MA(CLOSE,9),COLORFF00FF,LINETHICK2;
界点:MA(CLOSE,20),COLORFF9900;
LC:=REF(CLOSE,1);
rsi:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(Abs((CLOSE - LC)),3,1)) * 100);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
DRAWTEXT(CROSS(FF,MA15),(LOW * 0.96),'底'),COLOR0099FF;
DRAWTEXT(CROSS(FF,MA15),(LOW * 0.915),'背'),COLOR0099FF;
DRAWTEXT(CROSS(FF,MA15),(LOW * 0.88),'离'),COLOR0099FF;
ATR:=MA(TR,14);
AA:=(HHV(HIGH,20) - (2 * ATR));
BB:=CROSS(CLOSE,REF(HHV(HIGH,55),1));
SSS:=CROSS(MIN(MA(CLOSE,13),AA),CLOSE);
BBB:=BArslAST(BB);
SSSB:=BARSLAST(SSS);
B1:=((BBB = 0) AND (REF(SSSB,1) < REF(BBB,1)));
B1B:=BARSLAST(B1);
B2:=((((BB = 1) AND (B1B < SSSB)) AND (B1B > 0)) AND (COUNT(BB,SSSB) < 3));
B2B:=BARSLAST(B2);
B3:=((((BB = 1) AND (B2B < B1B)) AND (COUNT(BB,SSSB) < 4)) AND (COUNT(BB,SSSB) > 2));
DRAWTEXT((B1 = 1),(LOW * 0.96),'跟'),COLOR00FFFF;
DRAWTEXT((B1 = 1),(LOW * 0.92),'进'),COLOR00FFFF;
DRAWTEXT((B2 = 1),(LOW * 0.96),'加'),COLOR88FFFF;
DRAWTEXT((B2 = 1),(LOW * 0.925),'码'),COLOR88FFFF;

同花顺黑牛K线指标公式

相关文章