在线检测未来函数

比DDX好的指标CBX成本动向(通达信)

来源:Internet,编辑:股旁网,2010-05-24

{手动输入参数:NUM(1,999,13),SHORT(1,999,3),LONG(1,999,5)}
ZF:=H-L;
CB:=AMOUNT/VOL/100;
DV1:=IF(ZF>0 AND C>CB, ((H-C)/(H-CB))*((H-C)/(H-CB))*((H-CB)/ZF*VOL) ,0);
UV1:=IF(ZF>0 AND C>CB, VOL-DV1 ,0);
UV2:=IF(ZF>0 AND C<CB, ((C-L)/(CB-L))*((C-L)/(CB-L))*((CB-L)/ZF*VOL) ,0);
DV2:=IF(ZF>0 AND C<CB, VOL-UV2 ,0);
UV3:=IF(ZF=0 AND C>REF(C,1), VOL,0);
DV3:=IF(ZF=0 AND C<REF(C,1), VOL,0);
UV:=UV1+UV2+UV3;
DV:=DV1+DV2+DV3;
CBX:((UV-DV)/VOL)/CAPITAL*1000000,LINETHICK0;
STICKLINE(CBX>0,0,CBX,3,0),COLOR041CEC;
STICKLINE(CBX>0,0,CBX,3,0),COLOR0F26FB;
STICKLINE(CBX>0,0,CBX,2,0),COLOR2439FB;
STICKLINE(CBX>0,0,CBX,1,0),COLOR485AFB;
STICKLINE(CBX>0,0,CBX,0,0),COLOR6473FB;
STICKLINE(CBX<0,0,CBX,3,0),COLORCD690E;
STICKLINE(CBX<0,0,CBX,3,0),COLOREF7B12;
STICKLINE(CBX<0,0,CBX,2,0),COLORF08728;
STICKLINE(CBX<0,0,CBX,1,0),COLORF29540;
STICKLINE(CBX<0,0,CBX,0,0),COLORF5A963;
CBX1:EMA(SUM(CBX,NUM),2),COLORMAGENTA;
CBX2:EMA(CBX1,SHORT),COLORYELLOW;
CBX3:EMA(CBX1,LONG),COLORGREEN;






 

相关文章