在线检测未来函数

通达信资金流量指标公式

来源:Internet,编辑:股旁网,2010-05-24

AA:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
买量:=IF(CLOSE>OPEN,AA*(HIGH-LOW),IF(CLOSE<OPEN,AA*((HIGH-OPEN)+ (CLOSE-LOW)),VOL/2)),LINETHICK0,COLORRED;
卖量:=IF(CLOSE>OPEN,0-AA*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0- AA*(HIGH-LOW),0-VOL/2)),LINETHICK0,COLORGREEN;
进出量:=买量+卖量,COLOR00FFFF;STICKLINE(进出量<0,0,进出量,1,0),COLORFF6600;
STICKLINE(进出量<0,0,进出量,3,0),COLORFF9900;
STICKLINE(进出量<0,0,进出量,1.5,0),COLORFFCC00;
STICKLINE(进出量<0,0,进出量,0.5,0),COLORCYAN;
STICKLINE(进出量>0,0,进出量,3,0),COLOR000099;
STICKLINE(进出量>0,0,进出量,3,0),COLOR0000CC;
STICKLINE(进出量>0,0,进出量,1.0,0),COLOR0000FF;
STICKLINE(进出量>0,0,进出量,0.5,0),COLORCC66FF;N:=1;QJ0:= (HIGH+LOW+CLOSE)/3;
QJ1:=IF(HIGH=LOW,1,HIGH-MAX(OPEN,CLOSE));
QJ2:=IF(HIGH=LOW,1,MAX(CLOSE,OPEN)-QJ0);
QJ3:=IF(HIGH=LOW,1,MIN(OPEN,CLOSE)-LOW);
QJ4:=IF(HIGH=LOW,1,QJ0-MIN(CLOSE,OPEN));
QJ5:=VOL/(IF(HIGH=LOW,4,HIGH-LOW));
QJ6:="MACD.DIF">"MACD.DEA" AND "MACD.DEA"<0;
QJ7:="KDJ.K">"KDJ.D" AND "KDJ.D"<30;
QJ8:="MACD.DIF"<"MACD.DEA";
QJ9:="KDJ.K"<"KDJ.D" AND "KDJ.K">80;
特:QJ4*QJ5,NODRAW;大:QJ3*QJ5,NODRAW;
中:QJ1*QJ5,NODRAW;小:QJ2*QJ5,NODRAW;
W1:=SUM(大,N)+SUM(特,N);W2:=SUM(小,N)+SUM(中,N);
量振1:=特>大 AND 大>小;
量振2:=特<小 AND 大<小;
标振1:=QJ6 AND QJ7;
标振2:=QJ8 AND QJ9;
A:=W1-W2;A0:=IF(A>0,A,0);B0:=IF(A<0,A,0);
STICKLINE(A0,0,A0,1,0),COLOR000044;主力持仓:EMA(100*(CLOSE- LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)),3),COLORFF00FF;主筹码集中度:WINNER(C)*100,COLORRED;

 

相关文章