在线检测未来函数

通达信自带指标与dmi结合操盘副图

来源:Internet,编辑:股旁网,2010-05-24

VAR1:=EMA(EMA(CLOSE,9),9);
VAR2:=100*WINNER(CLOSE*0.95);
控盘:=(VAR1-REF(VAR1,1))/REF(VAR1,1)*1000;
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26),NODRAW,COLORWHITE;
DEA:=EMA(DIF,9);
MACD:(DIF-DEA)*2,NODRAW;
TR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),14);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),14);
DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),14);
PDI:= DMP*100/TR;
MDI:=DMM*100/TR;
DM:PDI-MDI,COLORWHITE,NODRAW;
ADX:EXPMEMA(ABS(MDI-PDI)/(MDI+PDI)*100,6),COLORFF00FF,NODRAW;
ADXR:EXPMEMA(ADX,6),COLORGREEN,NODRAW;
加速:IF(DM>0 AND ADXR>REF(ADXR,1) AND ADXR>20,控盘*1.1,DRAWNULL),CIRCLEDOT,COLORRED{持股};
盘升:IF(DM>0 AND ADXR>REF(ADXR,1) AND ADXR<20,控盘*1.2,DRAWNULL),CIRCLEDOT,COLORYELLOW;
空头:IF(控盘>0 AND DM<0,控盘*1.2,DRAWNULL),CROSSDOT,COLORGREEN;
多头:IF(DM>0 AND ADXR<REF(ADXR,1),控盘*1.2,DRAWNULL),CROSSDOT,COLORRED;
DRAWTEXT(CROSS(ADXR,ADX) AND ADXR>60 AND 控盘>0 AND 控盘<REF(控盘,1),控盘*1.3,'←改'),COLORGREEN;
DRAWICON(CROSS(MDI,PDI) AND 控盘>0,控盘*1.3,2);
DRAWTEXT(CROSS(ADXR,ADX) AND ADXR>=20 AND ADXR<60 AND 控盘>0 AND 控盘<REF(控盘,1),控盘*1.3,'←变'),COLORYELLOW;
DRAWTEXT(CROSS(ADXR,ADX) AND ADXR<20 AND DM>0,控盘*1.3,'←变化'),COLORWHITE;
STICKLINE(控盘<0 AND 控盘<REF(控盘,1),控盘,0,1.6,0),COLORWHITE;
无庄:IF(控盘<0,控盘,0),COLORWHITE,NODRAW;
STICKLINE(控盘<0 AND 控盘>REF(控盘,1),控盘,0,1.6,0),COLORFFCC66;
STICKLINE(控盘>REF(控盘,1) AND 控盘>0,控盘,0,1.6,0),COLORRED;
有庄:IF(控盘>REF(控盘,1) AND 控盘>0,控盘,0),COLORRED,NODRAW;
STICKLINE(VAR2>50 AND COST(85)<CLOSE AND 控盘>0,控盘,0,1.6,0),COLORFF00FF;
高度:IF(VAR2>50 AND COST(85)<CLOSE AND 控盘>0,控盘,0),COLORFF00FF,NODRAW;
STICKLINE(控盘<REF(控盘,1) AND 控盘>0,控盘,0,1.6,0),COLOR00FF00;
出货:IF(控盘<REF(控盘,1) AND 控盘>0,控盘,0),COLOR00FF00,NODRAW;
DRAWTEXT(CROSS(DIF,DEA) AND DIF>0,控盘*1.1,'B'),COLORRED;
DRAWTEXT(CROSS(DEA,DIF) AND DIF>0,控盘*1.1,'S'),COLORGREEN;
DRAWTEXT(CROSS(DIF,DEA) AND DIF<0,控盘*1.1,'←B'),COLORRED;
DRAWTEXT(CROSS(DEA,DIF) AND DIF<0,控盘*1.1,'←S'),COLORGREEN;
STICKLINE(ADXR>REF(ADXR,1),控盘*0.382,0,1,0),COLORYELLOW;
STICKLINE(ADXR<REF(ADXR,1),控盘*0.382,0,1,0),COLORBLUE;
启动1:=(CROSS(控盘,0) AND DM>0 AND MACD>0) OR (CROSS(DM,0) AND 控盘>0 AND MACD>0) OR (CROSS(MACD,0) AND DM>0 AND 控盘>0);
启动:IF(启动1,5,0),LINETHICK1,COLORYELLOW;

 

相关文章