在线检测未来函数

CCI 主图公式源码(大智慧)

来源:Internet,编辑:股旁网,2010-05-24

CCI趋势发生变化向上时主图上会有一条竖线提示,(回车会显示),指标中的7天线可以暂且看作是散户成本线,78天线看做机构线,机构不会为散户抬轿的,只有散户线在上,且股价运行在7天上方,股价才会拉升,个中含义敬请细细品味。。。 (无未来)大智慧主图 MA1:EMA(CLOSE,P1),colorwhite,LINETHICK1;
MA2:EMA(CLOSE,P2),colorRED,LINETHICK1;
散户成本: EMA(CLOSE,P1),colorwhite,linethick1;
主力成本: EMA(CLOSE,P2),colorred,linethick1;
DRAWTEXT(CROSS(散户成本,主力成本),散户成本,'★建仓') ,colorYELLOW;
DRAWTEXT(CROSS(主力成本,散户成本),主力成本,'★空仓') ,colorGREEN;

DRAWTEXTABS(8,5,'操盘定律:只做强势股,回避弱势股! '),colorred,LINETHICk3;
DRAWTEXTABS(8,25,'回避风险,保住本金.'),colorYellow,LINETHICK2;
DRAWTEXTABS(8,40,'回避风险,保住本金.'),colorwhite,LINETHICK2;
LC:=REF(CLOSE,3);
JH:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
DRAWTEXT(FILTER(CROSS(JH,30),55),LOW*0.98,'↑关注'),COLORYELLOW,LINETHICK1;
DRAWTEXT(FILTER(CROSS(84,JH),22),HIGH*1.02,'↓小心 '),COLOR00FF00;AA1:=AMOUNT/V;
BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=V<MA(V,5)*1.5;
FF1:=BB1 AND CC1 AND DD1 AND EE1;
DRAWTEXT(FF1,(LOW* 0.97),'老鼠仓'),COLOR4080FF;{时间窗}
A:=BARSCOUNT(C);
AH:=HHV(H,200);
AL:=LLV(L,200);
A0:=(AH-AL)/40;
B1:=L-A0;
STICKLINE((A+0)/34=FLOOR((A+0)/34),B1,B1-1.5*A0,3,0),COLORF00FF0;
DRAWTEXT((A+0)/34=FLOOR((A+0)/34),B1-1*A0,'时间窗'),COLORWHITE; varC:=SMA(MAX(C-REF(C,1),0),6,1)/SMA(ABS(C-REF(C,1)),6,1)*100;
DRAWICON(CROSS(82,varC),HIGH,2);
DRAWTEXT(CROSS(84,varC),H*1.01,'逃顶'),COLORYELLOW ;

DP:=(INDEXC-REF(INDEXC,1))/REF(INDEXC,1);
GG:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1);
VAR1:=IF(DP>0.01,0.9,IF(DP<-0.05,1,1.2));
VAR2:=VAR1*(GG-DP)*100;
核心拉力:=SUM(VAR2,5);
DRAWICON(核心拉力>REF(核心拉力,1) AND REF(核心拉力,1)<REF(核心拉力,2) AND REF(核心拉力,1)<-6,l,1);{n,14,2,100,1}
DRAWGBKLAST(c>0,STRIP(RGB(10,60,0),RGB(50,10,0),0));
TYP := (HIGH + LOW + CLOSE)/3;
yy:(TYP-MA(TYP,N))/(0.015*AVEDEV(TYP,N)),linethick0;
bb:=(TYP-MA(TYP,N))/(0.015*AVEDEV(TYP,N));
VERTLINE((if(cross(bb,-200),-200,0)),1),colorf00ff0,linethick3;
DRAWTEXTREL(20,30,'CCI主图显示 '),LINETHICK3,Coloryellow;

 

相关文章