在线检测未来函数

空中加油(通达信)

来源:Internet,编辑:股旁网,2010-05-24

小提示:这是艺术派指标,看图领吾无更多说明,与你的股票比对一作为中线.短线有一定参考价值;也给喜欢的高手优化增添一份乐趣!若兴趣不大的就一笑了之吧 。
{空中加油★}
{背景色}
RSVCC:=(CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*100;
STICKLINE( RSVCC>0,60,0,8,0),COLOR880022;
STICKLINE( RSVCC>0,-40,0,8,0),COLOR003300;
DIFF1:= EMA(C,3) - EMA(C,13);
DEA1 := EMA(DIFF1,9);
MACD1:= 2*(DIFF1-DEA1)*10;
DIFF2:= EMA(C,5) - EMA(C,26);
DEA2 := EMA(DIFF2,9);
MACD2:= 2*(DIFF2-DEA2)*10;
DIFF3:= EMA(C,7) - EMA(C,89);
DEA3 := EMA(DIFF3,21);
MACD3:= 2*(DIFF3-DEA3)*10;
{STICKLINE(C>0,0,10,6,0),COLORE5C3EA;
STICKLINE(C>0,0,-5,6,0),COLORF6B06C;}
STICKLINE(MACD3>=0,0,MACD3,5,0),COLOR9999FF;
STICKLINE(MACD3<0,0,-MACD3,5,0),COLOR9999AA;
STICKLINE(MACD2>=0,0,MACD2,5,0),COLOR9966FF;{COLOR007D19};
STICKLINE(MACD2<0,0,-MACD2,5,0),COLOR557799;{COLOR555555};
STICKLINE(MACD1>=0,0,MACD1,5,0),COLOR9900FF;
STICKLINE(MACD1<0,0,-MACD1,5,0),COLOR556688;
STICKLINE(MACD3,0,-ABS(MACD3)*0.6,5,0),COLOR232323;
STICKLINE(MACD1,0,-ABS(MACD1)*0.6,5,0),COLOR0F0F0F;

VAR21:=((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100)/3;
绿星持币:VAR21,COLORGREEN,POINTDOT,LINETHICK4;
红星持股:IF(VAR21>0,VAR21,0),CIRCLEDOT,COLORRED,LINETHICK2;
短顶:STICKLINE(VAR21>9 AND FILTER(VAR21<REF(VAR21,1),5),VAR21+2,0,3,0),COLORFF4400;
STICKLINE(VAR21>9 AND FILTER(VAR21<REF(VAR21,1),5),VAR21+2,0,2.4,0),COLORFF6600;
STICKLINE(VAR21>9 AND FILTER(VAR21<REF(VAR21,1),5),VAR21+2,0,1.8,0),COLORFF9900;
STICKLINE(VAR21>9 AND FILTER(VAR21<REF(VAR21,1),5),VAR21+2,0,1.2,0),COLORFFCC00;
STICKLINE(VAR21>9 AND FILTER(VAR21<REF(VAR21,1),5),VAR21+2,0,0.6,0),COLORGREEN;
大顶:STICKLINE(VAR21>20 AND FILTER(VAR21<REF(VAR21,1),5),VAR21+20,0,7,0),COLOR003300;
STICKLINE(VAR21>20 AND FILTER(VAR21<REF(VAR21,1),5),VAR21+20,0,6,0),COLOR005500;
STICKLINE(VAR21>20 AND FILTER(VAR21<REF(VAR21,1),5),VAR21+20,0,5,0),COLOR007700;
STICKLINE(VAR21>20 AND FILTER(VAR21<REF(VAR21,1),5),VAR21+20,0,3,0),COLOR009900;
STICKLINE(VAR21>20 AND FILTER(VAR21<REF(VAR21,1),5),VAR21+20,0,0.5,0),COLOR00CC00;
VAR22:=HHV(VAR21>20,10);
危险: STICKLINE(VAR22 AND CROSS((REF(HIGH,1)+REF(LOW,1))/2,MA(CLOSE,20)+2*STD(CLOSE,20)),VAR21+10,0,4,0)COLORFF0033;
STICKLINE(VAR22 AND CROSS((REF(HIGH,1)+REF(LOW,1))/2,MA(CLOSE,20)+2*STD(CLOSE,20)),VAR21+10,0,3.3,0)COLORFF0066;
STICKLINE(VAR22 AND CROSS((REF(HIGH,1)+REF(LOW,1))/2,MA(CLOSE,20)+2*STD(CLOSE,20)),VAR21+10,0,2.4,0)COLORFF0099;
STICKLINE(VAR22 AND CROSS((REF(HIGH,1)+REF(LOW,1))/2,MA(CLOSE,20)+2*STD(CLOSE,20)),VAR21+10,0,1.6,0)COLORFF00CC;
STICKLINE(VAR22 AND CROSS((REF(HIGH,1)+REF(LOW,1))/2,MA(CLOSE,20)+2*STD(CLOSE,20)),VAR21+10,0,0.8,0)COLORFF00FF;
注意止损:STICKLINE(VAR22 AND FILTER(VAR21< REF(VAR21,1),6) AND CROSS(MA(CLOSE,5),MA(CLOSE,2)),VAR21+6,0,3,0)COLOR0035FF;
STICKLINE(VAR22 AND FILTER(VAR21< REF(VAR21,1),6) AND CROSS(MA(CLOSE,5),MA(CLOSE,2)),VAR21+6,0,2.4,0)COLOR0064FF;
STICKLINE(VAR22 AND FILTER(VAR21< REF(VAR21,1),6) AND CROSS(MA(CLOSE,5),MA(CLOSE,2)),VAR21+6,0,1.8,0)COLOR0093FF;
STICKLINE(VAR22 AND FILTER(VAR21< REF(VAR21,1),6) AND CROSS(MA(CLOSE,5),MA(CLOSE,2)),VAR21+6,0,1.2,0)COLOR00C2FF;
STICKLINE(VAR22 AND FILTER(VAR21< REF(VAR21,1),6) AND CROSS(MA(CLOSE,5),MA(CLOSE,2)),VAR21+6,0,0.6,0)COLOR00FFFF;
短底:STICKLINE(VAR21<-9 AND VAR21> REF(VAR21,1),VAR21-2,0,3,0),COLOR000033;
STICKLINE(VAR21<-9 AND VAR21> REF(VAR21,1),VAR21-2,0,2.4,0),COLOR000066;
STICKLINE(VAR21<-9 AND VAR21> REF(VAR21,1),VAR21-2,0,1.8,0),COLOR000099;
STICKLINE(VAR21<-9 AND VAR21> REF(VAR21,1),VAR21-2,0,1.2,0),COLOR0000CC;
STICKLINE(VAR21<-9 AND VAR21> REF(VAR21,1),VAR21-2,0,0.6,0),COLOR0000FF;
DRAWTEXT(VAR21>9 AND FILTER(VAR21<REF(VAR21,1),5),VAR21+2,'短顶'),COLORCYAN;
DRAWTEXT(VAR21>20 AND FILTER(VAR21<REF(VAR21,1),5),VAR21+21,'大顶'),COLORGREEN;
DRAWTEXT(VAR22 AND CROSS((REF(HIGH,1)+REF(LOW,1))/2,MA(CLOSE,20)+2*STD(CLOSE,20)),VAR21+10,'危险'),COLOR0033FF;
DRAWTEXT(VAR22 AND FILTER(VAR21< REF(VAR21,1),6) AND CROSS(MA(CLOSE,5),MA(CLOSE,2)),VAR21+6,'注意止损'),COLORYELLOW;
DRAWTEXT(FILTER(VAR21<-9 AND VAR21>REF(VAR21,1),18),1.8,'买票准备');
MA5:=MA(CLOSE,5);
MA10:=MA(CLOSE,10);
MA20:=MA(CLOSE,20);
MA30:=MA(CLOSE,30);
MA250:=MA(CLOSE,250),COLORRED;
N1:=BARSLAST(CROSS(MA5,MA10));
N2:=BARSLAST(CROSS(MA10,MA5));
多:=IF(N1<N2,N1+1,0);
空:=IF(N2<N1,N2+1,0);
QSXS:=MA5>MA20 AND MA10>MA20 AND MA20>REF(MA20,1) AND MA30>REF(MA30,1);
启动:=多*QSXS,COLORRED,LINETHICK0;
跑道:=空*QSXS,COLORFFFF00,LINETHICK0;
HKFJ:=HHV(多,5)>=2 AND QSXS AND MA5>REF(MA5,1) AND MA5>MA10;
空中拉升:HKFJ*多,COLOR000099,LINETHICK3;
HKSJ:=BARSLAST(空中拉升>0 AND NOT(REF(空中拉升,1)))+1;
高度:=(C/REF(C,HKSJ)-1)*100,COLOR00FFFF;
客机安全高度:高度,COLOR999999;
空中加油:IF(高度>0,高度,0),COLORRED,LINETHICK3;

 

相关文章