在线检测未来函数

一个简单实用的kdj公式(通达信)

来源:Internet,编辑:股旁网,2010-05-24

我把公式起名为“实用kdj”。源码为:
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:SMA(RSV,3,1);
D:SMA(K,3,1);
J:3*K-2*D;
VARK:=K,COLORWHITE;
升K:=IF(VARK>REF(VARK,1),VARK,DRAWNULL),COLORRED;
平K:=IF(VARK=REF(VARK,1),VARK,DRAWNULL),COLORWHITE;
降K:=IF(VARK<REF(VARK,1),VARK,DRAWNULL),COLORGREEN;
VARD:=D,COLORWHITE;
升D:=IF(VARD>REF(VARD,1),VARD,DRAWNULL),COLORRED;
平D:=IF(VARD=REF(VARD,1),VARD,DRAWNULL),COLORWHITE;
降D:=IF(VARD<REF(VARD,1),VARD,DRAWNULL),COLORGREEN;
VARJ:=J,COLORWHITE;
升J:IF(VARJ>REF(VARJ,1),VARJ,DRAWNULL),COLORRED,LINETHICK2;
平J:IF(VARJ=REF(VARJ,1),VARJ,DRAWNULL),COLORWHITE,LINETHICK1;
降J:IF(VARJ<REF(VARJ,1),VARJ,DRAWNULL),COLORGREEN,LINETHICK1;
DRAWBAND(K,RGB(155,50,50),D,RGB(0,100,50));
STICKLINE(J<0,J,0,1,1),COLORYELLOW;
STICKLINE(J>100,J,100,1,1),COLORWHITE;

 

相关文章