在线检测未来函数

大智慧分时抓涨停主图指标公式

来源:Internet,编辑:股旁网,2010-05-24

BU:=BARSLAST(CLOSE=HHV(CLOSE,60));
SE:=BARSLAST(CLOSE=LLV(CLOSE,60));
KK1:=SE;
KK2:=BU;
LM1:=SE;
LM2:=BU;
OK:=KK1>KK2 AND LM1>LM2;
OK1:=KK1>KK2 AND LM1<LM2;
NOK:=KK2>KK1 AND LM2>LM1;
NOK1:=KK2>KK1 AND LM2<LM1;
DRAWICON(CROSS(KK1,KK2),OPEN*1,1);
DRAWTEXT(CROSS(KK1,KK2),OPEN*0.985,'抓'),color3cb371;

T:=barscount(c);
均价:=DYNAINFO(11);
总量:=SUM(VOL,T);
总额:=SUM(AMOUNT,T);
均价:=总额/(总量*100);
次数:=COUNT(CLOSE>均价,T);
占比:=次数/T*100;
分时强势:DRAWICON(CROSS(CLOSE,均价) AND CLOSE>均价 AND 占比>80 AND T>5,CLOSE*0.99,7);
DRAWTEXT(CROSS(CLOSE,均价) AND CLOSE>均价 AND 占比>80 AND T>5,CLOSE*0.98,'涨价'),colorFFFF00;

VAR1:=AMOUNT/VOL/100;
VAR2:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;
VAR3:=SUM(AMOUNT,5)/VAR1/100;
VAR4:=SUM(AMOUNT,13)/VAR1/100;
VAR5:=SUM(AMOUNT,34)/VAR1/100;
CYC5:=DMA(VAR2,VOL/VAR3);
CYC13:=DMA(VAR2,VOL/VAR4);
CYC34:=DMA(VAR2,VOL/VAR5);
CYC∞:=DMA(VAR2,VOL/CAPITAL);
一剑封喉:=CROSS(CLOSE,MA(CLOSE,13)) AND CROSS(CLOSE,MA(CLOSE,34)) AND CROSS(CLOSE,MA(CLOSE,55));
A1:=(CLOSE-LLV(LOW,22))/(HHV(HIGH,22)-LLV(LOW,22))*100;
A2:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
A:=3*SMA(A1,5,1)-2*SMA(SMA(A2,5,1),3,1);
YNGS:=一剑封喉 AND A<30;
DRAWICON(一剑封喉 AND A<30,LOW*0.985,10);
DRAWTEXT(一剑封喉 AND A<30,LOW*0.98,'停'),colorFF0000;

{明关键价位}
c1:=ref(c,1);
c2:=hhv(c1,2);
c3:=llv(c1,1);
et:=hhv(c1,2);
et1:=ref(et,1);
xb:=llv(c1,1);
xb1:=ref(xb,1);
m:=BARSLAST(c<xb and c1>=xb1);
m11:=ref(m,1);
n9:=BARSLAST(c>et and c1<=et1);
n1:=ref(n9,1);
m21:=BARSLAST(m-n9>0 and m11<=n1)+1;
n2:=BARSLAST(n9-m>0 and n1<=m11)+1;
et2:=hhv(et,m21);
xb2:=llv(xb,n2);
a:=if(m-n9>0 and m11<=n1,1,if(n9-m>0 and n1<=m11,0,2));
h1:=if(m-n9>0,c,et2);
h2:=if(a=1,c,c2);
h3:=if(m-n9<0,c,xb2);
h4:=if(a=1,c,xb2);
h5:=if(m-n9>0 or a=1,c,h3);
明关键价位:ref(h5,1);

MA1:=MA(CLOSE,2);
Var1:=MA(C, 1);
Var2:=MA(C, 5);
Var3:=MA(C, 10);
Var4:=MA(C, 20);
Var5:=MA(C, 30);
Var6:=(Var1+Var2+Var3+Var4+Var5)/5;
Var7:=(Var6-REF(Var6, 15))/REF(Var6,15)*100;
Var8:=(Var6-REF(Var6, 15))/REF(Var6, 15)*100;
Var9:=EMA(Var7, 8);
平均价:=(H+4*L+C+O)/7;
均价差:= EMA(平均价,13) - EMA(平均价,34);
移动均价:= EMA(均价差,5);
差:=(均价差-移动均价)*5;
A:=IF(差>=1000 ,1000 ,if(差<=平均价,平均价,差) );
分水岭:=FORCAST(FORCAST(A,31),10);
涨↑:if(A>分水岭,A,分水岭),LINETHICK1,colorred;
跌↓:if(A<分水岭,A,分水岭),LINETHICK1,ColorGREEN;

ma6:=MA(c,6);
ma18:=MA(c,18);
ma55:=MA(c,55);
ma125:=MA(c,125);
ma250:=MA(c,250);
TY:=C;
A1:=REF(TY,10)=HHV(TY,2*10+1); B1:=filter(A1,10); C1:=ref(B1,10+1); HD:=filter(C1,10);
A2:=REF(TY,10)=LLV(TY,2*10+1); B2:=filter(A2,10); C2:=ref(B2,10+1); LD:=ref(C2,10);
AA:=REF(c,barslast(HD)); B:=ref(c,barslast(LD));
t11:=barslast(HD)<barslast(LD) AND not(HD) ;
t21:=barslast(HD)>barslast(LD) AND not(LD);
波峰:if(t11,AA,AA),ColorFF00FF,pointdot;
stickline(t11,AA,AA,9,0),ColorFF00FF;
波谷:if(t21,B,B),Color80FF00,pointdot;
stickline(t21,B,B,9,0),Color80FF00;
买进价:=((c-ref(ma6,1))/6+ma6)*1.004;
买进条件:=cross(c,买进价) and 买进价>ref(买进价,1);
黄点状线:if(买进条件,h,l),COLORYELLOW,linethick1,pointdot;
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIFF,8);
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
B1:=REF(C,A1+1)>C AND REF(DIFF,A1+1)<DIFF AND CROSS(DIFF,DEA);
DRAWTEXT(IF(B1>0,1,0),L-0.1,'MACD底背'),COLORGREEN;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
A2:=BARSLAST(REF(CROSS(K,D),1));
B2:=REF(C,A2+1)>C AND REF(K,A2+1)<K AND CROSS(K,D);
DRAWTEXT(IF(B2>0,1,0),L-0.25,'KDJ底背'),COLORYELLOW;
LC:=REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
RSI2:=SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100;
A3:=BARSLAST(REF(CROSS(RSI1,RSI2),1));
B3:=REF(C,A3+1)>C AND REF(RSI1,A3+1)<RSI1 AND CROSS(RSI1,RSI2);
DRAWTEXT(IF(B3>0,1,0),L-0.4,'RSI底背'),COLORCYAN;
C1:=BARSLAST(REF(CROSS(DEA,DIFF),1));
D1:=REF(C,C1+1)<C AND REF(DIFF,C1+1)>DIFF AND CROSS(DEA,DIFF);
DRAWTEXT(IF(D1>0,1,0),H*1.01,'MACD顶背'),COLORWHITE;
C2:=BARSLAST(REF(CROSS(D,K),1));
D2:=REF(C,C2+1)<C AND REF(K,C2+1)>K AND CROSS(D,K);
DRAWTEXT(IF(D2>0,1,0),H+0.15,'KDJ顶背'),COLORWHITE;
C3:=BARSLAST(REF(CROSS(RSI2,RSI1),1));
D3:=REF(C,C3+1)<C AND REF(RSI1,C3+1)>RSI1 AND CROSS(RSI2,RSI1);
DRAWTEXT(IF(D3>0,1,0),H+0.1,'RSI顶背'),COLORMAGENTA;
ref(h,C1),colorB48246,pointdot;
KK:=DATE<1341231;
PK:=VOL*(OPEN+CLOSE+HIGH+LOW)/4;
PK1:=IF(VOL>0,PK/VOL,(OPEN+CLOSE+HIGH+LOW)/4);
C11:=PK1;
A01:=(C11-LLV(C11,75))/(HHV(C11,75)-LLV(C11,75));
A11:=SMA(A01,13,1);
A21:=SMA(A11,13,1);
A31:=3*A11-2*A21;
A41:=2*A31-0.5;
ZS:=DYNAINFO(3)*0.95;
选1:=IF(KK,C11*(1-(A41-A21)/40),0);
选2:=CROSS(C11,选1) AND CLOSE/REF(CLOSE,1)<1.03;
选3:IF(选2,ZS*1.03,ZS),colorGREEN;

 

相关文章