在线检测未来函数

大智慧主力30分钟统计指标公式

来源:Internet,编辑:股旁网,2010-06-05

{主力30分}
input:N(1,1,2);
TODAY:="分时DDX.DDX累积"<>0;{判断是否有正版数据}
TODAY1:="LXDDX.DDX#day"=0;{判断是否有雨杨数据}
DRAWTEXTABS(680,-12,IFS(TODAY,'正版数据',IFS(TODAY1,'引入数据','雨杨数据 '))),LINETHICK1,colorwhite;
DRAWTEXTABS(752,-12,IFS(N=1,'逐单','逐笔')),LINETHICK1,colorwhite;
ZT1:="wd.o12"{ORDERVOL(1,2)};
YT1累积:="DDEDATA@BIGORDERSCALE"(1,2)*SUM(VOL,0);
YT1:=YT1累积-REF(YT1累积,1);
RT1累积:="wd.主单买#day"*SUM(VOL,0);
RT1:=RT1累积-REF(RT1累积,1);
T1:=IF(TODAY,ZT1,IF(TODAY1,RT1,YT1));
T2:="wd.t12"{TRANSACTVOL(1,2)};
ZT3:="wd.o22"{ORDERVOL(2,2)};
YT3累积:="DDEDATA@BIGORDERSCALE"(2,2)*SUM(VOL,0);
YT3:=YT3累积-REF(YT3累积,1);
RT3累积:="wd.主单卖#day"*SUM(VOL,0);
RT3:=RT3累积-REF(RT3累积,1);
T3:=IF(TODAY,ZT3,IF(TODAY1,RT3,YT3));
T4:="wd.t22"{TRANSACTVOL(2,2)};
ZS1:="wd.d12"{ORDERNUM(1,2)};
YS1:="DDEDATA@BIGORDERSCALE"(1,2);
RS1:="wd.主单买#day";
S1:=IF(TODAY,ZS1,IF(TODAY1,RS1,YS1));
S2:="wd.l12"{TRANSACTNUM(1,2)};
ZS3:="wd.d22"{ORDERNUM(2,2)};
YS3:="DDEDATA@BIGORDERSCALE"(2,2);
RS3:="wd.主单卖#day";
S3:=IF(TODAY,ZS3,IF(TODAY1,RS3,YS3));
S4:="wd.l22"{TRANSACTNUM(2,2)};
M1:=TIME<=100000;
M2:=TIME<=103000 AND TIME>100000;
M3:=TIME<=110000 AND TIME>103000;
M4:=TIME<=113000 AND TIME>110000;
M5:=TIME<=133000 AND TIME>130000;
M6:=TIME<=140000 AND TIME>133000;
M7:=TIME<=143000 AND TIME>140000;
M8:=TIME<=150000 AND TIME>143000;
{数据1大买}
A1:=IF(M1,S1,0);
A2:=IF(M1,S2,0);
AA:=SUM(IF(N=1,A1,A2),0);
B1:=IF(M2,S1,0);
B2:=IF(M2,S2,0);
BB:=SUM(IF(N=1,B1,B2),0);
C1:=IF(M3,S1,0);
C2:=IF(M3,S2,0);
CC:=SUM(IF(N=1,C1,C2),0);
D1:=IF(M4,S1,0);
D2:=IF(M4,S2,0);
DD:=SUM(IF(N=1,D1,D2),0);
E1:=IF(M5,S1,0);
E2:=IF(M5,S2,0);
EE:=SUM(IF(N=1,E1,E2),0);
F1:=IF(M6,S1,0);
F2:=IF(M6,S2,0);
FF:=SUM(IF(N=1,F1,F2),0);
G1:=IF(M7,S1,0);
G2:=IF(M7,S2,0);
GG:=SUM(IF(N=1,G1,G2),0);
H1:=IF(M8,S1,0);
H2:=IF(M8,S2,0);
HH:=SUM(IF(N=1,H1,H2),0);
I1:=IF(M1,T1,0);
I2:=IF(M1,T2,0);
II:=SUM(IF(N=1,I1,I2),0);
J1:=IF(M2,T1,0);
J2:=IF(M2,T2,0);
JJ:=SUM(IF(N=1,J1,J2),0);
K1:=IF(M3,T1,0);
K2:=IF(M3,T2,0);
KK:=SUM(IF(N=1,K1,K2),0);
L1:=IF(M4,T1,0);
L2:=IF(M4,T2,0);
LL:=SUM(IF(N=1,L1,L2),0);
N1:=IF(M5,T1,0);
N2:=IF(M5,T2,0);
NN:=SUM(IF(N=1,N1,N2),0);
O1:=IF(M6,T1,0);
O2:=IF(M6,T2,0);
OO:=SUM(IF(N=1,O1,O2),0);
P1:=IF(M7,T1,0);
P2:=IF(M7,T2,0);
PP:=SUM(IF(N=1,P1,P2),0);
Q1:=IF(M8,T1,0);
Q2:=IF(M8,T2,0);
QQ:=SUM(IF(N=1,Q1,Q2),0);
{数据2大卖}
A3:=IF(M1,S3,0);
A4:=IF(M1,S4,0);
AA1:=SUM(IF(N=1,A3,A4),0);
B3:=IF(M2,S3,0);
B4:=IF(M2,S4,0);
BB1:=SUM(IF(N=1,B3,B4),0);
C3:=IF(M3,S3,0);
C4:=IF(M3,S4,0);
CC1:=SUM(IF(N=1,C3,C4),0);
D3:=IF(M4,S3,0);
D4:=IF(M4,S4,0);
DD1:=SUM(IF(N=1,D3,D4),0);
E3:=IF(M5,S3,0);
E4:=IF(M5,S4,0);
EE1:=SUM(IF(N=1,E3,E4),0);
F3:=IF(M6,S3,0);
F4:=IF(M6,S4,0);
FF1:=SUM(IF(N=1,F3,F4),0);
G3:=IF(M7,S3,0);
G4:=IF(M7,S4,0);
GG1:=SUM(IF(N=1,G3,G4),0);
H3:=IF(M8,S3,0);
H4:=IF(M8,S4,0);
HH1:=SUM(IF(N=1,H3,H4),0);
I3:=IF(M1,T3,0);
I4:=IF(M1,T4,0);
II1:=SUM(IF(N=1,I3,I4),0);
J3:=IF(M2,T3,0);
J4:=IF(M2,T4,0);
JJ1:=SUM(IF(N=1,J3,J4),0);
K3:=IF(M3,T3,0);
K4:=IF(M3,T4,0);
KK1:=SUM(IF(N=1,K3,K4),0);
L3:=IF(M4,T3,0);
L4:=IF(M4,T4,0);
LL1:=SUM(IF(N=1,L3,L4),0);
N3:=IF(M5,T3,0);
N4:=IF(M5,T4,0);
NN1:=SUM(IF(N=1,N3,N4),0);
O3:=IF(M6,T3,0);
O4:=IF(M6,T4,0);
OO1:=SUM(IF(N=1,O3,O4),0);
P3:=IF(M7,T3,0);
P4:=IF(M7,T4,0);
PP1:=SUM(IF(N=1,P3,P4),0);
Q3:=IF(M8,T3,0);
Q4:=IF(M8,T4,0);
QQ1:=SUM(IF(N=1,Q3,Q4),0);
{数据3总买总卖差}
MR:=IF(N=1,SUM(T1,0),SUM(T2,0));
MC:=IF(N=1,SUM(T3,0),SUM(T4,0));
MRE:=MR*DYNAINFO(11)*100/10000;
MCE:=MC*DYNAINFO(11)*100/10000;
流入资金:MRE,COLOR0000FF,linethick0,PRECIS2;
流出资金:MCE,COLORFFFF00,linethick0,PRECIS2;
MRB:=IF(N=1,SUM(S1,0),SUM(S2,0));
MCB:=IF(N=1,SUM(S3,0),SUM(S4,0));
RBG:=MR*100/MRB;
CBG:=MC*100/MCB;
JS:=MR-MC;
JE:=MRE-MCE;
净资金:JE,COLOR00FFFF,linethick0,PRECIS2;
JB:=MRB-MCB;
JC:=RBG-CBG;
RZB:=MR/DYNAINFO(8)*100;
CZB:=MC/DYNAINFO(8)*100;
MR1:=IF(N=1,T1,T2);
MC1:=IF(N=1,T3,T4);
ZMX:=(MR1-MC1)/DYNAINFO(8)*100;
CS:=IFS(N=1,'单','笔');
{表格}
DRAWRECTABS(0,0,838,48,RGB(1,1,1)),COLOR0000C0;
DRAWRECTABS(0,0,696,13,RGB(210,150,0)),COLOR0096D2;
DRAWRECTABS(696,0,838,13,RGB(210,100,0)),COLOR0064D2;
DRAWRECTABS(0,0,87,48,0),COLOR0000C0;
DRAWRECTABS(0,0,174,48,0),COLOR0000C0;
DRAWRECTABS(0,0,261,48,0),COLOR0000C0;
DRAWRECTABS(0,0,348,48,0),COLOR0000C0;
DRAWRECTABS(0,0,435,48,0),COLOR0000C0;
DRAWRECTABS(0,0,522,48,0),COLOR0000C0;
DRAWRECTABS(0,0,609,48,0),COLOR0000C0;
DRAWRECTABS(0,0,696,48,0),COLOR0000C0;
DRAWRECTABS(0,0,838,48,0),COLOR0000C0;
{显示文字数字}
DRAWTEXTABS(15,1,'9:30-10:00 10:00-10:30 10:30-11:00 11:00-11:30 13:00-13:30 13:30-14:00 14:00-14:30 14:30-15:00 '),COLORFFFFFF;
DRAWTEXTABS(36,13,NUMTOSTRN(AA,0)+CS),COLOR0000FF,ALIGN2;
DRAWTEXTABS(36,24,NUMTOSTRN(AA1,0)+CS),COLORFFFF00,ALIGN2;
DRAWTEXTABS(36,35,NUMTOSTRN(AA-AA1,0)+CS),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(86,13,NUMTOSTRN(II,0)+'手'),COLOR0000FF,ALIGN2;
DRAWTEXTABS(86,24,NUMTOSTRN(II1,0)+'手'),COLORFFFF00,ALIGN2;
DRAWTEXTABS(86,35,NUMTOSTRN(II-II1,0)+'手'),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(123,13,NUMTOSTRN(BB,0)+CS),COLOR0000FF,ALIGN2;
DRAWTEXTABS(123,24,NUMTOSTRN(BB1,0)+CS),COLORFFFF00,ALIGN2;
DRAWTEXTABS(123,35,NUMTOSTRN(BB-BB1,0)+CS),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(173,13,NUMTOSTRN(JJ,0)+'手'),COLOR0000FF,ALIGN2;
DRAWTEXTABS(173,24,NUMTOSTRN(JJ1,0)+'手'),COLORFFFF00,ALIGN2;
DRAWTEXTABS(173,35,NUMTOSTRN(JJ-JJ1,0)+'手'),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(210,13,NUMTOSTRN(CC,0)+CS),COLOR0000FF,ALIGN2;
DRAWTEXTABS(210,24,NUMTOSTRN(CC1,0)+CS),COLORFFFF00,ALIGN2;
DRAWTEXTABS(210,35,NUMTOSTRN(CC-CC1,0)+CS),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(260,13,NUMTOSTRN(KK,0)+'手'),COLOR0000FF,ALIGN2;
DRAWTEXTABS(260,24,NUMTOSTRN(KK1,0)+'手'),COLORFFFF00,ALIGN2;
DRAWTEXTABS(260,35,NUMTOSTRN(KK-KK1,0)+'手'),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(297,13,NUMTOSTRN(DD,0)+CS),COLOR0000FF,ALIGN2;
DRAWTEXTABS(297,24,NUMTOSTRN(DD1,0)+CS),COLORFFFF00,ALIGN2;
DRAWTEXTABS(297,35,NUMTOSTRN(DD-DD1,0)+CS),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(347,13,NUMTOSTRN(LL,0)+'手'),COLOR0000FF,ALIGN2;
DRAWTEXTABS(347,24,NUMTOSTRN(LL1,0)+'手'),COLORFFFF00,ALIGN2;
DRAWTEXTABS(347,35,NUMTOSTRN(LL-LL1,0)+'手'),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(384,13,NUMTOSTRN(EE,0)+CS),COLOR0000FF,ALIGN2;
DRAWTEXTABS(384,24,NUMTOSTRN(EE1,0)+CS),COLORFFFF00,ALIGN2;
DRAWTEXTABS(384,35,NUMTOSTRN(EE-EE1,0)+CS),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(434,13,NUMTOSTRN(NN,0)+'手'),COLOR0000FF,ALIGN2;
DRAWTEXTABS(434,24,NUMTOSTRN(NN1,0)+'手'),COLORFFFF00,ALIGN2;
DRAWTEXTABS(434,35,NUMTOSTRN(NN-NN1,0)+'手'),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(471,13,NUMTOSTRN(FF,0)+CS),COLOR0000FF,ALIGN2;
DRAWTEXTABS(471,24,NUMTOSTRN(FF1,0)+CS),COLORFFFF00,ALIGN2;
DRAWTEXTABS(471,35,NUMTOSTRN(FF-FF1,0)+CS),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(521,13,NUMTOSTRN(OO,0)+'手'),COLOR0000FF,ALIGN2;
DRAWTEXTABS(521,24,NUMTOSTRN(OO1,0)+'手'),COLORFFFF00,ALIGN2;
DRAWTEXTABS(521,35,NUMTOSTRN(OO-OO1,0)+'手'),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(558,13,NUMTOSTRN(GG,0)+CS),COLOR0000FF,ALIGN2;
DRAWTEXTABS(558,24,NUMTOSTRN(GG1,0)+CS),COLORFFFF00,ALIGN2;
DRAWTEXTABS(558,35,NUMTOSTRN(GG-GG1,0)+CS),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(608,13,NUMTOSTRN(PP,0)+'手'),COLOR0000FF,ALIGN2;
DRAWTEXTABS(608,24,NUMTOSTRN(PP1,0)+'手'),COLORFFFF00,ALIGN2;
DRAWTEXTABS(608,35,NUMTOSTRN(PP-PP1,0)+'手'),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(645,13,NUMTOSTRN(HH,0)+CS),COLOR0000FF,ALIGN2;
DRAWTEXTABS(645,24,NUMTOSTRN(HH1,0)+CS),COLORFFFF00,ALIGN2;
DRAWTEXTABS(645,35,NUMTOSTRN(HH-HH1,0)+CS),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(695,13,NUMTOSTRN(QQ,0)+'手'),COLOR0000FF,ALIGN2;
DRAWTEXTABS(695,24,NUMTOSTRN(QQ1,0)+'手'),COLORFFFF00,ALIGN2;
DRAWTEXTABS(695,35,NUMTOSTRN(QQ-QQ1,0)+'手'),COLOR00FFFF,ALIGN2;
DRAWRECTABS(767,2,767+RZB,12,RGB(255,30,30)),COLORFFFFFF;
DRAWRECTABS(767,2,767-CZB,12,RGB(30,30,255)),COLORFFFFFF;
DRAWTEXTABS(733,1,NUMTOSTRN(CZB,2)+'%'),ALIGN2,COLOR00FFFF;
DRAWTEXTABS(837,1,NUMTOSTRN(RZB,2)+'%'),ALIGN2,COLOR00FFFF;
DRAWTEXTABS(740,13,NUMTOSTRN(MR,0)+'手'),COLOR4848FF,ALIGN2;
DRAWTEXTABS(740,24,NUMTOSTRN(MC,0)+'手'),COLOR48FF48,ALIGN2;
DRAWTEXTABS(740,35,NUMTOSTRN(JS,0)+'手'),COLOREEEEEE,ALIGN2;
DRAWTEXTABS(773,13,NUMTOSTRN(MRB,0)+'笔'),COLOR4848FF,ALIGN2;
DRAWTEXTABS(773,24,NUMTOSTRN(MCB,0)+'笔'),COLOR48FF48,ALIGN2;
DRAWTEXTABS(773,35,NUMTOSTRN(JB,0)+'笔'),COLOREEEEEE,ALIGN2;
DRAWTEXTABS(837,13,NUMTOSTRN(RBG,0)+'股/笔'),COLOR4848FF,ALIGN2;
DRAWTEXTABS(837,24,NUMTOSTRN(CBG,0)+'股/笔'),COLOR48FF48,ALIGN2;
DRAWTEXTABS(837,35,NUMTOSTRN(JC,0)+'股/笔'),COLOREEEEEE,ALIGN2;
{超户30分}
input:N(1,1,2);
TODAY:="分时DDX.DDX累积"<>0;{判断是否有正版数据}
TODAY1:="LXDDX.DDX#day"=0;{判断是否有雨杨数据}
DRAWTEXTABS(680,-12,IFS(TODAY,'正版数据',IFS(TODAY1,'引入数据','雨杨数据 '))),LINETHICK1,colorwhite;
DRAWTEXTABS(752,-12,IFS(N=1,'逐单','逐笔')),LINETHICK1,colorwhite;
ZT1:="wd.o13"{ORDERVOL(1,3)};
YT1累积:="DDEDATA@BIGORDERSCALE"(1,3)*SUM(VOL,0);
YT1:=YT1累积-REF(YT1累积,1);
RT1累积:="wd.特单买#day"*SUM(VOL,0);
RT1:=RT1累积-REF(RT1累积,1);
T1:=IF(TODAY,ZT1,IF(TODAY1,RT1,YT1));
T2:="wd.t13"{TRANSACTVOL(1,3)};
ZT3:="wd.o23"{ORDERVOL(2,3)};
YT3累积:="DDEDATA@BIGORDERSCALE"(2,3)*SUM(VOL,0);
YT3:=YT3累积-REF(YT3累积,1);
RT3累积:="wd.特单卖#day"*SUM(VOL,0);
RT3:=RT3累积-REF(RT3累积,1);
T3:=IF(TODAY,ZT3,IF(TODAY1,RT3,YT3));
T4:="wd.t23"{TRANSACTVOL(2,3)};
ZS1:="wd.d13"{ORDERNUM(1,3)};
YS1:="DDEDATA@BIGORDERSCALE"(1,3);
RS1:="wd.特单买#day";
S1:=IF(TODAY,ZS1,IF(TODAY1,RS1,YS1));
S2:="wd.l13"{TRANSACTNUM(1,3)};
ZS3:="wd.d23"{ORDERNUM(2,3)};
YS3:="DDEDATA@BIGORDERSCALE"(2,3);
RS3:="wd.特单卖#day";
S3:=IF(TODAY,ZS3,IF(TODAY1,RS3,YS3));
S4:="wd.l23"{TRANSACTNUM(2,3)};
M1:=TIME<=100000;
M2:=TIME<=103000 AND TIME>100000;
M3:=TIME<=110000 AND TIME>103000;
M4:=TIME<=113000 AND TIME>110000;
M5:=TIME<=133000 AND TIME>130000;
M6:=TIME<=140000 AND TIME>133000;
M7:=TIME<=143000 AND TIME>140000;
M8:=TIME<=150000 AND TIME>143000;
{数据1大买}
A1:=IF(M1,S1,0);
A2:=IF(M1,S2,0);
AA:=SUM(IF(N=1,A1,A2),0);
B1:=IF(M2,S1,0);
B2:=IF(M2,S2,0);
BB:=SUM(IF(N=1,B1,B2),0);
C1:=IF(M3,S1,0);
C2:=IF(M3,S2,0);
CC:=SUM(IF(N=1,C1,C2),0);
D1:=IF(M4,S1,0);
D2:=IF(M4,S2,0);
DD:=SUM(IF(N=1,D1,D2),0);
E1:=IF(M5,S1,0);
E2:=IF(M5,S2,0);
EE:=SUM(IF(N=1,E1,E2),0);
F1:=IF(M6,S1,0);
F2:=IF(M6,S2,0);
FF:=SUM(IF(N=1,F1,F2),0);
G1:=IF(M7,S1,0);
G2:=IF(M7,S2,0);
GG:=SUM(IF(N=1,G1,G2),0);
H1:=IF(M8,S1,0);
H2:=IF(M8,S2,0);
HH:=SUM(IF(N=1,H1,H2),0);
I1:=IF(M1,T1,0);
I2:=IF(M1,T2,0);
II:=SUM(IF(N=1,I1,I2),0);
J1:=IF(M2,T1,0);
J2:=IF(M2,T2,0);
JJ:=SUM(IF(N=1,J1,J2),0);
K1:=IF(M3,T1,0);
K2:=IF(M3,T2,0);
KK:=SUM(IF(N=1,K1,K2),0);
L1:=IF(M4,T1,0);
L2:=IF(M4,T2,0);
LL:=SUM(IF(N=1,L1,L2),0);
N1:=IF(M5,T1,0);
N2:=IF(M5,T2,0);
NN:=SUM(IF(N=1,N1,N2),0);
O1:=IF(M6,T1,0);
O2:=IF(M6,T2,0);
OO:=SUM(IF(N=1,O1,O2),0);
P1:=IF(M7,T1,0);
P2:=IF(M7,T2,0);
PP:=SUM(IF(N=1,P1,P2),0);
Q1:=IF(M8,T1,0);
Q2:=IF(M8,T2,0);
QQ:=SUM(IF(N=1,Q1,Q2),0);
{数据2大卖}
A3:=IF(M1,S3,0);
A4:=IF(M1,S4,0);
AA1:=SUM(IF(N=1,A3,A4),0);
B3:=IF(M2,S3,0);
B4:=IF(M2,S4,0);
BB1:=SUM(IF(N=1,B3,B4),0);
C3:=IF(M3,S3,0);
C4:=IF(M3,S4,0);
CC1:=SUM(IF(N=1,C3,C4),0);
D3:=IF(M4,S3,0);
D4:=IF(M4,S4,0);
DD1:=SUM(IF(N=1,D3,D4),0);
E3:=IF(M5,S3,0);
E4:=IF(M5,S4,0);
EE1:=SUM(IF(N=1,E3,E4),0);
F3:=IF(M6,S3,0);
F4:=IF(M6,S4,0);
FF1:=SUM(IF(N=1,F3,F4),0);
G3:=IF(M7,S3,0);
G4:=IF(M7,S4,0);
GG1:=SUM(IF(N=1,G3,G4),0);
H3:=IF(M8,S3,0);
H4:=IF(M8,S4,0);
HH1:=SUM(IF(N=1,H3,H4),0);
I3:=IF(M1,T3,0);
I4:=IF(M1,T4,0);
II1:=SUM(IF(N=1,I3,I4),0);
J3:=IF(M2,T3,0);
J4:=IF(M2,T4,0);
JJ1:=SUM(IF(N=1,J3,J4),0);
K3:=IF(M3,T3,0);
K4:=IF(M3,T4,0);
KK1:=SUM(IF(N=1,K3,K4),0);
L3:=IF(M4,T3,0);
L4:=IF(M4,T4,0);
LL1:=SUM(IF(N=1,L3,L4),0);
N3:=IF(M5,T3,0);
N4:=IF(M5,T4,0);
NN1:=SUM(IF(N=1,N3,N4),0);
O3:=IF(M6,T3,0);
O4:=IF(M6,T4,0);
OO1:=SUM(IF(N=1,O3,O4),0);
P3:=IF(M7,T3,0);
P4:=IF(M7,T4,0);
PP1:=SUM(IF(N=1,P3,P4),0);
Q3:=IF(M8,T3,0);
Q4:=IF(M8,T4,0);
QQ1:=SUM(IF(N=1,Q3,Q4),0);
{数据3总买总卖差}
MR:=IF(N=1,SUM(T1,0),SUM(T2,0));
MC:=IF(N=1,SUM(T3,0),SUM(T4,0));
MRE:=MR*DYNAINFO(11)*100/10000;
MCE:=MC*DYNAINFO(11)*100/10000;
流入资金:MRE,COLOR0000FF,linethick0,PRECIS2;
流出资金:MCE,COLORFFFF00,linethick0,PRECIS2;
MRB:=IF(N=1,SUM(S1,0),SUM(S2,0));
MCB:=IF(N=1,SUM(S3,0),SUM(S4,0));
RBG:=MR*100/MRB;
CBG:=MC*100/MCB;
JS:=MR-MC;
JE:=MRE-MCE;
净资金:JE,COLOR00FFFF,linethick0,PRECIS2;
JB:=MRB-MCB;
JC:=RBG-CBG;
RZB:=MR/DYNAINFO(8)*100;
CZB:=MC/DYNAINFO(8)*100;
MR1:=IF(N=1,T1,T2);
MC1:=IF(N=1,T3,T4);
ZMX:=(MR1-MC1)/DYNAINFO(8)*100;
CS:=IFS(N=1,'单','笔');
{表格}
DRAWRECTABS(0,0,838,48,RGB(1,1,1)),COLOR0000C0;
DRAWRECTABS(0,0,696,13,RGB(210,150,0)),COLOR0096D2;
DRAWRECTABS(696,0,838,13,RGB(210,100,0)),COLOR0064D2;
DRAWRECTABS(0,0,87,48,0),COLOR0000C0;
DRAWRECTABS(0,0,174,48,0),COLOR0000C0;
DRAWRECTABS(0,0,261,48,0),COLOR0000C0;
DRAWRECTABS(0,0,348,48,0),COLOR0000C0;
DRAWRECTABS(0,0,435,48,0),COLOR0000C0;
DRAWRECTABS(0,0,522,48,0),COLOR0000C0;
DRAWRECTABS(0,0,609,48,0),COLOR0000C0;
DRAWRECTABS(0,0,696,48,0),COLOR0000C0;
DRAWRECTABS(0,0,838,48,0),COLOR0000C0;
{显示文字数字}
DRAWTEXTABS(15,1,'9:30-10:00 10:00-10:30 10:30-11:00 11:00-11:30 13:00-13:30 13:30-14:00 14:00-14:30 14:30-15:00 '),COLORFFFFFF;
DRAWTEXTABS(36,13,NUMTOSTRN(AA,0)+CS),COLOR0000FF,ALIGN2;
DRAWTEXTABS(36,24,NUMTOSTRN(AA1,0)+CS),COLORFFFF00,ALIGN2;
DRAWTEXTABS(36,35,NUMTOSTRN(AA-AA1,0)+CS),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(86,13,NUMTOSTRN(II,0)+'手'),COLOR0000FF,ALIGN2;
DRAWTEXTABS(86,24,NUMTOSTRN(II1,0)+'手'),COLORFFFF00,ALIGN2;
DRAWTEXTABS(86,35,NUMTOSTRN(II-II1,0)+'手'),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(123,13,NUMTOSTRN(BB,0)+CS),COLOR0000FF,ALIGN2;
DRAWTEXTABS(123,24,NUMTOSTRN(BB1,0)+CS),COLORFFFF00,ALIGN2;
DRAWTEXTABS(123,35,NUMTOSTRN(BB-BB1,0)+CS),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(173,13,NUMTOSTRN(JJ,0)+'手'),COLOR0000FF,ALIGN2;
DRAWTEXTABS(173,24,NUMTOSTRN(JJ1,0)+'手'),COLORFFFF00,ALIGN2;
DRAWTEXTABS(173,35,NUMTOSTRN(JJ-JJ1,0)+'手'),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(210,13,NUMTOSTRN(CC,0)+CS),COLOR0000FF,ALIGN2;
DRAWTEXTABS(210,24,NUMTOSTRN(CC1,0)+CS),COLORFFFF00,ALIGN2;
DRAWTEXTABS(210,35,NUMTOSTRN(CC-CC1,0)+CS),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(260,13,NUMTOSTRN(KK,0)+'手'),COLOR0000FF,ALIGN2;
DRAWTEXTABS(260,24,NUMTOSTRN(KK1,0)+'手'),COLORFFFF00,ALIGN2;
DRAWTEXTABS(260,35,NUMTOSTRN(KK-KK1,0)+'手'),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(297,13,NUMTOSTRN(DD,0)+CS),COLOR0000FF,ALIGN2;
DRAWTEXTABS(297,24,NUMTOSTRN(DD1,0)+CS),COLORFFFF00,ALIGN2;
DRAWTEXTABS(297,35,NUMTOSTRN(DD-DD1,0)+CS),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(347,13,NUMTOSTRN(LL,0)+'手'),COLOR0000FF,ALIGN2;
DRAWTEXTABS(347,24,NUMTOSTRN(LL1,0)+'手'),COLORFFFF00,ALIGN2;
DRAWTEXTABS(347,35,NUMTOSTRN(LL-LL1,0)+'手'),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(384,13,NUMTOSTRN(EE,0)+CS),COLOR0000FF,ALIGN2;
DRAWTEXTABS(384,24,NUMTOSTRN(EE1,0)+CS),COLORFFFF00,ALIGN2;
DRAWTEXTABS(384,35,NUMTOSTRN(EE-EE1,0)+CS),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(434,13,NUMTOSTRN(NN,0)+'手'),COLOR0000FF,ALIGN2;
DRAWTEXTABS(434,24,NUMTOSTRN(NN1,0)+'手'),COLORFFFF00,ALIGN2;
DRAWTEXTABS(434,35,NUMTOSTRN(NN-NN1,0)+'手'),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(471,13,NUMTOSTRN(FF,0)+CS),COLOR0000FF,ALIGN2;
DRAWTEXTABS(471,24,NUMTOSTRN(FF1,0)+CS),COLORFFFF00,ALIGN2;
DRAWTEXTABS(471,35,NUMTOSTRN(FF-FF1,0)+CS),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(521,13,NUMTOSTRN(OO,0)+'手'),COLOR0000FF,ALIGN2;
DRAWTEXTABS(521,24,NUMTOSTRN(OO1,0)+'手'),COLORFFFF00,ALIGN2;
DRAWTEXTABS(521,35,NUMTOSTRN(OO-OO1,0)+'手'),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(558,13,NUMTOSTRN(GG,0)+CS),COLOR0000FF,ALIGN2;
DRAWTEXTABS(558,24,NUMTOSTRN(GG1,0)+CS),COLORFFFF00,ALIGN2;
DRAWTEXTABS(558,35,NUMTOSTRN(GG-GG1,0)+CS),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(608,13,NUMTOSTRN(PP,0)+'手'),COLOR0000FF,ALIGN2;
DRAWTEXTABS(608,24,NUMTOSTRN(PP1,0)+'手'),COLORFFFF00,ALIGN2;
DRAWTEXTABS(608,35,NUMTOSTRN(PP-PP1,0)+'手'),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(645,13,NUMTOSTRN(HH,0)+CS),COLOR0000FF,ALIGN2;
DRAWTEXTABS(645,24,NUMTOSTRN(HH1,0)+CS),COLORFFFF00,ALIGN2;
DRAWTEXTABS(645,35,NUMTOSTRN(HH-HH1,0)+CS),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(695,13,NUMTOSTRN(QQ,0)+'手'),COLOR0000FF,ALIGN2;
DRAWTEXTABS(695,24,NUMTOSTRN(QQ1,0)+'手'),COLORFFFF00,ALIGN2;
DRAWTEXTABS(695,35,NUMTOSTRN(QQ-QQ1,0)+'手'),COLOR00FFFF,ALIGN2;
DRAWRECTABS(767,2,767+RZB,12,RGB(255,30,30)),COLORFFFFFF;
DRAWRECTABS(767,2,767-CZB,12,RGB(30,30,255)),COLORFFFFFF;
DRAWTEXTABS(733,1,NUMTOSTRN(CZB,2)+'%'),ALIGN2,COLOR00FFFF;
DRAWTEXTABS(837,1,NUMTOSTRN(RZB,2)+'%'),ALIGN2,COLOR00FFFF;
DRAWTEXTABS(740,13,NUMTOSTRN(MR,0)+'手'),COLOR4848FF,ALIGN2;
DRAWTEXTABS(740,24,NUMTOSTRN(MC,0)+'手'),COLOR48FF48,ALIGN2;
DRAWTEXTABS(740,35,NUMTOSTRN(JS,0)+'手'),COLOREEEEEE,ALIGN2;
DRAWTEXTABS(773,13,NUMTOSTRN(MRB,0)+'笔'),COLOR4848FF,ALIGN2;
DRAWTEXTABS(773,24,NUMTOSTRN(MCB,0)+'笔'),COLOR48FF48,ALIGN2;
DRAWTEXTABS(773,35,NUMTOSTRN(JB,0)+'笔'),COLOREEEEEE,ALIGN2;
DRAWTEXTABS(837,13,NUMTOSTRN(RBG,0)+'股/笔'),COLOR4848FF,ALIGN2;
DRAWTEXTABS(837,24,NUMTOSTRN(CBG,0)+'股/笔'),COLOR48FF48,ALIGN2;
DRAWTEXTABS(837,35,NUMTOSTRN(JC,0)+'股/笔'),COLOREEEEEE,ALIGN2;
{大户30分}
input:N(1,1,2);
TODAY:="分时DDX.DDX累积"<>0;{判断是否有正版数据}
TODAY1:="LXDDX.DDX#day"=0;{判断是否有雨杨数据}
DRAWTEXTABS(680,-12,IFS(TODAY,'正版数据',IFS(TODAY1,'引入数据','雨杨数据 '))),LINETHICK1,colorwhite;
DRAWTEXTABS(752,-12,IFS(N=1,'逐单','逐笔')),LINETHICK1,colorwhite;
ZT1:="wd.o12"-"wd.o13"{ORDERVOL(1,2)-ORDERVOL(1,3)};
YT1累积:=("DDEDATA@BIGORDERSCALE"(1,2)-"DDEDATA@BIGORDERSCALE" (1,3))*SUM(VOL,0);
YT1:=YT1累积-REF(YT1累积,1);
RT1累积:="wd.大单买#day"*SUM(VOL,0);
RT1:=RT1累积-REF(RT1累积,1);
T1:=IF(TODAY,ZT1,IF(TODAY1,RT1,YT1));
T2:="wd.t12"-"wd.t13"{TRANSACTVOL(1,2)-TRANSACTVOL(1,3)};
ZT3:="wd.o22"-"wd.o23"{ORDERVOL(2,2)-ORDERVOL(2,3)};
YT3累积:=("DDEDATA@BIGORDERSCALE"(2,2)-"DDEDATA@BIGORDERSCALE" (2,3))*SUM(VOL,0);
YT3:=YT3累积-REF(YT3累积,1);
RT3累积:="wd.大单卖#day"*SUM(VOL,0);
RT3:=RT3累积-REF(RT3累积,1);
T3:=IF(TODAY,ZT3,IF(TODAY1,RT3,YT3));
T4:="wd.t22"-"wd.t23"{TRANSACTVOL(2,2)-TRANSACTVOL(2,3)};
ZS1:="wd.d12"-"wd.d13"{ORDERNUM(1,2)-ORDERNUM(1,3)};
YS1:="DDEDATA@BIGORDERSCALE"(1,2)-"DDEDATA@BIGORDERSCALE"(1,3);
RS1:="wd.大单买#day";
S1:=IF(TODAY,ZS1,IF(TODAY1,RS1,YS1));
S2:="wd.l12"-"wd.l13"{TRANSACTNUM(1,2)-TRANSACTNUM(1,3)};
ZS3:="wd.d22"-"wd.d23"{ORDERNUM(2,2)-ORDERNUM(2,3)};
YS3:="DDEDATA@BIGORDERSCALE"(2,2)-"DDEDATA@BIGORDERSCALE"(2,3);
RS3:="wd.大单卖#day";
S3:=IF(TODAY,ZS3,IF(TODAY1,RS3,YS3));
S4:="wd.l22"-"wd.l23"{TRANSACTNUM(2,2)-TRANSACTNUM(2,3)};
M1:=TIME<=100000;
M2:=TIME<=103000 AND TIME>100000;
M3:=TIME<=110000 AND TIME>103000;
M4:=TIME<=113000 AND TIME>110000;
M5:=TIME<=133000 AND TIME>130000;
M6:=TIME<=140000 AND TIME>133000;
M7:=TIME<=143000 AND TIME>140000;
M8:=TIME<=150000 AND TIME>143000;
{数据1大买}
A1:=IF(M1,S1,0);
A2:=IF(M1,S2,0);
AA:=SUM(IF(N=1,A1,A2),0);
B1:=IF(M2,S1,0);
B2:=IF(M2,S2,0);
BB:=SUM(IF(N=1,B1,B2),0);
C1:=IF(M3,S1,0);
C2:=IF(M3,S2,0);
CC:=SUM(IF(N=1,C1,C2),0);
D1:=IF(M4,S1,0);
D2:=IF(M4,S2,0);
DD:=SUM(IF(N=1,D1,D2),0);
E1:=IF(M5,S1,0);
E2:=IF(M5,S2,0);
EE:=SUM(IF(N=1,E1,E2),0);
F1:=IF(M6,S1,0);
F2:=IF(M6,S2,0);
FF:=SUM(IF(N=1,F1,F2),0);
G1:=IF(M7,S1,0);
G2:=IF(M7,S2,0);
GG:=SUM(IF(N=1,G1,G2),0);
H1:=IF(M8,S1,0);
H2:=IF(M8,S2,0);
HH:=SUM(IF(N=1,H1,H2),0);
I1:=IF(M1,T1,0);
I2:=IF(M1,T2,0);
II:=SUM(IF(N=1,I1,I2),0);
J1:=IF(M2,T1,0);
J2:=IF(M2,T2,0);
JJ:=SUM(IF(N=1,J1,J2),0);
K1:=IF(M3,T1,0);
K2:=IF(M3,T2,0);
KK:=SUM(IF(N=1,K1,K2),0);
L1:=IF(M4,T1,0);
L2:=IF(M4,T2,0);
LL:=SUM(IF(N=1,L1,L2),0);
N1:=IF(M5,T1,0);
N2:=IF(M5,T2,0);
NN:=SUM(IF(N=1,N1,N2),0);
O1:=IF(M6,T1,0);
O2:=IF(M6,T2,0);
OO:=SUM(IF(N=1,O1,O2),0);
P1:=IF(M7,T1,0);
P2:=IF(M7,T2,0);
PP:=SUM(IF(N=1,P1,P2),0);
Q1:=IF(M8,T1,0);
Q2:=IF(M8,T2,0);
QQ:=SUM(IF(N=1,Q1,Q2),0);
{数据2大卖}
A3:=IF(M1,S3,0);
A4:=IF(M1,S4,0);
AA1:=SUM(IF(N=1,A3,A4),0);
B3:=IF(M2,S3,0);
B4:=IF(M2,S4,0);
BB1:=SUM(IF(N=1,B3,B4),0);
C3:=IF(M3,S3,0);
C4:=IF(M3,S4,0);
CC1:=SUM(IF(N=1,C3,C4),0);
D3:=IF(M4,S3,0);
D4:=IF(M4,S4,0);
DD1:=SUM(IF(N=1,D3,D4),0);
E3:=IF(M5,S3,0);
E4:=IF(M5,S4,0);
EE1:=SUM(IF(N=1,E3,E4),0);
F3:=IF(M6,S3,0);
F4:=IF(M6,S4,0);
FF1:=SUM(IF(N=1,F3,F4),0);
G3:=IF(M7,S3,0);
G4:=IF(M7,S4,0);
GG1:=SUM(IF(N=1,G3,G4),0);
H3:=IF(M8,S3,0);
H4:=IF(M8,S4,0);
HH1:=SUM(IF(N=1,H3,H4),0);
I3:=IF(M1,T3,0);
I4:=IF(M1,T4,0);
II1:=SUM(IF(N=1,I3,I4),0);
J3:=IF(M2,T3,0);
J4:=IF(M2,T4,0);
JJ1:=SUM(IF(N=1,J3,J4),0);
K3:=IF(M3,T3,0);
K4:=IF(M3,T4,0);
KK1:=SUM(IF(N=1,K3,K4),0);
L3:=IF(M4,T3,0);
L4:=IF(M4,T4,0);
LL1:=SUM(IF(N=1,L3,L4),0);
N3:=IF(M5,T3,0);
N4:=IF(M5,T4,0);
NN1:=SUM(IF(N=1,N3,N4),0);
O3:=IF(M6,T3,0);
O4:=IF(M6,T4,0);
OO1:=SUM(IF(N=1,O3,O4),0);
P3:=IF(M7,T3,0);
P4:=IF(M7,T4,0);
PP1:=SUM(IF(N=1,P3,P4),0);
Q3:=IF(M8,T3,0);
Q4:=IF(M8,T4,0);
QQ1:=SUM(IF(N=1,Q3,Q4),0);
{数据3总买总卖差}
MR:=IF(N=1,SUM(T1,0),SUM(T2,0));
MC:=IF(N=1,SUM(T3,0),SUM(T4,0));
MRE:=MR*DYNAINFO(11)*100/10000;
MCE:=MC*DYNAINFO(11)*100/10000;
流入资金:MRE,COLOR0000FF,linethick0,PRECIS2;
流出资金:MCE,COLORFFFF00,linethick0,PRECIS2;
MRB:=IF(N=1,SUM(S1,0),SUM(S2,0));
MCB:=IF(N=1,SUM(S3,0),SUM(S4,0));
RBG:=MR*100/MRB;
CBG:=MC*100/MCB;
JS:=MR-MC;
JE:=MRE-MCE;
净资金:JE,COLOR00FFFF,linethick0,PRECIS2;
JB:=MRB-MCB;
JC:=RBG-CBG;
RZB:=MR/DYNAINFO(8)*100;
CZB:=MC/DYNAINFO(8)*100;
MR1:=IF(N=1,T1,T2);
MC1:=IF(N=1,T3,T4);
ZMX:=(MR1-MC1)/DYNAINFO(8)*100;
CS:=IFS(N=1,'单','笔');
{表格}
DRAWRECTABS(0,0,838,48,RGB(1,1,1)),COLOR0000C0;
DRAWRECTABS(0,0,696,13,RGB(210,150,0)),COLOR0096D2;
DRAWRECTABS(696,0,838,13,RGB(210,100,0)),COLOR0064D2;
DRAWRECTABS(0,0,87,48,0),COLOR0000C0;
DRAWRECTABS(0,0,174,48,0),COLOR0000C0;
DRAWRECTABS(0,0,261,48,0),COLOR0000C0;
DRAWRECTABS(0,0,348,48,0),COLOR0000C0;
DRAWRECTABS(0,0,435,48,0),COLOR0000C0;
DRAWRECTABS(0,0,522,48,0),COLOR0000C0;
DRAWRECTABS(0,0,609,48,0),COLOR0000C0;
DRAWRECTABS(0,0,696,48,0),COLOR0000C0;
DRAWRECTABS(0,0,838,48,0),COLOR0000C0;
{显示文字数字}
DRAWTEXTABS(15,1,'9:30-10:00 10:00-10:30 10:30-11:00 11:00-11:30 13:00-13:30 13:30-14:00 14:00-14:30 14:30-15:00 '),COLORFFFFFF;
DRAWTEXTABS(36,13,NUMTOSTRN(AA,0)+CS),COLOR0000FF,ALIGN2;
DRAWTEXTABS(36,24,NUMTOSTRN(AA1,0)+CS),COLORFFFF00,ALIGN2;
DRAWTEXTABS(36,35,NUMTOSTRN(AA-AA1,0)+CS),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(86,13,NUMTOSTRN(II,0)+'手'),COLOR0000FF,ALIGN2;
DRAWTEXTABS(86,24,NUMTOSTRN(II1,0)+'手'),COLORFFFF00,ALIGN2;
DRAWTEXTABS(86,35,NUMTOSTRN(II-II1,0)+'手'),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(123,13,NUMTOSTRN(BB,0)+CS),COLOR0000FF,ALIGN2;
DRAWTEXTABS(123,24,NUMTOSTRN(BB1,0)+CS),COLORFFFF00,ALIGN2;
DRAWTEXTABS(123,35,NUMTOSTRN(BB-BB1,0)+CS),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(173,13,NUMTOSTRN(JJ,0)+'手'),COLOR0000FF,ALIGN2;
DRAWTEXTABS(173,24,NUMTOSTRN(JJ1,0)+'手'),COLORFFFF00,ALIGN2;
DRAWTEXTABS(173,35,NUMTOSTRN(JJ-JJ1,0)+'手'),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(210,13,NUMTOSTRN(CC,0)+CS),COLOR0000FF,ALIGN2;
DRAWTEXTABS(210,24,NUMTOSTRN(CC1,0)+CS),COLORFFFF00,ALIGN2;
DRAWTEXTABS(210,35,NUMTOSTRN(CC-CC1,0)+CS),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(260,13,NUMTOSTRN(KK,0)+'手'),COLOR0000FF,ALIGN2;
DRAWTEXTABS(260,24,NUMTOSTRN(KK1,0)+'手'),COLORFFFF00,ALIGN2;
DRAWTEXTABS(260,35,NUMTOSTRN(KK-KK1,0)+'手'),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(297,13,NUMTOSTRN(DD,0)+CS),COLOR0000FF,ALIGN2;
DRAWTEXTABS(297,24,NUMTOSTRN(DD1,0)+CS),COLORFFFF00,ALIGN2;
DRAWTEXTABS(297,35,NUMTOSTRN(DD-DD1,0)+CS),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(347,13,NUMTOSTRN(LL,0)+'手'),COLOR0000FF,ALIGN2;
DRAWTEXTABS(347,24,NUMTOSTRN(LL1,0)+'手'),COLORFFFF00,ALIGN2;
DRAWTEXTABS(347,35,NUMTOSTRN(LL-LL1,0)+'手'),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(384,13,NUMTOSTRN(EE,0)+CS),COLOR0000FF,ALIGN2;
DRAWTEXTABS(384,24,NUMTOSTRN(EE1,0)+CS),COLORFFFF00,ALIGN2;
DRAWTEXTABS(384,35,NUMTOSTRN(EE-EE1,0)+CS),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(434,13,NUMTOSTRN(NN,0)+'手'),COLOR0000FF,ALIGN2;
DRAWTEXTABS(434,24,NUMTOSTRN(NN1,0)+'手'),COLORFFFF00,ALIGN2;
DRAWTEXTABS(434,35,NUMTOSTRN(NN-NN1,0)+'手'),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(471,13,NUMTOSTRN(FF,0)+CS),COLOR0000FF,ALIGN2;
DRAWTEXTABS(471,24,NUMTOSTRN(FF1,0)+CS),COLORFFFF00,ALIGN2;
DRAWTEXTABS(471,35,NUMTOSTRN(FF-FF1,0)+CS),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(521,13,NUMTOSTRN(OO,0)+'手'),COLOR0000FF,ALIGN2;
DRAWTEXTABS(521,24,NUMTOSTRN(OO1,0)+'手'),COLORFFFF00,ALIGN2;
DRAWTEXTABS(521,35,NUMTOSTRN(OO-OO1,0)+'手'),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(558,13,NUMTOSTRN(GG,0)+CS),COLOR0000FF,ALIGN2;
DRAWTEXTABS(558,24,NUMTOSTRN(GG1,0)+CS),COLORFFFF00,ALIGN2;
DRAWTEXTABS(558,35,NUMTOSTRN(GG-GG1,0)+CS),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(608,13,NUMTOSTRN(PP,0)+'手'),COLOR0000FF,ALIGN2;
DRAWTEXTABS(608,24,NUMTOSTRN(PP1,0)+'手'),COLORFFFF00,ALIGN2;
DRAWTEXTABS(608,35,NUMTOSTRN(PP-PP1,0)+'手'),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(645,13,NUMTOSTRN(HH,0)+CS),COLOR0000FF,ALIGN2;
DRAWTEXTABS(645,24,NUMTOSTRN(HH1,0)+CS),COLORFFFF00,ALIGN2;
DRAWTEXTABS(645,35,NUMTOSTRN(HH-HH1,0)+CS),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(695,13,NUMTOSTRN(QQ,0)+'手'),COLOR0000FF,ALIGN2;
DRAWTEXTABS(695,24,NUMTOSTRN(QQ1,0)+'手'),COLORFFFF00,ALIGN2;
DRAWTEXTABS(695,35,NUMTOSTRN(QQ-QQ1,0)+'手'),COLOR00FFFF,ALIGN2;
DRAWRECTABS(767,2,767+RZB,12,RGB(255,30,30)),COLORFFFFFF;
DRAWRECTABS(767,2,767-CZB,12,RGB(30,30,255)),COLORFFFFFF;
DRAWTEXTABS(733,1,NUMTOSTRN(CZB,2)+'%'),ALIGN2,COLOR00FFFF;
DRAWTEXTABS(837,1,NUMTOSTRN(RZB,2)+'%'),ALIGN2,COLOR00FFFF;
DRAWTEXTABS(740,13,NUMTOSTRN(MR,0)+'手'),COLOR4848FF,ALIGN2;
DRAWTEXTABS(740,24,NUMTOSTRN(MC,0)+'手'),COLOR48FF48,ALIGN2;
DRAWTEXTABS(740,35,NUMTOSTRN(JS,0)+'手'),COLOREEEEEE,ALIGN2;
DRAWTEXTABS(773,13,NUMTOSTRN(MRB,0)+'笔'),COLOR4848FF,ALIGN2;
DRAWTEXTABS(773,24,NUMTOSTRN(MCB,0)+'笔'),COLOR48FF48,ALIGN2;
DRAWTEXTABS(773,35,NUMTOSTRN(JB,0)+'笔'),COLOREEEEEE,ALIGN2;
DRAWTEXTABS(837,13,NUMTOSTRN(RBG,0)+'股/笔'),COLOR4848FF,ALIGN2;
DRAWTEXTABS(837,24,NUMTOSTRN(CBG,0)+'股/笔'),COLOR48FF48,ALIGN2;
DRAWTEXTABS(837,35,NUMTOSTRN(JC,0)+'股/笔'),COLOREEEEEE,ALIGN2;
{中户30分}
input:N(1,1,2);
TODAY:="分时DDX.DDX累积"<>0;{判断是否有正版数据}
TODAY1:="LXDDX.DDX#day"=0;{判断是否有雨杨数据}
DRAWTEXTABS(680,-12,IFS(TODAY,'正版数据',IFS(TODAY1,'引入数据','雨杨数据 '))),LINETHICK1,colorwhite;
DRAWTEXTABS(752,-12,IFS(N=1,'逐单','逐笔')),LINETHICK1,colorwhite;
ZT1:="wd.o11"-"wd.o12"{ORDERVOL(1,1)-ORDERVOL(1,2)};
YT1累积:=("DDEDATA@BIGORDERSCALE"(1,1)-"DDEDATA@BIGORDERSCALE" (1,2))*SUM(VOL,0);
YT1:=YT1累积-REF(YT1累积,1);
RT1累积:="wd.中单买#day"*SUM(VOL,0);
RT1:=RT1累积-REF(RT1累积,1);
T1:=IF(TODAY,ZT1,IF(TODAY1,RT1,YT1));
T2:="wd.t11"-"wd.t12"{TRANSACTVOL(1,1)-TRANSACTVOL(1,2)};
ZT3:="wd.o21"-"wd.o22"{ORDERVOL(2,1)-ORDERVOL(2,2)};
YT3累积:=("DDEDATA@BIGORDERSCALE"(2,1)-"DDEDATA@BIGORDERSCALE" (2,2))*SUM(VOL,0);
YT3:=YT3累积-REF(YT3累积,1);
RT3累积:="wd.中单卖#day"*SUM(VOL,0);
RT3:=RT3累积-REF(RT3累积,1);
T3:=IF(TODAY,ZT3,IF(TODAY1,RT3,YT3));
T4:="wd.t21"-"wd.t22"{TRANSACTVOL(2,1)-TRANSACTVOL(2,2)};
ZS1:="wd.d11"-"wd.d12"{ORDERNUM(1,1)-ORDERNUM(1,2)};
YS1:="DDEDATA@BIGORDERSCALE"(1,1)-"DDEDATA@BIGORDERSCALE"(1,2);
RS1:="wd.中单买#day";
S1:=IF(TODAY,ZS1,IF(TODAY1,RS1,YS1));
S2:="wd.l11"-"wd.l12"{TRANSACTNUM(1,1)-TRANSACTNUM(1,2)};
ZS3:="wd.d21"-"wd.d22"{ORDERNUM(2,1)-ORDERNUM(2,2)};
YS3:="DDEDATA@BIGORDERSCALE"(2,1)-"DDEDATA@BIGORDERSCALE"(2,2);
RS3:="wd.中单卖#day";
S3:=IF(TODAY,ZS3,IF(TODAY1,RS3,YS3));
S4:="wd.l21"-"wd.l22"{TRANSACTNUM(2,1)-TRANSACTNUM(2,2)};
M1:=TIME<=100000;
M2:=TIME<=103000 AND TIME>100000;
M3:=TIME<=110000 AND TIME>103000;
M4:=TIME<=113000 AND TIME>110000;
M5:=TIME<=133000 AND TIME>130000;
M6:=TIME<=140000 AND TIME>133000;
M7:=TIME<=143000 AND TIME>140000;
M8:=TIME<=150000 AND TIME>143000;
{数据1大买}
A1:=IF(M1,S1,0);
A2:=IF(M1,S2,0);
AA:=SUM(IF(N=1,A1,A2),0);
B1:=IF(M2,S1,0);
B2:=IF(M2,S2,0);
BB:=SUM(IF(N=1,B1,B2),0);
C1:=IF(M3,S1,0);
C2:=IF(M3,S2,0);
CC:=SUM(IF(N=1,C1,C2),0);
D1:=IF(M4,S1,0);
D2:=IF(M4,S2,0);
DD:=SUM(IF(N=1,D1,D2),0);
E1:=IF(M5,S1,0);
E2:=IF(M5,S2,0);
EE:=SUM(IF(N=1,E1,E2),0);
F1:=IF(M6,S1,0);
F2:=IF(M6,S2,0);
FF:=SUM(IF(N=1,F1,F2),0);
G1:=IF(M7,S1,0);
G2:=IF(M7,S2,0);
GG:=SUM(IF(N=1,G1,G2),0);
H1:=IF(M8,S1,0);
H2:=IF(M8,S2,0);
HH:=SUM(IF(N=1,H1,H2),0);
I1:=IF(M1,T1,0);
I2:=IF(M1,T2,0);
II:=SUM(IF(N=1,I1,I2),0);
J1:=IF(M2,T1,0);
J2:=IF(M2,T2,0);
JJ:=SUM(IF(N=1,J1,J2),0);
K1:=IF(M3,T1,0);
K2:=IF(M3,T2,0);
KK:=SUM(IF(N=1,K1,K2),0);
L1:=IF(M4,T1,0);
L2:=IF(M4,T2,0);
LL:=SUM(IF(N=1,L1,L2),0);
N1:=IF(M5,T1,0);
N2:=IF(M5,T2,0);
NN:=SUM(IF(N=1,N1,N2),0);
O1:=IF(M6,T1,0);
O2:=IF(M6,T2,0);
OO:=SUM(IF(N=1,O1,O2),0);
P1:=IF(M7,T1,0);
P2:=IF(M7,T2,0);
PP:=SUM(IF(N=1,P1,P2),0);
Q1:=IF(M8,T1,0);
Q2:=IF(M8,T2,0);
QQ:=SUM(IF(N=1,Q1,Q2),0);
{数据2大卖}
A3:=IF(M1,S3,0);
A4:=IF(M1,S4,0);
AA1:=SUM(IF(N=1,A3,A4),0);
B3:=IF(M2,S3,0);
B4:=IF(M2,S4,0);
BB1:=SUM(IF(N=1,B3,B4),0);
C3:=IF(M3,S3,0);
C4:=IF(M3,S4,0);
CC1:=SUM(IF(N=1,C3,C4),0);
D3:=IF(M4,S3,0);
D4:=IF(M4,S4,0);
DD1:=SUM(IF(N=1,D3,D4),0);
E3:=IF(M5,S3,0);
E4:=IF(M5,S4,0);
EE1:=SUM(IF(N=1,E3,E4),0);
F3:=IF(M6,S3,0);
F4:=IF(M6,S4,0);
FF1:=SUM(IF(N=1,F3,F4),0);
G3:=IF(M7,S3,0);
G4:=IF(M7,S4,0);
GG1:=SUM(IF(N=1,G3,G4),0);
H3:=IF(M8,S3,0);
H4:=IF(M8,S4,0);
HH1:=SUM(IF(N=1,H3,H4),0);
I3:=IF(M1,T3,0);
I4:=IF(M1,T4,0);
II1:=SUM(IF(N=1,I3,I4),0);
J3:=IF(M2,T3,0);
J4:=IF(M2,T4,0);
JJ1:=SUM(IF(N=1,J3,J4),0);
K3:=IF(M3,T3,0);
K4:=IF(M3,T4,0);
KK1:=SUM(IF(N=1,K3,K4),0);
L3:=IF(M4,T3,0);
L4:=IF(M4,T4,0);
LL1:=SUM(IF(N=1,L3,L4),0);
N3:=IF(M5,T3,0);
N4:=IF(M5,T4,0);
NN1:=SUM(IF(N=1,N3,N4),0);
O3:=IF(M6,T3,0);
O4:=IF(M6,T4,0);
OO1:=SUM(IF(N=1,O3,O4),0);
P3:=IF(M7,T3,0);
P4:=IF(M7,T4,0);
PP1:=SUM(IF(N=1,P3,P4),0);
Q3:=IF(M8,T3,0);
Q4:=IF(M8,T4,0);
QQ1:=SUM(IF(N=1,Q3,Q4),0);
{数据3总买总卖差}
MR:=IF(N=1,SUM(T1,0),SUM(T2,0));
MC:=IF(N=1,SUM(T3,0),SUM(T4,0));
MRE:=MR*DYNAINFO(11)*100/10000;
MCE:=MC*DYNAINFO(11)*100/10000;
流入资金:MRE,COLOR0000FF,linethick0,PRECIS2;
流出资金:MCE,COLORFFFF00,linethick0,PRECIS2;
MRB:=IF(N=1,SUM(S1,0),SUM(S2,0));
MCB:=IF(N=1,SUM(S3,0),SUM(S4,0));
RBG:=MR*100/MRB;
CBG:=MC*100/MCB;
JS:=MR-MC;
JE:=MRE-MCE;
净资金:JE,COLOR00FFFF,linethick0,PRECIS2;
JB:=MRB-MCB;
JC:=RBG-CBG;
RZB:=MR/DYNAINFO(8)*100;
CZB:=MC/DYNAINFO(8)*100;
MR1:=IF(N=1,T1,T2);
MC1:=IF(N=1,T3,T4);
ZMX:=(MR1-MC1)/DYNAINFO(8)*100;
CS:=IFS(N=1,'单','笔');
{表格}
DRAWRECTABS(0,0,838,48,RGB(1,1,1)),COLOR0000C0;
DRAWRECTABS(0,0,696,13,RGB(210,150,0)),COLOR0096D2;
DRAWRECTABS(696,0,838,13,RGB(210,100,0)),COLOR0064D2;
DRAWRECTABS(0,0,87,48,0),COLOR0000C0;
DRAWRECTABS(0,0,174,48,0),COLOR0000C0;
DRAWRECTABS(0,0,261,48,0),COLOR0000C0;
DRAWRECTABS(0,0,348,48,0),COLOR0000C0;
DRAWRECTABS(0,0,435,48,0),COLOR0000C0;
DRAWRECTABS(0,0,522,48,0),COLOR0000C0;
DRAWRECTABS(0,0,609,48,0),COLOR0000C0;
DRAWRECTABS(0,0,696,48,0),COLOR0000C0;
DRAWRECTABS(0,0,838,48,0),COLOR0000C0;
{显示文字数字}
DRAWTEXTABS(15,1,'9:30-10:00 10:00-10:30 10:30-11:00 11:00-11:30 13:00-13:30 13:30-14:00 14:00-14:30 14:30-15:00 '),COLORFFFFFF;
DRAWTEXTABS(36,13,NUMTOSTRN(AA,0)+CS),COLOR0000FF,ALIGN2;
DRAWTEXTABS(36,24,NUMTOSTRN(AA1,0)+CS),COLORFFFF00,ALIGN2;
DRAWTEXTABS(36,35,NUMTOSTRN(AA-AA1,0)+CS),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(86,13,NUMTOSTRN(II,0)+'手'),COLOR0000FF,ALIGN2;
DRAWTEXTABS(86,24,NUMTOSTRN(II1,0)+'手'),COLORFFFF00,ALIGN2;
DRAWTEXTABS(86,35,NUMTOSTRN(II-II1,0)+'手'),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(123,13,NUMTOSTRN(BB,0)+CS),COLOR0000FF,ALIGN2;
DRAWTEXTABS(123,24,NUMTOSTRN(BB1,0)+CS),COLORFFFF00,ALIGN2;
DRAWTEXTABS(123,35,NUMTOSTRN(BB-BB1,0)+CS),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(173,13,NUMTOSTRN(JJ,0)+'手'),COLOR0000FF,ALIGN2;
DRAWTEXTABS(173,24,NUMTOSTRN(JJ1,0)+'手'),COLORFFFF00,ALIGN2;
DRAWTEXTABS(173,35,NUMTOSTRN(JJ-JJ1,0)+'手'),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(210,13,NUMTOSTRN(CC,0)+CS),COLOR0000FF,ALIGN2;
DRAWTEXTABS(210,24,NUMTOSTRN(CC1,0)+CS),COLORFFFF00,ALIGN2;
DRAWTEXTABS(210,35,NUMTOSTRN(CC-CC1,0)+CS),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(260,13,NUMTOSTRN(KK,0)+'手'),COLOR0000FF,ALIGN2;
DRAWTEXTABS(260,24,NUMTOSTRN(KK1,0)+'手'),COLORFFFF00,ALIGN2;
DRAWTEXTABS(260,35,NUMTOSTRN(KK-KK1,0)+'手'),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(297,13,NUMTOSTRN(DD,0)+CS),COLOR0000FF,ALIGN2;
DRAWTEXTABS(297,24,NUMTOSTRN(DD1,0)+CS),COLORFFFF00,ALIGN2;
DRAWTEXTABS(297,35,NUMTOSTRN(DD-DD1,0)+CS),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(347,13,NUMTOSTRN(LL,0)+'手'),COLOR0000FF,ALIGN2;
DRAWTEXTABS(347,24,NUMTOSTRN(LL1,0)+'手'),COLORFFFF00,ALIGN2;
DRAWTEXTABS(347,35,NUMTOSTRN(LL-LL1,0)+'手'),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(384,13,NUMTOSTRN(EE,0)+CS),COLOR0000FF,ALIGN2;
DRAWTEXTABS(384,24,NUMTOSTRN(EE1,0)+CS),COLORFFFF00,ALIGN2;
DRAWTEXTABS(384,35,NUMTOSTRN(EE-EE1,0)+CS),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(434,13,NUMTOSTRN(NN,0)+'手'),COLOR0000FF,ALIGN2;
DRAWTEXTABS(434,24,NUMTOSTRN(NN1,0)+'手'),COLORFFFF00,ALIGN2;
DRAWTEXTABS(434,35,NUMTOSTRN(NN-NN1,0)+'手'),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(471,13,NUMTOSTRN(FF,0)+CS),COLOR0000FF,ALIGN2;
DRAWTEXTABS(471,24,NUMTOSTRN(FF1,0)+CS),COLORFFFF00,ALIGN2;
DRAWTEXTABS(471,35,NUMTOSTRN(FF-FF1,0)+CS),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(521,13,NUMTOSTRN(OO,0)+'手'),COLOR0000FF,ALIGN2;
DRAWTEXTABS(521,24,NUMTOSTRN(OO1,0)+'手'),COLORFFFF00,ALIGN2;
DRAWTEXTABS(521,35,NUMTOSTRN(OO-OO1,0)+'手'),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(558,13,NUMTOSTRN(GG,0)+CS),COLOR0000FF,ALIGN2;
DRAWTEXTABS(558,24,NUMTOSTRN(GG1,0)+CS),COLORFFFF00,ALIGN2;
DRAWTEXTABS(558,35,NUMTOSTRN(GG-GG1,0)+CS),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(608,13,NUMTOSTRN(PP,0)+'手'),COLOR0000FF,ALIGN2;
DRAWTEXTABS(608,24,NUMTOSTRN(PP1,0)+'手'),COLORFFFF00,ALIGN2;
DRAWTEXTABS(608,35,NUMTOSTRN(PP-PP1,0)+'手'),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(645,13,NUMTOSTRN(HH,0)+CS),COLOR0000FF,ALIGN2;
DRAWTEXTABS(645,24,NUMTOSTRN(HH1,0)+CS),COLORFFFF00,ALIGN2;
DRAWTEXTABS(645,35,NUMTOSTRN(HH-HH1,0)+CS),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(695,13,NUMTOSTRN(QQ,0)+'手'),COLOR0000FF,ALIGN2;
DRAWTEXTABS(695,24,NUMTOSTRN(QQ1,0)+'手'),COLORFFFF00,ALIGN2;
DRAWTEXTABS(695,35,NUMTOSTRN(QQ-QQ1,0)+'手'),COLOR00FFFF,ALIGN2;
DRAWRECTABS(767,2,767+RZB,12,RGB(255,30,30)),COLORFFFFFF;
DRAWRECTABS(767,2,767-CZB,12,RGB(30,30,255)),COLORFFFFFF;
DRAWTEXTABS(733,1,NUMTOSTRN(CZB,2)+'%'),ALIGN2,COLOR00FFFF;
DRAWTEXTABS(837,1,NUMTOSTRN(RZB,2)+'%'),ALIGN2,COLOR00FFFF;
DRAWTEXTABS(740,13,NUMTOSTRN(MR,0)+'手'),COLOR4848FF,ALIGN2;
DRAWTEXTABS(740,24,NUMTOSTRN(MC,0)+'手'),COLOR48FF48,ALIGN2;
DRAWTEXTABS(740,35,NUMTOSTRN(JS,0)+'手'),COLOREEEEEE,ALIGN2;
DRAWTEXTABS(773,13,NUMTOSTRN(MRB,0)+'笔'),COLOR4848FF,ALIGN2;
DRAWTEXTABS(773,24,NUMTOSTRN(MCB,0)+'笔'),COLOR48FF48,ALIGN2;
DRAWTEXTABS(773,35,NUMTOSTRN(JB,0)+'笔'),COLOREEEEEE,ALIGN2;
DRAWTEXTABS(837,13,NUMTOSTRN(RBG,0)+'股/笔'),COLOR4848FF,ALIGN2;
DRAWTEXTABS(837,24,NUMTOSTRN(CBG,0)+'股/笔'),COLOR48FF48,ALIGN2;
DRAWTEXTABS(837,35,NUMTOSTRN(JC,0)+'股/笔'),COLOREEEEEE,ALIGN2;
{散户30分}
input:N(1,1,2);
TODAY:="分时DDX.DDX累积"<>0;{判断是否有正版数据}
TODAY1:="LXDDX.DDX#day"=0;{判断是否有雨杨数据}
DRAWTEXTABS(680,-12,IFS(TODAY,'正版数据',IFS(TODAY1,'引入数据','雨杨数据 '))),LINETHICK1,colorwhite;
DRAWTEXTABS(752,-12,IFS(N=1,'逐单','逐笔')),LINETHICK1,colorwhite;
ZT1:="wd.o10"-"wd.o11"{ORDERVOL(1,0)-ORDERVOL(1,1)};
YT1累积:=("DDEDATA@BIGORDERSCALE"(1,0)-"DDEDATA@BIGORDERSCALE" (1,1))*SUM(VOL,0);
YT1:=YT1累积-REF(YT1累积,1);
RT1累积:="wd.散单买#day"*SUM(VOL,0);
RT1:=RT1累积-REF(RT1累积,1);
T1:=IF(TODAY,ZT1,IF(TODAY1,RT1,YT1));
T2:="wd.t10"-"wd.t11"{TRANSACTVOL(1,0)-TRANSACTVOL(1,1)};
ZT3:="wd.o20"-"wd.o21"{ORDERVOL(2,0)-ORDERVOL(2,1)};
YT3累积:=("DDEDATA@BIGORDERSCALE"(2,0)-"DDEDATA@BIGORDERSCALE" (2,1))*SUM(VOL,0);
YT3:=YT3累积-REF(YT3累积,1);
RT3累积:="wd.散单卖#day"*SUM(VOL,0);
RT3:=RT3累积-REF(RT3累积,1);
T3:=IF(TODAY,ZT3,IF(TODAY1,RT3,YT3));
T4:="wd.t20"-"wd.t21"{TRANSACTVOL(2,0)-TRANSACTVOL(2,1)};
ZS1:="wd.d10"-"wd.d11"{ORDERNUM(1,0)-ORDERNUM(1,1)};
YS1:="DDEDATA@BIGORDERSCALE"(1,0)-"DDEDATA@BIGORDERSCALE"(1,1);
RS1:="wd.散单买#day";
S1:=IF(TODAY,ZS1,IF(TODAY1,RS1,YS1));
S2:="wd.l10"-"wd.l11"{TRANSACTNUM(1,0)-TRANSACTNUM(1,1)};
ZS3:="wd.d20"-"wd.d21"{ORDERNUM(2,0)-ORDERNUM(2,1)};
YS3:="DDEDATA@BIGORDERSCALE"(2,0)-"DDEDATA@BIGORDERSCALE"(2,1);
RS3:="wd.散单卖#day";
S3:=IF(TODAY,ZS3,IF(TODAY1,RS3,YS3));
S4:="wd.l20"-"wd.l21"{TRANSACTNUM(2,0)-TRANSACTNUM(2,1)};
M1:=TIME<=100000;
M2:=TIME<=103000 AND TIME>100000;
M3:=TIME<=110000 AND TIME>103000;
M4:=TIME<=113000 AND TIME>110000;
M5:=TIME<=133000 AND TIME>130000;
M6:=TIME<=140000 AND TIME>133000;
M7:=TIME<=143000 AND TIME>140000;
M8:=TIME<=150000 AND TIME>143000;
{数据1大买}
A1:=IF(M1,S1,0);
A2:=IF(M1,S2,0);
AA:=SUM(IF(N=1,A1,A2),0);
B1:=IF(M2,S1,0);
B2:=IF(M2,S2,0);
BB:=SUM(IF(N=1,B1,B2),0);
C1:=IF(M3,S1,0);
C2:=IF(M3,S2,0);
CC:=SUM(IF(N=1,C1,C2),0);
D1:=IF(M4,S1,0);
D2:=IF(M4,S2,0);
DD:=SUM(IF(N=1,D1,D2),0);
E1:=IF(M5,S1,0);
E2:=IF(M5,S2,0);
EE:=SUM(IF(N=1,E1,E2),0);
F1:=IF(M6,S1,0);
F2:=IF(M6,S2,0);
FF:=SUM(IF(N=1,F1,F2),0);
G1:=IF(M7,S1,0);
G2:=IF(M7,S2,0);
GG:=SUM(IF(N=1,G1,G2),0);
H1:=IF(M8,S1,0);
H2:=IF(M8,S2,0);
HH:=SUM(IF(N=1,H1,H2),0);
I1:=IF(M1,T1,0);
I2:=IF(M1,T2,0);
II:=SUM(IF(N=1,I1,I2),0);
J1:=IF(M2,T1,0);
J2:=IF(M2,T2,0);
JJ:=SUM(IF(N=1,J1,J2),0);
K1:=IF(M3,T1,0);
K2:=IF(M3,T2,0);
KK:=SUM(IF(N=1,K1,K2),0);
L1:=IF(M4,T1,0);
L2:=IF(M4,T2,0);
LL:=SUM(IF(N=1,L1,L2),0);
N1:=IF(M5,T1,0);
N2:=IF(M5,T2,0);
NN:=SUM(IF(N=1,N1,N2),0);
O1:=IF(M6,T1,0);
O2:=IF(M6,T2,0);
OO:=SUM(IF(N=1,O1,O2),0);
P1:=IF(M7,T1,0);
P2:=IF(M7,T2,0);
PP:=SUM(IF(N=1,P1,P2),0);
Q1:=IF(M8,T1,0);
Q2:=IF(M8,T2,0);
QQ:=SUM(IF(N=1,Q1,Q2),0);
{数据2大卖}
A3:=IF(M1,S3,0);
A4:=IF(M1,S4,0);
AA1:=SUM(IF(N=1,A3,A4),0);
B3:=IF(M2,S3,0);
B4:=IF(M2,S4,0);
BB1:=SUM(IF(N=1,B3,B4),0);
C3:=IF(M3,S3,0);
C4:=IF(M3,S4,0);
CC1:=SUM(IF(N=1,C3,C4),0);
D3:=IF(M4,S3,0);
D4:=IF(M4,S4,0);
DD1:=SUM(IF(N=1,D3,D4),0);
E3:=IF(M5,S3,0);
E4:=IF(M5,S4,0);
EE1:=SUM(IF(N=1,E3,E4),0);
F3:=IF(M6,S3,0);
F4:=IF(M6,S4,0);
FF1:=SUM(IF(N=1,F3,F4),0);
G3:=IF(M7,S3,0);
G4:=IF(M7,S4,0);
GG1:=SUM(IF(N=1,G3,G4),0);
H3:=IF(M8,S3,0);
H4:=IF(M8,S4,0);
HH1:=SUM(IF(N=1,H3,H4),0);
I3:=IF(M1,T3,0);
I4:=IF(M1,T4,0);
II1:=SUM(IF(N=1,I3,I4),0);
J3:=IF(M2,T3,0);
J4:=IF(M2,T4,0);
JJ1:=SUM(IF(N=1,J3,J4),0);
K3:=IF(M3,T3,0);
K4:=IF(M3,T4,0);
KK1:=SUM(IF(N=1,K3,K4),0);
L3:=IF(M4,T3,0);
L4:=IF(M4,T4,0);
LL1:=SUM(IF(N=1,L3,L4),0);
N3:=IF(M5,T3,0);
N4:=IF(M5,T4,0);
NN1:=SUM(IF(N=1,N3,N4),0);
O3:=IF(M6,T3,0);
O4:=IF(M6,T4,0);
OO1:=SUM(IF(N=1,O3,O4),0);
P3:=IF(M7,T3,0);
P4:=IF(M7,T4,0);
PP1:=SUM(IF(N=1,P3,P4),0);
Q3:=IF(M8,T3,0);
Q4:=IF(M8,T4,0);
QQ1:=SUM(IF(N=1,Q3,Q4),0);
{数据3总买总卖差}
MR:=IF(N=1,SUM(T1,0),SUM(T2,0));
MC:=IF(N=1,SUM(T3,0),SUM(T4,0));
MRE:=MR*DYNAINFO(11)*100/10000;
MCE:=MC*DYNAINFO(11)*100/10000;
流入资金:MRE,COLOR0000FF,linethick0,PRECIS2;
流出资金:MCE,COLORFFFF00,linethick0,PRECIS2;
MRB:=IF(N=1,SUM(S1,0),SUM(S2,0));
MCB:=IF(N=1,SUM(S3,0),SUM(S4,0));
RBG:=MR*100/MRB;
CBG:=MC*100/MCB;
JS:=MR-MC;
JE:=MRE-MCE;
净资金:JE,COLOR00FFFF,linethick0,PRECIS2;
JB:=MRB-MCB;
JC:=RBG-CBG;
RZB:=MR/DYNAINFO(8)*100;
CZB:=MC/DYNAINFO(8)*100;
MR1:=IF(N=1,T1,T2);
MC1:=IF(N=1,T3,T4);
ZMX:=(MR1-MC1)/DYNAINFO(8)*100;
CS:=IFS(N=1,'单','笔');
{表格}
DRAWRECTABS(0,0,838,48,RGB(1,1,1)),COLOR0000C0;
DRAWRECTABS(0,0,696,13,RGB(210,150,0)),COLOR0096D2;
DRAWRECTABS(696,0,838,13,RGB(210,100,0)),COLOR0064D2;
DRAWRECTABS(0,0,87,48,0),COLOR0000C0;
DRAWRECTABS(0,0,174,48,0),COLOR0000C0;
DRAWRECTABS(0,0,261,48,0),COLOR0000C0;
DRAWRECTABS(0,0,348,48,0),COLOR0000C0;
DRAWRECTABS(0,0,435,48,0),COLOR0000C0;
DRAWRECTABS(0,0,522,48,0),COLOR0000C0;
DRAWRECTABS(0,0,609,48,0),COLOR0000C0;
DRAWRECTABS(0,0,696,48,0),COLOR0000C0;
DRAWRECTABS(0,0,838,48,0),COLOR0000C0;
{显示文字数字}
DRAWTEXTABS(15,1,'9:30-10:00 10:00-10:30 10:30-11:00 11:00-11:30 13:00-13:30 13:30-14:00 14:00-14:30 14:30-15:00 '),COLORFFFFFF;
DRAWTEXTABS(36,13,NUMTOSTRN(AA,0)+CS),COLOR0000FF,ALIGN2;
DRAWTEXTABS(36,24,NUMTOSTRN(AA1,0)+CS),COLORFFFF00,ALIGN2;
DRAWTEXTABS(36,35,NUMTOSTRN(AA-AA1,0)+CS),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(86,13,NUMTOSTRN(II,0)+'手'),COLOR0000FF,ALIGN2;
DRAWTEXTABS(86,24,NUMTOSTRN(II1,0)+'手'),COLORFFFF00,ALIGN2;
DRAWTEXTABS(86,35,NUMTOSTRN(II-II1,0)+'手'),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(123,13,NUMTOSTRN(BB,0)+CS),COLOR0000FF,ALIGN2;
DRAWTEXTABS(123,24,NUMTOSTRN(BB1,0)+CS),COLORFFFF00,ALIGN2;
DRAWTEXTABS(123,35,NUMTOSTRN(BB-BB1,0)+CS),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(173,13,NUMTOSTRN(JJ,0)+'手'),COLOR0000FF,ALIGN2;
DRAWTEXTABS(173,24,NUMTOSTRN(JJ1,0)+'手'),COLORFFFF00,ALIGN2;
DRAWTEXTABS(173,35,NUMTOSTRN(JJ-JJ1,0)+'手'),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(210,13,NUMTOSTRN(CC,0)+CS),COLOR0000FF,ALIGN2;
DRAWTEXTABS(210,24,NUMTOSTRN(CC1,0)+CS),COLORFFFF00,ALIGN2;
DRAWTEXTABS(210,35,NUMTOSTRN(CC-CC1,0)+CS),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(260,13,NUMTOSTRN(KK,0)+'手'),COLOR0000FF,ALIGN2;
DRAWTEXTABS(260,24,NUMTOSTRN(KK1,0)+'手'),COLORFFFF00,ALIGN2;
DRAWTEXTABS(260,35,NUMTOSTRN(KK-KK1,0)+'手'),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(297,13,NUMTOSTRN(DD,0)+CS),COLOR0000FF,ALIGN2;
DRAWTEXTABS(297,24,NUMTOSTRN(DD1,0)+CS),COLORFFFF00,ALIGN2;
DRAWTEXTABS(297,35,NUMTOSTRN(DD-DD1,0)+CS),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(347,13,NUMTOSTRN(LL,0)+'手'),COLOR0000FF,ALIGN2;
DRAWTEXTABS(347,24,NUMTOSTRN(LL1,0)+'手'),COLORFFFF00,ALIGN2;
DRAWTEXTABS(347,35,NUMTOSTRN(LL-LL1,0)+'手'),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(384,13,NUMTOSTRN(EE,0)+CS),COLOR0000FF,ALIGN2;
DRAWTEXTABS(384,24,NUMTOSTRN(EE1,0)+CS),COLORFFFF00,ALIGN2;
DRAWTEXTABS(384,35,NUMTOSTRN(EE-EE1,0)+CS),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(434,13,NUMTOSTRN(NN,0)+'手'),COLOR0000FF,ALIGN2;
DRAWTEXTABS(434,24,NUMTOSTRN(NN1,0)+'手'),COLORFFFF00,ALIGN2;
DRAWTEXTABS(434,35,NUMTOSTRN(NN-NN1,0)+'手'),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(471,13,NUMTOSTRN(FF,0)+CS),COLOR0000FF,ALIGN2;
DRAWTEXTABS(471,24,NUMTOSTRN(FF1,0)+CS),COLORFFFF00,ALIGN2;
DRAWTEXTABS(471,35,NUMTOSTRN(FF-FF1,0)+CS),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(521,13,NUMTOSTRN(OO,0)+'手'),COLOR0000FF,ALIGN2;
DRAWTEXTABS(521,24,NUMTOSTRN(OO1,0)+'手'),COLORFFFF00,ALIGN2;
DRAWTEXTABS(521,35,NUMTOSTRN(OO-OO1,0)+'手'),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(558,13,NUMTOSTRN(GG,0)+CS),COLOR0000FF,ALIGN2;
DRAWTEXTABS(558,24,NUMTOSTRN(GG1,0)+CS),COLORFFFF00,ALIGN2;
DRAWTEXTABS(558,35,NUMTOSTRN(GG-GG1,0)+CS),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(608,13,NUMTOSTRN(PP,0)+'手'),COLOR0000FF,ALIGN2;
DRAWTEXTABS(608,24,NUMTOSTRN(PP1,0)+'手'),COLORFFFF00,ALIGN2;
DRAWTEXTABS(608,35,NUMTOSTRN(PP-PP1,0)+'手'),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(645,13,NUMTOSTRN(HH,0)+CS),COLOR0000FF,ALIGN2;
DRAWTEXTABS(645,24,NUMTOSTRN(HH1,0)+CS),COLORFFFF00,ALIGN2;
DRAWTEXTABS(645,35,NUMTOSTRN(HH-HH1,0)+CS),COLOR00FFFF,ALIGN2;
DRAWTEXTABS(695,13,NUMTOSTRN(QQ,0)+'手'),COLOR0000FF,ALIGN2;
DRAWTEXTABS(695,24,NUMTOSTRN(QQ1,0)+'手'),COLORFFFF00,ALIGN2;
DRAWTEXTABS(695,35,NUMTOSTRN(QQ-QQ1,0)+'手'),COLOR00FFFF,ALIGN2;
DRAWRECTABS(767,2,767+RZB,12,RGB(255,30,30)),COLORFFFFFF;
DRAWRECTABS(767,2,767-CZB,12,RGB(30,30,255)),COLORFFFFFF;
DRAWTEXTABS(733,1,NUMTOSTRN(CZB,2)+'%'),ALIGN2,COLOR00FFFF;
DRAWTEXTABS(837,1,NUMTOSTRN(RZB,2)+'%'),ALIGN2,COLOR00FFFF;
DRAWTEXTABS(740,13,NUMTOSTRN(MR,0)+'手'),COLOR4848FF,ALIGN2;
DRAWTEXTABS(740,24,NUMTOSTRN(MC,0)+'手'),COLOR48FF48,ALIGN2;
DRAWTEXTABS(740,35,NUMTOSTRN(JS,0)+'手'),COLOREEEEEE,ALIGN2;
DRAWTEXTABS(773,13,NUMTOSTRN(MRB,0)+'笔'),COLOR4848FF,ALIGN2;
DRAWTEXTABS(773,24,NUMTOSTRN(MCB,0)+'笔'),COLOR48FF48,ALIGN2;
DRAWTEXTABS(773,35,NUMTOSTRN(JB,0)+'笔'),COLOREEEEEE,ALIGN2;
DRAWTEXTABS(837,13,NUMTOSTRN(RBG,0)+'股/笔'),COLOR4848FF,ALIGN2;
DRAWTEXTABS(837,24,NUMTOSTRN(CBG,0)+'股/笔'),COLOR48FF48,ALIGN2;
DRAWTEXTABS(837,35,NUMTOSTRN(JC,0)+'股/笔'),COLOREEEEEE,ALIGN2;

大智慧主力30分钟统计指标公式

 

相关文章