在线检测未来函数

大智慧单阳不破主图指标公式

来源:Internet,编辑:股旁网,2010-06-07

工作线:EMA(C,14),COLOR00FFFF,LINETHICK1;
好线:EMA(C,25),COLORFFFFFF,LINETHICK1;
{单阳不破}
单阳:=C>O*1.03 AND VOL>REF(VOL,1)*1.5;
不破价:=REF(L,BARSLAST(单阳));
DRAWTEXT(单阳,L-L*0.02,'阳'),COLOR00FFFF;
LS0:=BARSLAST(单阳);
LS11:=IF(1,LS0=1,单阳);
LS21:=IF(1,LLV(L,1)>REF(L,1),1);
单阳不破:=LS11 AND LS21;
STICKLINE(单阳不破,不破价-不破价*0.002,不破价,4,0),COLORRED;
DRAWTEXT(单阳不破,不破价-不破价*0.02,'1'),COLORGREEN;
n:=13;
A3:=REF(H,N)=HHV(H,2*N+1);
B3:=FILTER(A3,N);
C3:=BACKSET(B3,N+1);
D3:=FILTER(C3,N);{高点}
A4:=REF(L,N)=LLV(L,2*N+1);
B4:=FILTER(A4,N);
C4:=BACKSET(B4,N+1);
D4:=FILTER(C4,N);{低点}
STICKLINE(D3 or (D3 AND C<O AND VOL>MA(VOL,5) AND VOL>MA(VOL,60)),H+0.3,H+0.7,2,0);
STICKLINE(D4 or (D4 AND C>O AND VOL>ref(LLV(VOL,60),1)),l-0.3,l-0.7,2,0);
stickline(C>O,H,L,1,0),Color0000ff;
stickline(C<O,H,L,1,0),Color00ff00;
stickline(C>O,C,O,8,0),Color000055;
stickline(C>O,C,O,7,0),Color000077;
stickline(C>O,C,O,5,0),Color000099;
stickline(C>O,C,O,4,0),Color0000bb;
stickline(C>O,C,O,2,0),Color6500dd;
stickline(C>O,C,O,1,0),Color9C00ff;
stickline(C<O,C,O,8,0),Color005500;
stickline(C<O,C,O,7,0),Color007700;
stickline(C<O,C,O,5,0),Color009900;
stickline(C<O,C,O,4,0),Color00bb00;
stickline(C<O,C,O,2,0),Color65dd00;
stickline(C<O,C,O,1,0),Color9Cff00;
dd:=MA(H,10)*1.02;
STICKLINE(cross(dd,c),CLOSE,OPEN,8,0),COLOR80FFFF;
LS12:=IF(2,LS0=2,单阳);
LS22:=IF(2,LLV(L,2)>REF(L,2),1);
单阳不破2:=LS12 AND LS22;
STICKLINE(单阳不破2,不破价-不破价*0.002,不破价,4,0),COLORRED;
DRAWTEXT(单阳不破2,不破价-不破价*0.02,'2'),COLORGREEN;
LS13:=IF(3,LS0=3,单阳);
LS23:=IF(3,LLV(L,3)>REF(L,3),1);
单阳不破3:=LS13 AND LS23;
STICKLINE(单阳不破3,不破价-不破价*0.002,不破价,4,0),COLORRED;
DRAWTEXT(单阳不破3,不破价-不破价*0.02,'3'),COLORGREEN;
LS14:=IF(4,LS0=4,单阳);
LS24:=IF(4,LLV(L,4)>REF(L,4),1);
单阳不破4:=LS14 AND LS24;
STICKLINE(单阳不破4,不破价-不破价*0.002,不破价,4,0),COLORRED;
DRAWTEXT(单阳不破4,不破价-不破价*0.02,'4'),COLORGREEN;
LS15:=IF(5,LS0=5,单阳);
LS25:=IF(5,LLV(L,5)>REF(L,5),1);
单阳不破5:=LS15 AND LS25;
STICKLINE(单阳不破5,不破价-不破价*0.002,不破价,4,0),COLORRED;
DRAWTEXT(单阳不破5,不破价-不破价*0.02,'5'),COLORGREEN;
LS16:=IF(6,LS0=6,单阳);
LS26:=IF(6,LLV(L,6)>REF(L,6),1);
单阳不破6:=LS16 AND LS26;
STICKLINE(单阳不破6,不破价-不破价*0.002,不破价,4,0),COLORRED;
DRAWTEXT(单阳不破6,不破价-不破价*0.02,'6'),COLORGREEN;
LS17:=IF(7,LS0=7,单阳);
LS27:=IF(7,LLV(L,7)>REF(L,7),1);
单阳不破7:=LS17 AND LS27;
STICKLINE(单阳不破7,不破价-不破价*0.002,不破价,4,0),COLORRED;
DRAWTEXT(单阳不破7,不破价-不破价*0.02,'7'),COLORGREEN;
LS18:=IF(8,LS0=8,单阳);
LS28:=IF(8,LLV(L,8)>REF(L,8),1);
单阳不破8:=LS18 AND LS28;
STICKLINE(单阳不破8,不破价-不破价*0.002,不破价,4,0),COLORRED;
DRAWTEXT(单阳不破8,不破价-不破价*0.02,'8'),COLORGREEN;
LS19:=IF(9,LS0=9,单阳);
LS29:=IF(9,LLV(L,9)>REF(L,9),1);
单阳不破9:=LS19 AND LS29;
STICKLINE(单阳不破9,不破价-不破价*0.002,不破价,4,0),COLORRED;
DRAWTEXT(单阳不破9,不破价-不破价*0.02,'9'),COLORGREEN;
LS110:=IF(10,LS0=10,单阳);
LS210:=IF(10,LLV(L,10)>REF(L,10),1);
单阳不破10:=LS110 AND LS210;
STICKLINE(单阳不破10,不破价-不破价*0.002,不破价,4,0),COLORRED;
DRAWTEXT(单阳不破10,不破价-不破价*0.02,'10'),COLORGREEN;

大智慧单阳不破主图指标公式

 

相关文章