在线检测未来函数

飞狐K线形态主图指标公式

来源:Internet,编辑:股旁网,2010-08-02

工作线:EMA(CLOSE,7),COLORRED,LINETHICK2;
工作线2:EMA(CLOSE,14),LINETHICK2;
九号线:=EMA(CLOSE,18);
暴涨线:=MA(CLOSE,181);
牛:=EMA(CLOSE,144)>=REF(EMA(CLOSE,144),1);
DRAWTEXT((工作线2>=REF(工作线2,1) AND
L<工作线2 AND C>工作线2) ,L, '买'),COLORYELLOW;
DRAWTEXT((九号线>=REF(九号线,1) AND 牛 AND L<九号线 AND H>九号线)
AND ((CLOSE<REF(CLOSE,1) OR O>C)),L*0.98 , '●九号'),COLOR00FF00;
DRAWTEXT((工作线>=REF(工作线,1) AND 牛 AND L<工作线 AND H>工作线)
{AND ((CLOSE<REF(CLOSE,1) OR O>C))},L*0.96 , '◆工作'),COLORWHITE;
DRAWTEXT( (暴涨线>=REF(暴涨线,1) AND 牛 AND L<暴涨线 AND H>暴涨线)
AND ((CLOSE<REF(CLOSE,1) OR O>C)),L*0.94 , '★暴涨'),COLORMAGENTA;
黄昏之星:=((((((REF(CLOSE,2) / REF(OPEN,2)) > 1.03) AND (REF(OPEN,1) >
REF(CLOSE,2))) AND ((ABS((REF(OPEN,1) - REF(CLOSE,1))) /
REF(CLOSE,1)) < 0.02)) AND ((CLOSE / OPEN) < 0.97)) AND (CLOSE <REF(CLOSE,2)));
射击之星:=(((MIN(OPEN,CLOSE) = LOW) AND ((HIGH - LOW) > (3 *
(MAX(OPEN,CLOSE) - LOW)))) AND (CLOSE > MA(CLOSE,5)));
锤头:=(((HIGH = MAX(OPEN,CLOSE)) AND ((HIGH - LOW) > (3 * (HIGH -
MIN(OPEN,CLOSE))))) AND (CLOSE < MA(CLOSE,5)));
吊颈:=(( (HIGH = MAX(OPEN,CLOSE)) AND ((HIGH - LOW) > (3 * (HIGH -
MIN(OPEN,CLOSE))))));

穿头破脚:=((((((REF(CLOSE,1) / REF(OPEN,1)) > 1.03) AND ((CLOSE / OPEN)
< 0.96)) AND (CLOSE < REF(OPEN,1))) AND (OPEN > REF(CLOSE,1))) OR
(((((REF(CLOSE,1) / REF(OPEN,1)) < 0.97) AND ((CLOSE / OPEN) >
1.04)) AND (CLOSE > REF(OPEN,1))) AND (OPEN < REF(CLOSE,1))));
身怀六甲:=(((((ABS((REF(CLOSE,1) - REF(OPEN,1))) / REF(CLOSE,1)) > 0.04)
AND ((ABS((CLOSE - OPEN)) / CLOSE) < 0.005)) AND (MAX(CLOSE,OPEN) <
MAX(REF(CLOSE,1),REF(OPEN,1)))) AND (MIN(CLOSE,OPEN) > MIN(REF(CLOSE,1),REF(OPEN,1))));

乌云盖顶:=(((((REF(CLOSE,1) / REF(OPEN,1)) > 1.03) AND ((CLOSE / OPEN) <
0.97)) AND (OPEN > REF(CLOSE,1))) AND (CLOSE < REF(CLOSE,1)));
曙光初现:=(((((REF(CLOSE,1) / REF(OPEN,1)) < 0.97) AND ((CLOSE / OPEN) >
1.03)) AND (OPEN < REF(CLOSE,1))) AND (CLOSE > REF(CLOSE,1)));
倾盆雨:=(((((REF(CLOSE,1) / REF(OPEN,1)) >= 1.03) AND (OPEN <
REF(CLOSE,1))) AND (OPEN > REF(OPEN,1))) AND (CLOSE < REF(OPEN,1)));
DRAWTEXT(倾盆雨,H*1.03,'倾盆大雨'),COLORCYAN;
DRAWTEXT(黄昏之星,H*1.02,'黄昏之星'),COLORCYAN;
DRAWTEXT(射击之星,H*1.03,'射击之星可能见顶'),COLORCYAN;
DRAWTEXT(锤头,L-L*0.02,'锤头可能见底'),COLORGREEN;
DRAWTEXT(吊颈,H*1.03,'吊颈'),COLORCYAN;
DRAWTEXT(穿头破脚,H*1.05,'穿头破脚'),COLORCYAN;
DRAWTEXT(乌云盖顶,H*1.03,'乌云盖顶'),COLORCYAN;
DRAWTEXT(曙光初现,L-L*0.02,'曙光初现(放量)'),COLORGREEN;
DRAWTEXT(身怀六甲,L-L*0.02,'身怀六甲,底升顶落'),COLORGREEN;
中:MA(CLOSE,27),COLORGRAY;
上:=中 + 2*STD(CLOSE,20);
下:=中 - 2*STD(CLOSE,20);
上轨:EMA(上,3),COLORGRAY;


阳长下影线:=(O-L)/O>0.06 AND C>O;
阴长下影线:=(C-L)/C>0.06 AND C<O;
阳长上影线:=(H-C)/C>0.06 AND C>O;
阴长上影线:=(H-O)/O>0.06 AND C<O;
光头阳长下影线:=C=H AND (O-L)/O>0.06 AND C>O;
光脚阴长上影线:=C=L AND (H-O)/O>0.06 AND C<O;
白色十字星:=C=O AND H>C AND C>L;
DRAWTEXT(阳长下影线,H*1.01,'阳长下影线'),COLORCYAN;
DRAWTEXT(阴长下影线,H*1.04,'阴长下影线'),COLORwhite;
DRAWTEXT(阳长上影线,H*1.06,'阳长上影线'),COLORred;
DRAWTEXT(光头阳长下影线,H*1.07,'光头阳长下影线'),COLORCYAN;
DRAWTEXT(光脚阴长上影线,H*1.08,'光脚阴长上影线'),COLORyellow;
DRAWTEXT(白色十字星,H*1.02,'白色十字星'),COLORwhite;


aa:=Close > Ref(Close, 1) and Ref(Close, 1) > Ref(Close, 2) and Ref(Close, 1) < Ref(Close, 3) and If(Ref(Close, 3) < Ref(Close, 4), 1, If(Ref(Close, 4) < Ref(Close, 5),Ref(Close, 1) < Ref(Close, 4) or( Ref(Close, 2) < Ref(Close, 4) and Ref(Close, 3) >= Ref(Close, 5) ),If(Ref(Close, 5) < Ref(Close, 6), 1,Ref(Close, 6) < Ref(Close, 7))));
bb:=Close < Ref(Close, 1) and Ref(Close, 1) < Ref(Close, 2) and Ref(Close, 1) > Ref(Close, 3) and If(Ref(Close, 3) > Ref(Close, 4), 1, If(Ref(Close, 4) > Ref(Close, 5),Ref(Close, 1) > Ref(Close, 4) or( Ref(Close, 2) > Ref(Close, 4) and Ref(Close, 3) <= Ref(Close, 5) ),If(Ref(Close, 5) > Ref(Close, 6), 1,Ref(Close, 6) > Ref(Close, 7))));
drawtext(aa and close>ref(open,2),low*0.995,'三平底翻红'),color,COLORFF00FF;
drawtext(bb and close<ref(close,2),high*1.01,'三平顶翻绿'),color00ff00;
drawicon(aa and close>ref(open,2),low,1);
drawicon(bb and close<ref(close,2),high*1.01,2);

 

早晨之星:=REF(CLOSE,2)/REF(OPEN,2)<0.95 AND REF(OPEN,1)<REF(CLOSE,2) AND

(ABS(REF(OPEN,1)-REF(CLOSE,1)))/REF(CLOSE,1)<0.03 AND CLOSE/OPEN>1.05 AND

CLOSE>REF(CLOSE,2);
DRAWTEXT(早晨之星,H*1.02,'早晨之星'),COLORwhite;
长十字:=CLOSE=OPEN AND HIGH/LOW>1.03;
DRAWTEXT(长十字,H*1.02,'长十字'),COLORwhite;
垂死十字:=CLOSE=OPEN AND CLOSE=LOW AND CLOSE<>HIGH;
DRAWTEXT(垂死十字,H*1.02,'垂死十字'),COLORwhite;
早晨十字星:=REF(CLOSE,2)/REF(OPEN,2)<0.95 AND REF(OPEN,1)<REF(CLOSE,2) AND
REF(OPEN,1)=REF(CLOSE,1) AND CLOSE/OPEN>1.05 AND CLOSE>REF(CLOSE,2);
DRAWTEXT(早晨十字星,H*1.02,'早晨十字星'),COLORwhite;
黄昏十字星:=REF(CLOSE,2)/REF(OPEN,2)>1.05 AND REF(OPEN,1)>REF(CLOSE,2) AND
REF(OPEN,1)=REF(CLOSE,1) AND CLOSE/OPEN<0.95 AND CLOSE<REF(CLOSE,2);
DRAWTEXT(黄昏十字星,H*1.02,'黄昏十字星'),COLORwhite;
倒锤头:=MIN(OPEN,CLOSE)=LOW AND HIGH-LOW>3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE<MA(CLOSE,5);
DRAWTEXT(倒锤头,H*1.02,'倒锤头'),COLORwhite;
锤头:=HIGH=MAX(OPEN,CLOSE) AND HIGH-LOW>3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE<MA(CLOSE,5);
DRAWTEXT(锤头,H*1.02,'锤头'),COLORwhite;

曙光初现:=REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.03 AND OPEN<REF(CLOSE,1) AND
CLOSE>REF(CLOSE,1);
DRAWTEXT(曙光初现,H*1.02,'曙光初现'),COLORwhite;
十字胎:=(ABS(REF(CLOSE,1)-REF(OPEN,1)))/REF(CLOSE,1)>0.04 AND CLOSE=OPEN AND
CLOSE<MAX(REF(CLOSE,1),REF(OPEN,1)) AND CLOSE>MIN(REF(CLOSE,1),REF(OPEN,1));
DRAWTEXT(十字胎,H*1.02,'十字胎'),COLORwhite;
大阳烛:=CLOSE/OPEN>1.05 AND HIGH/LOW<CLOSE/OPEN+0.018;
DRAWTEXT(大阳烛,H*1.02,'大阳烛'),COLORwhite;
三个白武士:=REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)>REF(OPEN,1) AND CLOSE>OPEN AND
REF(CLOSE,1)>REF(CLOSE,2) AND CLOSE>REF(CLOSE,1);
DRAWTEXT(三个白武士,H*1.02,'三个白武士'),COLORwhite;
双飞乌鸦:=REF(CLOSE,1)<REF(OPEN,1) AND CLOSE<OPEN AND CLOSE/OPEN<0.98;
DRAWTEXT(双飞乌鸦,H*1.02,'双飞乌鸦'),COLORwhite;
孕育线:=REF(CLOSE,2)>REF(OPEN,2) AND (REF(CLOSE,2)-REF(OPEN,2))/REF(OPEN,2)>=2/100 AND
REF(OPEN,1)>=REF(CLOSE,1) AND (REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<=2/100 AND
REF(OPEN,1)<=REF(CLOSE,2) AND REF(CLOSE,1)>=REF(OPEN,2) AND CLOSE>=OPEN AND
(CLOSE-OPEN)/OPEN>=2/100 AND CLOSE>=REF(OPEN,1) AND OPEN<=REF(CLOSE,1) AND
(MAX(CLOSE,REF(CLOSE,2))-MIN(CLOSE,REF(CLOSE,2)))/MIN(CLOSE,REF(CLOSE,2))<=1/100;
DRAWTEXT(孕育线,H*1.02,'孕育线'),COLORwhite;
多方炮:=REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND CLOSE>OPEN;
DRAWTEXT(多方炮,H*1.02,'多方炮'),COLORwhite;
出水芙蓉:=(OPEN<EMA(CLOSE,20) OR OPEN<EMA(CLOSE,40) OR OPEN<EMA(CLOSE,60)) AND
CLOSE>MAX(EMA(CLOSE,20),MAX(EMA(CLOSE,40),EMA(CLOSE,60))) AND VOL/MA(VOL,30)>1.2 AND
CLOSE/REF(CLOSE,1)>1.049;
DRAWTEXT(出水芙蓉,H*1.02,'出水芙蓉'),COLORwhite;
下跌三部曲:=REF(CLOSE,4)/REF(OPEN,4)>1.03 AND REF(CLOSE,3)<REF(OPEN,3) AND
REF(CLOSE,2)<REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND REF(LOW,4)<REF(LOW,3) AND
REF(LOW,4)<REF(LOW,2) AND REF(LOW,4)<REF(LOW,1) AND REF(HIGH,4)>REF(HIGH,3) AND
REF(HIGH,4)>REF(HIGH,2) AND REF(HIGH,4)>REF(HIGH,1) AND CLOSE/OPEN>1.03 AND
CLOSE>REF(CLOSE,4);
DRAWTEXT(下跌三部曲,H*1.02,'下跌三部曲'),COLORwhite;
下跌三部曲:=REF(CLOSE,4)/REF(OPEN,4)<0.97 AND REF(CLOSE,3)>REF(OPEN,3) AND
REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)>REF(OPEN,1) AND REF(LOW,4)<REF(LOW,3) AND
REF(LOW,4)<REF(LOW,2) AND REF(LOW,4)<REF(LOW,1) AND REF(HIGH,4)>REF(HIGH,3) AND
REF(HIGH,4)>REF(HIGH,2) AND REF(HIGH,4)>REF(HIGH,1) AND CLOSE/OPEN<0.97 AND
CLOSE<REF(CLOSE,4);
DRAWTEXT(下跌三部曲,H*1.02,'下跌三部曲'),COLORwhite;
跳空缺口:=HIGH<REF(LOW,1) OR LOW>REF(HIGH,1);
DRAWTEXT(跳空缺口,H*1.02,'跳空缺口'),COLORwhite;
{股旁网-股票公式网站 www.gupang.com}
三只乌鸦:=REF(CLOSE,2)<REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND CLOSE<OPEN AND
REF(CLOSE,1)<REF(CLOSE,2) AND CLOSE<REF(CLOSE,1);
DRAWTEXT(三只乌鸦,H*1.02,'三只乌鸦'),COLORwhite;
分离:=OPEN=REF(OPEN,1) AND (CLOSE-OPEN)*(REF(CLOSE,1)-REF(OPEN,1))<0;
DRAWTEXT(分离,H*1.02,'分离'),COLORwhite;
大阴烛:=OPEN/CLOSE>1.05 AND HIGH/LOW<OPEN/CLOSE+0.018;
DRAWTEXT(大阴烛,H*1.02,'大阴烛'),COLORwhite;
好友反攻:=REF(CLOSE,1)<REF(OPEN,1) AND CLOSE>OPEN AND (ABS(CLOSE-REF(CLOSE,1)))/CLOSE<0.002
OR REF(CLOSE,1)>REF(OPEN,1) AND CLOSE<OPEN AND (ABS(CLOSE-REF(CLOSE,1)))/CLOSE<0.002;
DRAWTEXT(好友反攻,H*1.02,'好友反攻'),COLORwhite;

飞狐K线形态主图指标公式

 

相关文章