在线检测未来函数

同花顺超前MACD指标公式

来源:Internet,编辑:股旁网,2010-08-05

SQX:=(C-MA(CLOSE,13))*100;
diff:EMA(MA(sqx,7),1),COLOR00ffff;
dea:EMA(diff,7),COLORff33ff;
MACD:(diff-dea)*2,COLORSTICK;
低位金叉:IF(CROSS(DIFF,DEA) AND DIFF<-0.1,30,0),coloryellow;
STICKLINE(低位金叉,0,15,8,0),coloryellow;
DRAWICON(低位金叉,0.3,1);
JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
二次金叉:IF(CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1,32,0),COLORff00ff,LINETHICK2;
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
背离:IF(REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA),10,0),colorred;
DRAWLINE(A1=0,DEA,底背离,DEA,0),colorred,LINETHICK2;
A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));
顶背离:REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF),colorgreen;
DRAWLINE(A2=0,DEA,顶背离,DEA,0),colorgreen,LINETHICK2;
A3:=CROSS(DIFF,DEA) AND DEA<0;
零下二次金叉:IF(FILTER(COUNT(A3,21)=2,10),70,0),COLORff0000,LINETHICK2;

同花顺超前MACD指标公式

 

相关文章