在线检测未来函数

大智慧量能饱和及选股指标公式

来源:Internet,编辑:股旁网,2010-08-07

使用说明:B线大于50在量能坑处上穿S线为有效买点,量能饱和时,B线下穿S线为有效卖点

input:n1(4,1,100),n2(8,1, 100),n3(16,1,100),m(6,1,100),n(34,1,100);
HH:=MAX(HIGH,REF(CLOSE,1));
LL:=MIN(LOW,REF(CLOSE,1));
AA:=SUM(CLOSE-LL,N1)/SUM(HH-LL,N1);
BB:=SUM(CLOSE-LL,N2)/SUM(HH-LL,N2);
CC:=SUM(CLOSE-LL,N3)/SUM(HH-LL,N3);
B:(AA/N1+BB/N2+CC/N3)*N1*N2*N3/(N1*N2+N2*N3+N1*N3)*100,colorred,LINETHICK2;
S:EMA(b,M),colorcyan,LINETHICK2;
SAT:=(AMOUNT/C)/(HHV(AMOUNT,N)/HHV(C,N));
饱和度:=IF(SAT>1,1,SAT)*100;
量能≤5:STICKLINE(饱和度<=5,5,饱和度+20,4,0),COLORRED;
量能5~80:STICKLINE((饱和度>5 AND 饱和度< 80),5,饱和度+8,4,0),COLORyellow;
量能80~97:STICKLINE((饱和度>80 AND 饱和度< 97),5,饱和度,4,0),COLORFFCC00;
{股旁网-股票公式网站 www.gupang.com}
量能≥97:STICKLINE(饱和度>=97,5,饱和度,4,0),COLORGREEN;
IF BARSTATUS=2 and (饱和度) THEN BEGIN DRAWTEXTREL(0,100,'饱和度:'+NUMTOSTRN(饱和度,2)),LINETHICK6,COLORccffcc;end;
DIFF : (EMA(CLOSE,9) - EMA(CLOSE,17))*50,colorred; 

选股公式:
input:n1(4,1,100),n2(8,1, 100),n3(16,1,100),m(6,1,100),n(34,1,100);
HH:=MAX(HIGH,REF(CLOSE,1));
LL:=MIN(LOW,REF(CLOSE,1));
AA:=SUM(CLOSE-LL,N1)/SUM(HH-LL,N1);
BB:=SUM(CLOSE-LL,N2)/SUM(HH-LL,N2);
CC:=SUM(CLOSE-LL,N3)/SUM(HH-LL,N3);
B:=(AA/N1+BB/N2+CC/N3)*N1*N2*N3/(N1*N2+N2*N3+N1*N3)*100;
S:=EMA(b,M);
DIFF:=(EMA(CLOSE,9) - EMA(CLOSE,17))*50;
a1:=vol<ma(v,20);
a2:=diff>ref(diff,1);
b>40 and cross(b,s) and a1 and c>ref(c,1) and a2;

大智慧量能饱和及选股指标公式

 

相关文章