在线检测未来函数

通达信短线趋势王主图指标公式

来源:Internet,编辑:股旁网,2010-08-13

EMA5:EMA(C,5),COLORFF00FF,LINETHICK1;
EMA10:EMA(C,10),COLOR00FFFF,LINETHICK1;
EMA55:EMA(C,55),COLORFFFFFF,LINETHICK1;
DRAWBAND(EMA5,RGB(0,220,220),EMA10,RGB(0,200,0));
N:=5;N1:=21;
VAR1:=4*SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,5,1)-3
*SMA(SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,5,1),3.2,1);
VAR1A:=(HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9))*100-70;
VAR2A:=SMA(VAR1A,9,1)+100;
VAR3A:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR4A:=SMA(VAR3A,3,1);
VAR5A:=SMA(VAR4A,3,1)+100;
VAR6A:=VAR5A-VAR2A;
MM:=IF(VAR6A>N1,VAR6A-N1,0);
AA:= REF(MM,1)<MM;
BB:= REF(MM,1)>MM;
买入:DRAWICON(CROSS(MM,REF(MM,1)),L-0.2,1);
卖出:DRAWICON(CROSS(REF(MM,1),MM),H+0.2,2);
STICKLINE(AA,C,O,3,0),COLORRED;
STICKLINE(AA,H,L,0.5,0),COLORRED;
STICKLINE(BB,C,O,3,0),COLOR00FF00;
STICKLINE(BB,H,L,0.5,0),COLOR00FF00;
{股旁网-股票公式网站 www.gupang.com}
STICKLINE(AA,CLOSE,OPEN,4,0),COLOR000099;
STICKLINE(AA,CLOSE,OPEN,2,0),COLOR0000CC;
STICKLINE(AA,CLOSE,OPEN,1.5,0),COLOR3300CC;
STICKLINE(AA,CLOSE,OPEN,1.0,0),COLOR9900FF;
STICKLINE(AA,CLOSE,OPEN,0.5,0),COLORCC00FF;
STICKLINE(AA,CLOSE,OPEN,0.2,0),COLOR66FFCC;
STICKLINE(BB,CLOSE,OPEN,4,0),COLOR993300;
STICKLINE(BB,CLOSE,OPEN,3.0,0),COLORCC3300;
STICKLINE(BB,CLOSE,OPEN,2.0,0),COLORFF3300;
STICKLINE(BB,CLOSE,OPEN,1.5,0),COLORFF6600;
STICKLINE(BB,CLOSE,OPEN,1.0,0),COLORFF9900;
STICKLINE(BB,CLOSE,OPEN,0.2,0),COLORFFFFFF;
STICKLINE(买入,O,(C-O)/2+O,4,0),COLOR335555;
STICKLINE(买入,O,(C-O)/2+O,2,0),COLOR338888;
STICKLINE(买入,O,(C-O)/2+O,1.5,0),COLOR33AAAA;
STICKLINE(买入,O,(C-O)/2+O,1,0),COLOR33CCCC;
STICKLINE(买入,O,(C-O)/2+O,0,0),COLOR33EEEE;
STICKLINE(卖出,O,(C-O)/2+O,4,0),COLOR550055;
STICKLINE(卖出,O,(C-O)/2+O,2,0),COLOR880088;
STICKLINE(卖出,O,(C-O)/2+O,1.5,0),COLORAA00AA;
STICKLINE(卖出,O,(C-O)/2+O,1,0),COLORCC00CC;
STICKLINE(卖出,O,(C-O)/2+O,0.5,0),COLOREE00EE;

通达信短线趋势王主图指标公式

 

相关文章