在线检测未来函数

通达信K线组合主图指标公式

来源:Internet,编辑:股旁网,2010-08-22

支撑价:LLV(LOW,19), COLORLIRED,POINTDOT,LINETHICK4;
阻力价:HHV(HIGH,19),COLORLIBLUE,POINTDOT, LINETHICK4;
MA5:MA(C,5),COLORWHITE,LINETHICK1;
IF(MA5>REF(MA5,1),MA5,DRAWNULL),COLORRED,LINETHICK2;
IF(MA5<REF(MA5,1),MA5,DRAWNULL),COLORGREEN,LINETHICK2;
MA13:MA(CLOSE,13),COLORYELLOW;
MA21:MA(CLOSE,21),COLORMAGENTA;
MA34:=MA(CLOSE,34);
MA60:MA(CLOSE,60),COLORGREEN;
MA120:MA(CLOSE,120),COLORBLUE;
QQ:=0,COLORWHITE;
MA1:=MA(CLOSE,5);
MA2:=MA(CLOSE,10);
JG:=CROSS(MA1,MA2);
VOLUME:=VOL,VOLSTICK;
MAVOL1:=MA(VOLUME,5);
MAVOL2:=MA(VOLUME,10);
NL:=CROSS(MAVOL1,MAVOL2);
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2,COLORSTICK;
NA:=CROSS(DIF,DEA);
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,9,1);
D:=SMA(K,9,1);
J:=3*K-2*D;
KD:=CROSS(K,D) AND CROSS(J,D);
一招定乾坤:DRAWTEXT((JG AND NL AND NA) OR (JG AND NL AND KD) OR
(JG AND NA AND KD) OR (NL AND NA AND KD),L*0.94,'一招定乾坤'),COLORYELLOW;
X:=LLV(J,2)=LLV(J,8);
Y:=IF(CROSS(J,REF(J+0.01,1)) AND X AND J<20,30,0);
DRAWTEXT(CROSS(J,REF(J+0.01,1)) AND X AND J<20,LOW*0.98,'★短进'),COLORLIMAGENTA;
JH9:=SMA(MAX(C-REF(C,1),0),5,1)/SMA(ABS(C-REF(C,1)),5,1)*100;
DRAWTEXT(CROSS(84,JH9),H*1.02,'★S'),COLORGREEN;
空:=EMA(C,5);
均衡:=EMA(空,5),COLORWHITE;
中轨:=HHV(MA(H,13),13),COLORRED,LINETHICK2;
VAR5:=FILTER(均衡>REF(均衡,1)AND 中轨<REF(中轨,1)AND C>REF(C,1),11);
DRAWTEXT(VAR5,L*0.98,'追涨'),COLORMAGENTA;
菩提:=MEMA(H,20);
般:=MEMA(CLOSE,7),COLORBROWN;
若:=MEMA(CLOSE,3),COLORLIBLUE;
{股旁网-股票公式网站 www.gupang.com}
DRAWICON(LONGCROSS(般,若,0.25) AND 菩提>H ,L*0.98,1),COLORRED;
YM:=(H+O+L+3*C)/6;
XM:=EMA(100-(100/(1+SUM(IF(YM>REF(YM,1),YM*VOL,0),14)/SUM
(IF(YM<REF(YM,1),YM*VOL,0),14))),5);
ZM:=DRAWLINE(XM>=HHV(XM,4),XM,XM<=LLV(XM,4),XM,1);
TJ1:=XM=ZM;
TJ2:=XM<REF(XM,1);
DRAWTEXT(TJ1 AND TJ2,LOW*0.95,'买进'),COLORYELLOW;
趋势线:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1), , COLORBLUE;
DRAWTEXT(CROSS(趋势线,10),LOW*0.90,'底买'),COLORMAGENTA;
VAR111:=(((CLOSE - MA(CLOSE,6))/(MA(CLOSE,6)))*(200) + ((CLOSE - MA(CLOSE,24))/(MA(CLOSE,24)))*(200) + ((CLOSE - MA(CLOSE,32))/(MA(CLOSE,32)))*(200))/(3);
DRAWICON((VAR111 > 20) AND FILTER((VAR111 < REF(VAR111,1)),5),(HIGH)*(1.02),2),COLORGREEN;
RSV99:=(CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100;
K99:=MA(RSV99,2.5);
D99:=MA(K99,2.5);
J99:=3*K99-2*D99;
JJ99:=J99<20;
DRAWTEXT(REF(J99,1)<20 AND EMA(C,20)>REF(EMA(C,20),1) AND NOT(JJ99),LOW*0.92,'超跌短进'),COLORMAGENTA;

通达信K线组合主图指标公式

 

相关文章