在线检测未来函数

同花顺黑马组合主图指标公式

来源:Internet,编辑:股旁网,2010-08-30

VAR1:=EMA(C,5);
VAR2:=EMA(C,10);
VAR3:=EMA(C,20);
VAR4:=EMA(C,30);
VAR5:=(VAR1+VAR2+VAR3+VAR4)/4;
VAR6:=(VAR5-REF(VAR5,15))/REF(VAR5,15)*100;
VAR7:=EMA(VAR6,8);
STICKLINE(VAR6<1*REF(VAR6,1),H,L,0.5,0),colorblue;STICKLINE(VAR6<1*REF(VAR6,1),O,C,8, 0),colorblue;
STICKLINE(VAR6>1*REF(VAR6,1),H,L,0.5,0),colorred;STICKLINE(VAR6>1*REF(VAR6,1),O,C,8, 0),colorred;
STICKLINE(VAR6<1*REF(VAR6,1) AND VAR7>1*REF(VAR7,1),H,L,0.5,0),colorgreen;STICKLINE(VAR6<1*REF(VAR6,1) AND VAR7>1*REF(VAR7,1),O,C,8, 0),colorgreen;
byx:=MA(CLOSE,8);
FILLRGN(byx,REF(byx,1),byx>REF(byx,1),RGB(255,0,0),byx<REF(byx,1),RGB(0,255,0));
MA$1:MA(CLOSE, 5);
MA$2:MA(CLOSE, 10);
MA$3:MA(CLOSE, 20);
MA$4:MA(CLOSE, 30);
MA65:MA(CLOSE, 65);
MA130:MA(CLOSE,130);
SAT:=IF((AMOUNT/C)/(HHV(AMOUNT,13)/HHV(C,13))*100>100,100,(AMOUNT/C)/(HHV(AMOUNT,13)/HHV(C,13))*100);
glba1:=MA$1>REF(MA$1,1);
glba2:=MA$2>REF(MA$2,1);
glba3:=MA$1>REF(MA$3,1);
glba4:=MA$1>REF(MA$4,1);
dtpl:=CLOSE>=MA$1 AND MA$2>=MA$1 AND MA$3>=MA$4;
dtpl0=COUNT(dtpl,20);
gzd:=glba1 AND glba2 AND glba3 AND glba4;
MA0:=(MA$1+MA$2+MA$3+MA$4)/4;
MA1:=MA(MA0,8);
gzdnum:=LONGCROSS(MA0,MA1,1);
satcount:=LONGCROSS(sat,100,21);
glbbif$5:=LONGCROSS(CLOSE,MA$4,5);
Vglbh:=VOL/CAPITAL*100;
Lbglb:=VOL/MA(VOL,5);
TIPTEXT(glbbif$5,LOW,'葛兰碧第一买点'),colorblue;
TIPTEXT(gzdnum AND gzd AND C>MA$4 ,LOW,'多周期向上共振---积极介入点'),colorred;
TIPTEXT(satcount AND Vglbh>2.0 AND Lbglb>1.0,LOW-1.0,'量能饱和点,即将起飞'),coloryellow;
A1:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1);
Hm0:=EMA(A1,5);
A2:=(Hm0-REF(Hm0,1))/REF(Hm0,1)*100;
A3:=EMA(C,5);
A4:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;
qs0:=(MA(3*SMA(A4,6,1)-2*SMA(SMA(A4,5,1),5,1),2));
A5:=(HHV(H,60)-C)/(HHV(H,60)-LLV(L,60))*100;
DRAWTEXT(FILTER(REF(Hm0,1)>90 AND A2<0,7),HIGH+2,'跑!'),colorgreen;
DRAWTEXT(CROSS(A1,Hm0)AND Hm0<A5,LOW-2,'黑马'),coloryellow;
DRAWTEXT(CROSS(Hm0,A5)AND qs0<80,LOW-2.5,'追涨'),coloryellow;
DRAWTEXT(CROSS(qs0,0)AND Hm0<40,LOW-3,'大黑马'),colorred;
DRAWICON(A2<-10 AND A2>REF(A2,1) AND A3>REF(A3,1),LOW-2,4);
DRAWTEXT(A2<-10 AND A2>REF(A2,1) AND A3>REF(A3,1),LOW-2,'底部来临'),coloryellow;
dy:=SUM((OUTVOL-INVOL)/CAPITAL*100,0),colorwhite;
dy5:=MA(dy,5),Colorffeeaa;
dy10:=MA(dy,10),Color0000ff; Vdy:=LONGCROSS(dy,dy5,5);
VAR1:=C>O;
TIPTEXT(Vdy AND Lbglb>1.00 AND VAR1 AND Vglbh>2.0,LOW,'介入点,主动性买盘明显增大'),colorwhite;

同花顺黑马组合主图指标公式

 

相关文章