在线检测未来函数

通达信主力灯塔指标公式

来源:Internet,编辑:股旁网,2010-09-11

高抛线:="BDZX.AK";
低吸线:="BDZX.AD1";
标准A:=低吸线+(高抛线-低吸线)*2/3;
标准C:=低吸线+(高抛线-低吸线)*1/3;
高抛:="BDZX.AA";
低吸:="BDZX.BB";
标准B:=低吸+(高抛-低吸)*2/3;
弈神:="CYQKL.KL";
运动趋势:=XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(XMA(弈神,2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2),2);
风险①:运动趋势*1.1,COLORBROWN,NODRAW;
风险②:运动趋势*1.125,COLORWHITE,NODRAW;
风险③:运动趋势*1.15,COLORYELLOW,NODRAW;
安全①:运动趋势*0.95,COLORWHITE,NODRAW;
安全②:运动趋势*0.925,COLORRED,NODRAW;
安全③:运动趋势*0.90,COLORGREEN,NODRAW;
DRAWBAND(风险①,RGB(250,249,8),风险②,RGB(250,249,8));
DRAWBAND(风险②,RGB(114,2,4), 风险③,RGB(114,2,4));
DRAWBAND(安全①,RGB(248,242,242),安全②,RGB(248,242,242));
DRAWBAND(安全②,RGB(70,177,63),安全③,RGB(70,177,63));
AA:=MA((2*CLOSE+HIGH+LOW)/4,5);
通道1:=AA*102/100;
通道2:=AA*(200-102)/100;
CC:="SDLH.散户资金指数";
DD:=DMA(CLOSE,CC);
通道3:=(1+7/100)*DD;
通道4:=(1-7/100)*DD;
{==================================}
KA0:=(HHV(C,45)-LLV(C,45))/"BDZX.AJ";
KA1:=SMA(C,"BDZX.AJ"/15,1);
KA2:=SMA(C-KA0*3,"BDZX.AJ"/15,1);
KA3:=SMA(KA1-KA0*3,"BDZX.AJ"/15,1);
短期策略:=KA2>=KA3,NODRAW,COLORMAGENTA;
短期拐点:=REF(短期策略,1)=0 AND 短期策略=1,NODRAW;
赢在龙头:=(L+H+C*"BDZX.AJ"*2)/"BDZX.AJ"/3;
趋势轨:=EMA(赢在龙头,"BDZX.AJ"*6),NODRAW;
赢在:=(趋势轨-REF(趋势轨,1))/REF(趋势轨,1)*100;
趋势拐点:=CROSS(赢在,0);
G:=BARSLAST(CROSS(赢在,0))+1;
风险控制:REF(L,G),NODRAW,COLORRED;
止损线A:=REF(L,G);
止损线B:=REF(止损线A,BARSLAST(止损线A>REF(止损线A,1) OR 止损线A<REF(止损线A,1))+1);
超跌轨:="LHXJ.主力控盘";
操盘线:KA2,NODRAW,COLORMAGENTA;
标准:=运动趋势>REF(运动趋势,1);
系数:=(L-安全①)/安全①*100;
风险系数:IF(标准,系数,DRAWNULL),NODRAW;
STICKLINE(C>=O,C,O,3,0),COLOR0000AA;
STICKLINE(C>=O,C,O,2.5,0),COLOR0000BB ;
STICKLINE(C>=O,C,O,1.5,0),COLOR0000CC ;
STICKLINE(C>=O,C,O,1,0),COLOR0000EE;
STICKLINE(C>=O,H,L,0,0),COLOR0000FF;
STICKLINE(C<=O,C,O,3,0),COLOR7B7B00;
STICKLINE(C<=O,C,O,2.5,0),COLOR909000;
STICKLINE(C<=O,C,O,1.5,0),COLORA8A800;
STICKLINE(C<=O,C,O,1,0),COLORCECE00;
STICKLINE(C<=O,H,L,0,0),COLORFFFF00;
{股旁网-股票公式网站 www.Gupang.com}
IF(赢在>0,REF(L,G),DRAWNULL),COLORRED,POINTDOT,LINETHICK4;
IF(赢在<0,REF(L,G),DRAWNULL),COLORBLUE,POINTDOT,LINETHICK4;
IF(KA2>=KA3 AND 低吸线>0,KA2,DRAWNULL),COLORMAGENTA,LINETHICK4;
IF(KA2>=KA3 AND KA2>=标准B AND 低吸线>0,KA2,DRAWNULL),COLORLIGREEN,LINETHICK4;
IF(KA2>=KA3 AND KA2>=标准A AND 低吸线>0,KA2,DRAWNULL),COLORBLUE,LINETHICK4;
IF(KA2<KA3 AND 低吸线>0,KA2,DRAWNULL),LINETHICK1,COLORBLUE;
IF(运动趋势>REF(运动趋势,1),安全②,DRAWNULL),CIRCLEDOT,COLORRED;
IF(运动趋势<REF(运动趋势,1),安全②,DRAWNULL),CIRCLEDOT,COLORCYAN;
上趋势:=MA(LOW,20)*1.2;
次上趋势:=MA(LOW,20)*1.1;
次下趋势:=MA(HIGH,20)*0.9;
下趋势:=MA(HIGH,20)*0.8,COLORGREEN;
ZD:=(C-REF(C,1))/REF(C,1)*100;
HDZF:=(HHV(H,20)-C)/(HHV(H,20)-LLV(L,20));
趋势强度:=IF(C>次上趋势,IF(C>上趋势,4,3),IF(C>次下趋势 AND C<次上趋势,2,IF(C<下趋势,0,1)));
超短:=CROSS(超跌轨*1.01,L);{ AND H>=REF(L,1);}
狙击手:=超短 AND 趋势强度=3 OR (超短 AND COUNT(超短,BARSLAST(趋势强度=3))=1 AND C>MIN(止损线A,止损线B)) AND L<标准C,NODRAW;
DRAWICON(狙击手,H+0.01,6);

通达信主力灯塔指标公式

 

相关文章