在线检测未来函数

通达信博弈k线指标公式

来源:Internet,编辑:股旁网,2010-09-12

N1:=5; N2:=13; N3:=17; N4:=2;
KDCM:=100*(1-WINNER(C));
空头1:STICKLINE(C>1,KDCM,0,4.8,0),COLORLIGREEN;
空头:C>1,COLORLIGREEN;
DDCM:=100*WINNER(C);
多头1:STICKLINE(C>1,DDCM,0,4.8,0),COLORLIGRAY;
多头:C>1,COLORLIGRAY;
布林:=HHV(HHV(WINNER(LOW)*100,14),60);
阻力区:EMA(EMA(布林,16)-2*STD(布林,16),3),COLORLICYAN;
阻力:EMA(EMA(布林,14)+2*STD(布林,14),18),COLORLIGRAY;
STICKLINE(阻力区>0,阻力区,阻力,0,0),COLORLICYAN;
{70%筹码分布空间小于30%时为晶红色}
筹码上:=COST(85);
筹码下:=COST(15);
筹码中间价:=(筹码上+筹码下)/2;
下下:=(筹码下/筹码中间价*100)*2;
STICKLINE(下下<30,阻力区,阻力,3,0),COLORFFCC00;
主力区:WINNER(CLOSE)*CAPITAL/VOL,COLORSTICK;
VAR1:=1*VOL/CAPITAL;
VR2:=1*(WINNER(CLOSE)-REF(WINNER(CLOSE),1))/REF(WINNER(CLOSE),1);
VR3:=(C-REF(C,1))/REF(C,1);
穿透率:=VR2/VAR1*(1-VR3);
STICKLINE(穿透率>=0,0,穿透率/2,1/8,0),COLORRED;
STICKLINE(穿透率<0,0,穿透率/2,1/8,0),COLORGREEN;
获利盘:=WINNER(CLOSE)*100;
获利变动:=VR2;
套牢盘:=100*(1-WINNER(C)),COLORRED;
CKDP:100*(C-COST(1))/(COST(99)-COST(1)),COLORRED;
CBW:=100*(COST(99)-COST(1))/COST(1),COLORBLUE;
VAR2:=WINNER(OPEN)*100;
VAR3:=WINNER(CLOSE)*100;
VAR4:=WINNER(HIGH)*100;
VAR5:=WINNER(LOW)*100;
开:=WINNER(O)*100,LINETHICK0,COLORWHITE;
高:=WINNER(H)*100,LINETHICK0,COLORBLUE;
低:=WINNER(L)*100,LINETHICK0,COLORCYAN;
收:=WINNER(C)*100,LINETHICK0,COLORGREEN;
{股旁网-股票公式网站 www.Gupang.com}
博弈K线长阳:=收-开>20;
无量长阳:=收-开>15 AND V/CAPITAL<0.03;
STICKLINE(收>=开,开,收,3,1),COLORYELLOW;
STICKLINE(收>=开,低,开,0,0),COLORYELLOW;
STICKLINE(收>=开,收,高,0,0),COLORYELLOW;
STICKLINE(收<开,开,收,3,1),COLORGREEN;
STICKLINE(收<开,收,低,0,0),COLORGREEN;
STICKLINE(收<开,开,高,0,0),COLORGREEN;
STICKLINE(无量长阳,开,收,3,0),COLORMAGENTA;
STICKLINE(无量长阳,低,开,0,0),COLORMAGENTA;
STICKLINE(无量长阳,收,高,0,0),COLORMAGENTA;
STICKLINE(博弈K线长阳,开,收,3,0),COLORRED;
STICKLINE(博弈K线长阳,低,开,0,0),COLORRED;
STICKLINE(博弈K线长阳,收,高,0,0),COLORRED;
STICKLINE(CLOSE>0,100,100,3,0),COLORCYAN;
STICKLINE(CLOSE>0,80,80,3,0),COLORMAGENTA;
STICKLINE(CLOSE>0,50,50,3,0),COLORYELLOW;
STICKLINE(CLOSE>0,20,20,3,0),COLORMAGENTA;
STICKLINE(CLOSE>0,0,0,3,0),COLORCYAN;
均线:EMA(VAR3,34),COLORCC9900,LINETHICK2;
突:EMA(WINNER(CLOSE),25)+EMA(WINNER(CLOSE),60)/11*1000,COLORWHITE;
牛熊线:=(COST(65)-COST(35))*100/(COST(97)-COST(3)), COLORBLUE;
WIN:=100*WINNER(CLOSE );
STICKLINE(WIN>REF(WIN,1)AND(WINNER(CLOSE)-WINNER(OPEN))*100>25,WIN,REF(WIN,1),0.01,0),COLORWHITE;
STICKLINE(WIN<REF(WIN,1)AND(WINNER(OPEN)-WINNER(CLOSE))*100>25,WIN,REF(WIN,1),0.01,0),COLORBLUE;
算:=REF(CLOSE,1)*0.865;
再算:=REF(CLOSE,13)*0.772;
启动:=IF((CLOSE-MIN(算,再算))/CLOSE<0.1 AND SUM(穿透率,5)/5<1.8,1, 0);
Y1:=STICKLINE(启动,0,V*100/CAPITAL,0.1,0),LINETHICK3,COLORGREEN;
Y2:=STICKLINE(VOL>MA(VOL,5)*0.1,0,VOL,0.1,0);
DRAWICON(启动,18,1);
MA1:=MA(WINNER(CLOSE)*100,N1),COLORWHITE;
MA2:=MA(WINNER(CLOSE)*100,N2),COLORYELLOW;
VR5:=IF(ABS(WINNER(CLOSE)-WINNER(OPEN))*100/(VOL/CAPITAL*100)>=10 AND ABS(WINNER(CLOSE)-WINNER(OPEN))*100>=25 AND CLOSE>OPEN,ABS(WINNER(CLOSE)-WINNER(OPEN))*100,0);
DRAWTEXT(VR5,WINNER(LOW)*100,'关注'),COLORBLUE;
DRAWTEXT(WINNER(OPEN)<WINNER(CLOSE) AND CROSS(WINNER(CLOSE)*100,MA1) AND MA1>=MA2 ,WINNER(LOW)*100,'买入'),COLORYELLOW;
{买入选股:80*(WINNER(OPEN)<WINNER(CLOSE) AND CROSS(WINNER(CLOSE)*100,MA1) AND MA1>=MA2),COLORYELLOW;}
无量长阳选股:60*((WINNER(CLOSE)-WINNER(OPEN))*100>=N3 AND VOL/CAPITAL*100<=N4),COLORMAGENTA;
{DRAWTEXT(CURRBARSCOUNT=60,-10,'绿空—阴线'),COLOR0000FF;
DRAWTEXT(CURRBARSCOUNT=60,-20,'黄空—阳线'),COLORFFFFFF;
DRAWTEXT(CURRBARSCOUNT=60,-30,'桃红实心—无量长阳'),COLOR00FFFF;
DRAWTEXT(CURRBARSCOUNT=60,-40,'红色实心——博弈K长阳'),COLOR00FF00;};

通达信博弈k线指标公式

 

相关文章