在线检测未来函数

通达信MACD强弱分柝走势指标公式

来源:Internet,编辑:股旁网,2010-09-01

DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA), COLORSTICK;
DRAWBAND(DIFF,RGB(255,50,0),DEA,RGB(0,255,50));
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,1,0),COLORGREEN;
STICKLINE(MACD<REF(MACD,1)AND MACD<0,0,MACD,1,0),COLORFFCC33;
STICKLINE(MACD>REF(MACD,1)AND MACD,0,MACD,1,0),COLORYELLOW;
STICKLINE(MACD>REF(MACD,1)AND MACD>0,0,MACD,1,0),COLORMAGENTA;
强弱分界:0,COLORBLUE,LINETHICK2;
{股旁网-股票公式网站 www.gupaNg.com}
DRAWTEXT(ISLASTBAR AND DIFF>REF(DIFF,1),DIFF,' ↑向上趋势'),COLORFFFFFF;
DRAWTEXT(ISLASTBAR AND DIFF<REF(DIFF,1),DIFF,' ↓向下趋势'),COLORFFFFFF;
DRAWTEXT(ISLASTBAR AND MACD>REF(MACD,1),MACD,' ↑上涨柱'),COLOR0000FF;
DRAWTEXT(ISLASTBAR AND MACD<REF(MACD,1),MACD,' ↓下跌柱'),COLOR00FF00;

通达信MACD强弱分柝走势指标公式

 

相关文章