在线检测未来函数

飞狐ACCI指标公式

来源:Internet,编辑:股旁网,2010-09-03

DRAWGBK((CLOSE > 0),COLORRGB(0,0,0),COLORRGB(0,0,0),1);
N1:=5;N2:=10;
{cdp}
PT := REF(HIGH,1)-REF(LOW,1),linethick0;
CDP : (HIGH + LOW + CLOSE)/3,linethick0;
AH最高值 : CDP + PT,linethick0;
AL近高值 : CDP - PT,linethick0;
NH最低值 : 2*CDP-LOW,linethick0;
NL近低值 : 2*CDP-HIGH,linethick0;
{}
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=(SMA(RSV,9,1));
KK:=INTPART(SMA(RSV,3,1));
DD:=INTPART(SMA(K,3,1));
A:=(KK-DD)*5;
A1:=REF(A,1);
B:=A1-A,Color808080;
B1:=REF(A1-A,1);
B2:=REF(A1-A,2);
CC:=B+B1+B2,Color00FFFF;
短强:STICKLINE(a>cc and a>0 ,a,cc,8,0),Color0000D5;
转强:STICKLINE(a>cc and a<0,a,cc,8,0),Color00DFDF;
转弱:STICKLINE(a<=cc and a>0,a,cc,8,0),Color00CA00;
弱势:STICKLINE(a<cc and a<0,a,cc,8,0),ColorFF0000;
Var1A:=EMA(EMA(EMA(CLOSE,1),3),3),Color00FF00;
aa:=Var1A-REF(Var1A,1)+Var1A,;
TYP:=(HIGH + LOW + CLOSE)/3;
cci:="cci"(14);
a:=ref(c,1);
rsi:=sma(max(c-a,0),6,1)/sma(abs(c-a),6,1)*100;
a1:=c-ma(c,5)/ma(c,5)*100<1;
a2:=c-ma(c,13)/ma(c,13)*100<-10;
a3:=c-ma(c,34)/ma(c,34)*100<-15;
a4:=rsi<18;
a5:=cci<-120;
底:(a1 and a2 and a3 and a4 and a5)*100;
rK:SMA(cci,3,1),linethick0;
rD:SMA(rK,3,1),linethick0;
rJ:3*rK-2*rD,linethick0;
头:=390+REVERSE(EMA(rJ, 1));
底:=-290+REVERSE(EMA(rJ,1)),linethick0;
抛:if(rJ>头,200,300),COLORGREEN;
吸:if(rJ<底,-200,-300),colorred,linethick2;
TYP := (HIGH + LOW + CLOSE)/3;
CCI:(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14)),COLORWHITE,LINETHICK2;
底部:-200,LINEDOT;
买入:-100,LINEDOT,COLORGRAY;
卖出:100,LINEDOT;
aass:0;
底部:=CROSS(CCI,-100);
DRAWICON(底部,-100,1);
顶部:=CROSS(150,CCI);
DRAWICON(顶部,150,2);
TYP := (HIGH + LOW + CLOSE)/3;
JG1:=(TYP-MA(TYP,N1))/(0.015*AVEDEV(TYP,N1));
JG2:=(TYP-MA(TYP,N2))/(0.015*AVEDEV(TYP,N2));
JGA:=EMA(JG1,13 );
JGB:=EMA(JG2,13);
aa:=cross(jg2,-200) and jg1>-100;
{股旁网-股票公式网站 www.Gupang.com}
drawtext(cross(jgb,jga)and jgb>0,210,' $逃顶')linethick2 ,color9999ff;
drawtext(filter(aa,5)=1,-180,' $抄底')linethick2, coloryellow;
stickline(cross(jgb,jga)and jgb>0,180,210,10,0),colorgreen ;
stickline(filter(aa,5)=1,-180,-210,10,0),colorred;
{}
中线: -200*(HHV(HIGH,40)-CLOSE)/(HHV(HIGH,40)-LLV(LOW,40)),LINETHICK0;
短线: -200*(HHV(HIGH,10)-CLOSE)/(HHV(HIGH,10)-LLV(LOW,10)),COLORFFFF00,LINETHICK0;
逃顶线: -5,COLOR00FF00,LINETHICK0;
抄底线: -250,COLORRED,LINETHICK0;
DRAWTEXT(中线>-3.5,逃顶线+180,'逃'),COLORGREEN;
DRAWTEXT(中线<-196,抄底线-8,'底'),COLORFF00FF;
{}
VAR1:=EMA(CLOSE,12)-EMA(CLOSE,24);
VAR11:=EMA(CLOSE,24)-EMA(CLOSE,12);
VAR2:=EMA(VAR1,9);
VAR22:=EMA(VAR11,9);
VAR3:=(VAR1-VAR2)*10;
VAR33:=(VAR11-VAR22)*12;
VAR5:= IF( VAR3>0.5,POW(VAR3,3)*10/10+POW(VAR3,3),0);
VAR55:= IF( VAR33>0.5,POW(VAR33,3)*10/10+POW(VAR33,3),0);
顶2:VAR5>0;
底2:VAR55>0;
DRAWICON(顶2=1 AND REF(顶2,1)=0 AND REF(顶2,2)=0 AND REF(顶2,3)=0 AND REF(顶2,4)=0 AND REF(顶2,5)=0 AND REF(顶2,6)=0 AND REF(顶2,7)=0 AND REF(顶2,8)=0,0,1);
{神奇变色线}
趋势:SMA(((CLOSE-LLV(LOW,28))/(HHV(HIGH,28)-LLV(LOW,28))),3,1),COLORRED,LINETHICK;
判断:SMA(趋势,3,1),COLORYELLOW;
PARTLINE(判断>50 AND 趋势>判断,判断),COLORYELLOW,LINETHICK3;
PARTLINE(判断<50 AND 趋势<=判断,判断),COLORBLUE,LINETHICK3;
PARTLINE(判断>50 AND 趋势<=判断,判断),COLORRED,LINETHICK3;
PARTLINE(判断<50 AND 趋势>判断,判断),COLOR1477ff,LINETHICK3;

飞狐ACCI指标公式

 

相关文章