在线检测未来函数

飞狐顶底先知指标公式

来源:Internet,编辑:股旁网,2010-09-03

使用说明:底部出现黄色细线进入底部关注,出现B时买入顶部出现粉色及蓝色减仓、清仓。

DRAWGBK(DATE>900101,COLORRGB(15,50,90),COLORRGB(0,0,0),1);//蓝色
VAR1:=IF(DATE>=2990601,0,1);
VAR2:=TROUGHBARS(3,15,1)<10;
VAR3:=PEAKBARS(3,15,1)<10;
VAR4:=IF(VAR2=1,50,0);
VAR5:=IF(VAR3=1,50,0);
底: IF(VAR4=50,50,0),STICK,LINETHICK1;
顶: IF(VAR5=50,80,0),STICK,LINETHICK1;
TT:=BARPOS=SYSPARAM(2);
HH:=SYSPARAM(4);
DRAWTEXT(TT,HH,'代码:'+STKLABEL),ALIGN4,PXDN1,colorFFFFFF;
DRAWTEXT(TT,HH,' 名称:'+STKNAME),ALIGN4,PXDN1,colorFF00;
drawtext(sysparam(2)=barpos,c,' 板块:'+blkname),,colorcyan,align4;
{捞钱手(原码)}
拾金线:ma(sma((l+h+2*c)/4-ref((l+h+2*c)/4,1),5,1)/sma(abs((l+h+2*c)/4-ref((l+h+2*c)/4,1)),5,1)*100,1)+50,LINETHICK0,COLORMAGENTA;
顶a:120,POINTDOT,COLORWHITE,LINETHICK0;
风险:100,POINTDOT,COLORWHITE,LINETHICK0;
中:50,POINTDOT,COLORWHITE,LINETHICK0;
减仓:IF(拾金线>=风险,100,120),LINETHICK1,colorwhite;
减仓2:=IF(CROSS(拾金线,风险),100,120);
DRAWTEXT(减仓2=100,100,'减仓'),LINETHICK1,COLORWHITE;
卖出:IF( CROSS(风险,拾金线),100,120),LINETHICK1,COLORGREEN;
DRAWTEXT(卖出=100,95,'卖出'),LINETHICK1,COLORGREEN;
{}
rr8:=MA(CLOSE,27);
rr9:=(CLOSE-rr8)/rr8*100;
rrA:=MA(rr9,2);
rrB:=BARSLAST(CROSS(-10,rrA)=1);
rrD:=rrA<-10 AND rrB>3;
【黄金坑】:IF(rrD,-60,0),coloryellow,LINETHICK2;
{顶底先知}
CS:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
YJD:(EMA(CS,3)-50)*2,colorred;
0;
极弱:-80;
强势1:60;
风险1:80;
弱势1:-60;
FILLRGN(YJD<弱势1,YJD,弱势1),color000082;
FILLRGN(YJD>强势1,YJD,强势1),COLORCC6600;
{股旁网-股票公式网站 www.Gupang.com}
VAR1:=REF(CLOSE,1);
VAR2:=SMA(MAX(CLOSE-VAR1,0),6,1)/SMA(ABS(CLOSE-VAR1),6,1)*100;
STICKLINE(CROSS(75.9,VAR2),YJD+5,YJD-5,3,0),COLORYELLOW;
DRAWTEXT(ISLASTBAR=1,78,' 清仓'),COLORRED;
DRAWTEXT(ISLASTBAR=1,60,' 减仓'),COLORYELLOW;
DRAWTEXT(ISLASTBAR=1,0,' 控盘'),COLORWHITE;
DRAWTEXT(ISLASTBAR=1,-60,' 回补'),COLORGREEN;
DRAWTEXT(ISLASTBAR=1,-80,' 吸筹'),COLORBLUE;
VAR1:=REF(CLOSE,1);
VAR2:=(SMA(MAX(CLOSE-VAR1,0),6,1))/(SMA(ABS(CLOSE-VAR1),6,1))*100;
短期顶部:CROSS(80,VAR2)*30,colorFFFFFF,LINETHICK0;
DRAWTEXT(CROSS(80,VAR2),90,'★见顶 '),colorFFFF;
Nv:=5;
VAR1:4*SMA((CLOSE-LLV(LOW,Nv))/(HHV(HIGH,Nv)-LLV(LOW,Nv))*100,5,1)-
3*SMA(SMA((CLOSE-LLV(LOW,Nv))/(HHV(HIGH,Nv)-LLV(LOW,Nv))*100,5,1),3.2,1),COLORYELLOW,LINETHICK0;
VAR2:=8,COLORGREEN,LINETHICK0;
上升在即: IF(CROSS(VAR1,VAR2),-80,0),STICK,COLOR0000CC,LINETHICK0;
DRAWTEXT(CROSS(VAR1,VAR2),-50,'B'),COLOR00FFFF;
{时间}
BB:=BARPOS=SYSPARAM(1);
variable:wday[7]='星期六';
wday[1]:='星期日';
wday[2]:='星期一';
wday[3]:='星期二';
wday[4]:='星期三';
wday[5]:='星期四';
wday[6]:='星期五';
fy:=YEAR;
fm:=MONTH;
fd:=DAY;
wd:=WEEKDAY;
p:=SYSPARAM(1);
str1:=' '+' 今日: '+NUMTOSTR(fy[p],0)+'年'+NUMTOSTR(fm[p],0)+'月'+NUMTOSTR(fd[p],0)+'日 '+wday[wd[p]+1]+'';
DRAWTEXT(barpos=p,-57,'\n \n'+str1),PXUP10,ALIGN2,COLORFFEEAA;

飞狐顶底先知指标公式

 

相关文章