在线检测未来函数

通达信主力显现主图指标公式

来源:Internet,编辑:股旁网,2010-11-18

H1:EMA(C,8);
H2:EMA(H1,20);
VR1:=(HHV(H,36)-C)/(HHV(H,36)-LLV(L,36))*100;
VR2:=SMA(VR1,5,1);
VR3:=SMA(VR2,8,1);
VAR4:=CROSS(VR2,VR3) AND VR3< 20;
VAR5:=C>LLV(C,60)*1.13 AND VAR4;
VAR6:=IF(C>200,VAR4,VAR5);
HH2:=XMA(CLOSE,14);
HH3:=MEMA(CLOSE,4);
VAR1:=(CLOSE-LLV(LOW,60.135))/(HHV(HIGH,60.135)-LLV(LOW,60))*80;
VAR2:=SMA(VAR1,7,1);
VAR3:=SMA(VAR2,5,1);
AA1:=AMOUNT/VOL;
BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=VOL<MA(V,5)*1.5;
FF1:=BB1 AND CC1 AND DD1 AND EE1;
{股旁网-股票公式网站 www.gupanG.com}
DRAWTEXT(FF1,L*0.99,'庄影'),COLORYELLOW;
AA:=CROSS(MA(C,5),MA(C,20)) AND CROSS(MA(C,5),MA(C,30)) AND CROSS(MA(C,5),MA(C,60));
BB:=MA(C,60)>MA(C,10) AND CROSS(MA(C,10),MA(C,30)) AND MA(C,30)>MA(C,20) AND ABS(MA(C,60)-MA(C,20))/MA(C,20)<0.05;
CC:=MA(C,30)>MA(C,5) AND CROSS(MA(C,5),MA(C,20)) AND MA(C,20)>MA(C,10), COLORYELLOW;
DD:=ABS((MA(C,5)-MA(C,10))+(MA(C,10)-MA(C,20))+(MA(C,20)-MA(C,30)))<0.02 AND MA(C,5)>REF(MA(C,5),1) AND MA(C,10)>REF(MA(C,10),1);
EE:=MA(C,20)>MA(C,5) AND CROSS(MA(C,5),MA(C,10)) AND MA(C,10)>MA(C,60) AND ABS(MA(C,20)-MA(C,60))/MA(C,60)<0.05;
FF:=AA OR BB OR CC OR DD OR EE ;
HH1:=FF AND FILTER( FF,8);
DRAWICON(HH1,L,1);
DRAWTEXT(HH1,L*0.958,'庄现'),COLORWHITE;
DRAWICON(LONGCROSS(HH2,HH3,1),HH2*0.958,1),COLORRED;
DRAWICON(LONGCROSS(HH3,HH2,1),HH3*1.03,2),COLORGREEN;
DRAWTEXT(CROSS(VAR2,VAR3) AND VAR2<20 AND HH2>HH3,HH2*0.9165,'★坚决全仓'),COLORMAGENTA;
低吸:0.82*MA(FORCAST(CLOSE,2),40),COLORF7E300,POINTDOT;
满仓:0.72*MA(FORCAST(CLOSE,2),40),POINTDOT,COLOR0000FF;

通达信主力显现主图指标公式

 

相关文章