在线检测未来函数

通达信关注涨停主图指标公式

来源:Internet,编辑:股旁网,2011-02-08

MID:=(3*CLOSE+LOW+OPEN+HIGH)/6;
DKX:(20*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+16*REF(MID,4)+15*REF(MID,5)
+14*REF(MID,6)+13*REF(MID,7)+12*REF(MID,8)+11*REF(MID,9)+10*REF(MID,10)+9*REF(MID,11)
+8*REF(MID,12)+7*REF(MID,13)+6*REF(MID,14)+5*REF(MID,15)+4*REF(MID,16)+3*REF(MID,17)
+2*REF(MID,18)+REF(MID,20))/210,LINETHICK1;
MADKX:MA(DKX,10),LINETHICK1;
X1A:=30;
压力:HHV(C,X1A),COLORFF5500;
X1C:=IF(ISLASTBAR,BARSLAST(C=CONST(压力))+1,1/0);
X1D:=IF(X1C=1,' 1',IF(X1C=2,' 2',IF(X1C=3,' 3',IF(X1C=4,' 4',IF(X1C=5,' 5',
IF(X1C=6,' 6',IF(X1C=7,' 7',IF(X1C=8,' 8',IF(X1C=9,' 9',IF(X1C=10,' 10',
IF(X1C=11,' 11',IF(X1C=12,' 12',IF(X1C=13,' 13',IF(X1C=14,' 14',IF(X1C=15,' 15',
IF(X1C=16,' 16',IF(X1C=17,' 17',IF(X1C=18,' 18',IF(X1C=19,' 19',IF(X1C=20,' 20',
IF(X1C=21,' 21',IF(X1C=22,' 22',IF(X1C=23,' 23',IF(X1C=24,' 24',IF(X1C=25,' 25',
IF(X1C=26,' 26',IF(X1C=27,' 27',IF(X1C=28,' 28',IF(X1C=29,' 29',IF(X1C=30,' 30',' 0'))))))))))))))))))))))))))))));
X1E:DRAWTEXT(ISLASTBAR,压力,X1D),COLORFF5500;
X2A:=30;
支撑:LLV(C,X2A),COLORFF00FF;
X2C:=IF(ISLASTBAR,BARSLAST(C=CONST(支撑))+1,1/0);
X2D:=IF(X2C=1,' 1',IF(X2C=2,' 2',IF(X2C=3,' 3',IF(X2C=4,' 4',IF(X2C=5,' 5',
IF(X2C=6,' 6',IF(X2C=7,' 7',IF(X2C=8,' 8',IF(X2C=9,' 9',IF(X2C=10,' 10',
IF(X2C=11,' 11',IF(X2C=12,' 12',IF(X2C=13,' 13',IF(X2C=14,' 14',IF(X2C=15,' 15',
IF(X2C=16,' 16',IF(X2C=17,' 17',IF(X2C=18,' 18',IF(X2C=19,' 19',IF(X2C=20,' 20',
IF(X2C=21,' 21',IF(X2C=22,' 22',IF(X2C=23,' 23',IF(X2C=24,' 24',IF(X2C=25,' 25',
IF(X2C=26,' 26',IF(X2C=27,' 27',IF(X2C=28,' 28',IF(X2C=29,' 29',IF(X2C=30,' 30',' 0'))))))))))))))))))))))))))))));
X2E:DRAWTEXT(ISLASTBAR,支撑,X2D),COLORFF00FF;
ZDT:=(C-REF(C,1))/REF(C,1)*100;
STICKLINE(ZDT>9.8,O,C,2,0),COLORYELLOW;
STICKLINE(ZDT<-9.8,O,C,2,0),COLOR00FF00;
{股旁网-股票公式网站 www.GupAng.com}
涨停:=ZDT>9.8;
不破价:=REF(L,BARSLAST(涨停));
LS0:=BARSLAST(涨停);
LS11:=IF(1,LS0=1,涨停);
LS21:=IF(1,LLV(L,1)>REF(L,1),1);
涨停不破:=LS11 AND LS21;
STICKLINE(涨停不破,不破价-不破价*0.002,不破价,4,0),COLORRED;
DRAWTEXT(涨停不破,不破价-不破价*0.02,'1'),COLORGREEN;
LS12:=IF(2,LS0=2,涨停);
LS22:=IF(2,LLV(L,2)>REF(L,2),1);
涨停不破2:=LS12 AND LS22;
{股旁网-股票公式网站 www.GupAng.com}
STICKLINE(涨停不破2,不破价-不破价*0.002,不破价,4,0),COLORRED;
DRAWTEXT(涨停不破2,不破价-不破价*0.02,'2'),COLORGREEN;
LS13:=IF(3,LS0=3,涨停);
LS23:=IF(3,LLV(L,3)>REF(L,3),1);
涨停不破3:=LS13 AND LS23;
STICKLINE(涨停不破3,不破价-不破价*0.002,不破价,4,0),COLORRED;
DRAWTEXT(涨停不破3,不破价-不破价*0.02,'3'),COLORGREEN;
LS14:=IF(4,LS0=4,涨停);
LS24:=IF(4,LLV(L,4)>REF(L,4),1);
涨停不破4:=LS14 AND LS24;
STICKLINE(涨停不破4,不破价-不破价*0.002,不破价,4,0),COLORRED;
DRAWTEXT(涨停不破4,不破价-不破价*0.02,'4'),COLORGREEN;
LS15:=IF(5,LS0=5,涨停);
LS25:=IF(5,LLV(L,5)>REF(L,5),1);
涨停不破5:=LS15 AND LS25;
STICKLINE(涨停不破5,不破价-不破价*0.002,不破价,4,0),COLORRED;
DRAWTEXT(涨停不破5,不破价-不破价*0.02,'5'),COLORGREEN;
LS16:=IF(6,LS0=6,涨停);
LS26:=IF(6,LLV(L,6)>REF(L,6),1);
涨停不破6:=LS16 AND LS26;
STICKLINE(涨停不破6,不破价-不破价*0.002,不破价,4,0),COLORRED;
DRAWTEXT(涨停不破6,不破价-不破价*0.02,'6'),COLORGREEN;
LS17:=IF(7,LS0=7,涨停);
LS27:=IF(7,LLV(L,7)>REF(L,7),1);
涨停不破7:=LS17 AND LS27;
STICKLINE(涨停不破7,不破价-不破价*0.002,不破价,4,0),COLORRED;
DRAWTEXT(涨停不破7,不破价-不破价*0.02,'7'),COLORGREEN;
LS18:=IF(8,LS0=8,涨停);
LS28:=IF(8,LLV(L,8)>REF(L,8),1);
涨停不破8:=LS18 AND LS28;
STICKLINE(涨停不破8,不破价-不破价*0.002,不破价,4,0),COLORRED;
DRAWTEXT(涨停不破8,不破价-不破价*0.02,'8'),COLORGREEN;
LS19:=IF(9,LS0=9,涨停);
LS29:=IF(9,LLV(L,9)>REF(L,9),1);
涨停不破9:=LS19 AND LS29;
STICKLINE(涨停不破9,不破价-不破价*0.002,不破价,4,0),COLORRED;
DRAWTEXT(涨停不破9,不破价-不破价*0.02,'9'),COLORGREEN;
LS110:=IF(10,LS0=10,涨停);
LS210:=IF(10,LLV(L,10)>REF(L,10),1);
涨停不破10:=LS110 AND LS210;
STICKLINE(涨停不破10,不破价-不破价*0.002,不破价,4,0),COLORRED;
DRAWTEXT(涨停不破10,不破价-不破价*0.02,'0'),COLORGREEN;
LS111:=IF(11,LS0=11,涨停);
LS211:=IF(11,LLV(L,11)>REF(L,11),1);
涨停不破11:=LS111 AND LS211;
STICKLINE(涨停不破11,不破价-不破价*0.002,不破价,4,0),COLORRED;
DRAWTEXT(涨停不破11,不破价-不破价*0.02,'1'),COLORGREEN;
LS112:=IF(12,LS0=12,涨停);
LS212:=IF(12,LLV(L,12)>REF(L,12),1);
涨停不破12:=LS112 AND LS212;
STICKLINE(涨停不破12,不破价-不破价*0.002,不破价,4,0),COLORRED;
DRAWTEXT(涨停不破12,不破价-不破价*0.02,'2'),COLORGREEN;
LS113:=IF(13,LS0=13,涨停);
LS213:=IF(13,LLV(L,13)>REF(L,13),1);
涨停不破13:=LS113 AND LS213;
STICKLINE(涨停不破13,不破价-不破价*0.002,不破价,4,0),COLORRED;
DRAWTEXT(涨停不破13,不破价-不破价*0.02,'3'),COLORGREEN;
LS114:=IF(14,LS0=14,涨停);
LS214:=IF(14,LLV(L,14)>REF(L,14),1);
涨停不破14:=LS114 AND LS214;
STICKLINE(涨停不破14,不破价-不破价*0.002,不破价,4,0),COLORRED;
DRAWTEXT(涨停不破14,不破价-不破价*0.02,'4'),COLORGREEN;
LS115:=IF(15,LS0=15,涨停);
LS215:=IF(15,LLV(L,15)>REF(L,15),1);
涨停不破15:=LS115 AND LS215;
STICKLINE(涨停不破15,不破价-不破价*0.002,不破价,4,0),COLORRED;
DRAWTEXT(涨停不破15,不破价-不破价*0.02,'5'),COLORGREEN;

通达信关注涨停主图指标公式

 

相关文章