在线检测未来函数

通达信WR+DMI指标公式

来源:Internet,编辑:股旁网,2011-02-08

N:=7;
{DMI}
MTR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),N);
DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),N);
PDI: DMP*100/MTR;
MDI: DMM*100/MTR;
DRAWBAND(PDI,RGB(100,0,50),MDI,RGB(256,96,96));
ADX:EXPMEMA((PDI-MDI)/(PDI+MDI)*100,N),COLORFF00FF;
{股旁网-股票公式网站 www.GupAng.com}
ADXR:EXPMEMA(ADX,N/2),COLOR00FF00;
{LTSH}
WR:100-100*(HHV(HIGH,40)-CLOSE)/(HHV(HIGH,40)-LLV(LOW,40)),COLORFFFFFF,LINETHICK2;
见顶:100,COLOR0000FF,LINETHICK2;
见底:0,COLOR00FF00,LINETHICK2;
STICKLINE(WR=100,101,110,5,0),COLOR0000FF;
STICKLINE(WR=0,101,110,5,0),COLOR00FF00;
STICKLINE(WR<100 AND WR>=99,101,110,5,1),COLOR00FFFF;
STICKLINE(WR<=0.6 AND WR>0,101,110,5,0),COLOR00FFFF;

通达信WR+DMI指标公式

 

相关文章