在线检测未来函数

通达信CCI精灵指标公式

来源:Internet,编辑:股旁网,2011-02-17

N:=14;
VAR1:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
VAR2:=SMA(ABS(LOW-VAR1),13,1)/SMA(MAX(LOW-VAR1,0),10,1);
VAR3:=EMA(VAR2,10);
VAR4:=LLV(LOW,33);
VAR5:=EMA(IF(LOW<=VAR4,VAR3,0),3);
主力进场:IF(VAR5>REF(VAR5,1),VAR5,0),COLORRED,NODRAW;
STICKLINE(VAR5>REF(VAR5,1),0,VAR5,3,0 ),COLOR000055;
STICKLINE(VAR5>REF(VAR5,1),0,VAR5,2.6,0 ),COLOR000077;
STICKLINE(VAR5>REF(VAR5,1),0,VAR5,2.1,0 ),COLOR000099;
STICKLINE(VAR5>REF(VAR5,1),0,VAR5,1.5,0 ),COLOR0000BB;
STICKLINE(VAR5>REF(VAR5,1),0,VAR5,0.9,0 ),COLOR0000DD;
STICKLINE(VAR5>REF(VAR5,1),0,VAR5,0.3,0 ),COLOR0000FF;
洗盘:IF(VAR5<REF(VAR5,1),VAR5,0),COLORGREEN,NODRAW;
STICKLINE(VAR5<REF(VAR5,1),0,VAR5,3,0),COLOR005500;
STICKLINE(VAR5<REF(VAR5,1),0,VAR5,2.6,0),COLOR007700;
STICKLINE(VAR5<REF(VAR5,1),0,VAR5,2.1,0),COLOR009900;
STICKLINE(VAR5<REF(VAR5,1),0,VAR5,1.5,0),COLOR00BB00;
STICKLINE(VAR5<REF(VAR5,1),0,VAR5,0.9,0),COLOR00DD00;
STICKLINE(VAR5<REF(VAR5,1),0,VAR5,0.3,0),COLOR00FF00;
{股旁网-股票公式网站 www.GupaNg.com}
趋势线:= (CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*100 , COLORAABBDD;
BB:=((REF(趋势线,1)<REF(趋势线,2) AND 趋势线<-20 AND 趋势线>-25) AND 趋势线>=REF(趋势线,1)) OR (REF(CROSS(-20,趋势线),1) AND CROSS(趋势线,-20));
DRAWTEXT(BB,80,'见底信号'),COLOR41B5FA;
见底信号:IF(BB,80,-1),COLORRED;
TYP:=(HIGH+LOW+CLOSE)/3;
CCI20:(TYP-MA(TYP,N))/(0.015*AVEDEV(TYP,N)) COLORYELLOW;
K:=SMA(CCI20,3,1);
D:=SMA(K,3,1);
指数TYP:=(INDEXH+INDEXL+INDEXC)/3;
指数CCI:=(指数TYP-MA(指数TYP,N))/(0.015*AVEDEV(指数TYP,N));
DRAWBAND(K,RGB(255,50,100),D,RGB(0,200,0));
IF(CCI20<REF(CCI20,1),CCI20,DRAWNULL),COLORFFFF00,LINETHICK1;
IF(CCI20>REF(CCI20,1),CCI20,DRAWNULL),COLOR0000EA,LINETHICK2;
超跌:-175,POINTDOT,COLORCYAN,LINETHICK4;
STICKLINE(CCI20<=-185,-185,-200,2,0),COLOR377CF0;
顶部:150,POINTDOT,COLORGREEN,LINETHICK4;
STICKLINE(CCI20>=150,158,168,2,0),COLORGREEN;
强势买入:STICKLINE(C,100,100,-1,0),COLORLIMAGENTA;
反弹买入:STICKLINE(C,-100,-100,-1,0),COLOR0099FF;
抄底:IF(CROSS(CCI20,反弹买入),-100,0),STICK,COLORYELLOW,LINETHICK2;
DRAWTEXT( CURRBARSCOUNT=45,198,'★主力进场 见底 CCI背离 先价突破 先机分时确认★'),COLORCYAN;

通达信CCI精灵指标公式

 

相关文章