在线检测未来函数

通达信DMI秀才指标公式

来源:Internet,编辑:股旁网,2011-04-04

TRYGB:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),14);
HD:=HIGH-REF(HIGH,1);
LD:=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),14);
DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),14);
多:DMP*100/TRYGB,COLORWHITE,LINETHICK1;
空:DMM*100/TRYGB,COLORYELLOW,LINETHICK1;
ADX:EXPMEMA(ABS(空-多)/(空+多)*100,5),COLORRED,LINETHICK1;
ADXR:EXPMEMA(ADX,3),COLORGREEN;
{股旁网-股票公式网站 www.GupaNG.com}
DRAWBAND(多,RGB(100,10,10),空,RGB(10,100,10));
DRAWBAND(ADX,RGB(250,10,10),ADXR,RGB(10,250,10));
IF(空<多 AND ADX>REF(ADX,1) AND ADX>=25,ADX,DRAWNULL),COLORRED,LINETHICK2;
IF(空<多 AND ADX>多 AND ADX<REF(ADX,1),ADX,DRAWNULL),COLORGREEN,LINETHICK1;
IF(空>多 AND 空>REF(空,1) AND 多<REF(多,1) AND ADX>REF(ADX,1),ADX,DRAWNULL),COLORCYAN,LINETHICK2;
IF(COUNT(多>=50,4)>=1 AND 多<=50 AND ADX>=70,ADX,DRAWNULL),COLORYELLOW,LINETHICK2;
VAR20:=(3*CLOSE+LOW+OPEN+HIGH)/6;
VAR21:=(20*VAR20+19*REF(VAR20,1)+18*REF(VAR20,2)+17*REF(VAR20,3)+16*REF(VAR20,4)+15*REF(VAR20,5)+14*REF(VAR20,6)+13*REF(VAR20,7)+12*REF(VAR20,8)+11*REF(VAR20,9)+10*REF(VAR20,10)+9*REF(VAR20,11)+8* REF(VAR20,12)+7*REF(VAR20,13)+6*REF(VAR20,14)+5*REF(VAR20,15)+4*REF(VAR20,16)+3*REF(VAR20,17)+2*REF(VAR20,18)+REF(VAR20,21))/210;
VAR22:=EMA(VAR21,15);
VAR23:=HHV(CLOSE,90);
VAR24:=LLV(CLOSE,90);
VAR25:=VAR23-VAR24;
VAR26:=EMA((CLOSE-VAR24)/VAR25-0.5,14);
ZLSP:=VAR26*20;
VAR27:=REF(HHV(CLOSE,66),2);
VAR28:=CROSS(CLOSE,VAR27) AND (HHV(CLOSE,110)/LLV(CLOSE,110)-1)*100<45 AND ZLSP<5.666;
VAR29:=LLV(ZLSP,35)<-8.9 AND CROSS(ZLSP,-7.815) AND ZLSP<-1.2;
VAR30:=10*FILTER(VAR29,41);
VAR31:=15*FILTER(VAR28,41)>10;
STICKLINE(VAR31,10,30,1,0),COLORYELLOW;

通达信DMI秀才指标公式

 

相关文章