在线检测未来函数

通达信一品量能指标公式

来源:Internet,编辑:股旁网,2011-04-09

N:=1;N1:=5;N2:=21;N3:=34;
AA:=(AMOUNT*N/C)/(HHV(AMOUNT,N1)/HHV(C,N1))*100;
AA2:=(AMOUNT*N/C)/(HHV(AMOUNT,N2)/HHV(C,N2))*100;
AA3:=(AMOUNT*N/C)/(HHV(AMOUNT,N3)/HHV(C,N3))*100;
SAT:IF(AA>100,100,AA),COLORFFFFFF,POINTDOT,LINETHICK2;
SAT2:IF(AA2>100,100,AA2),COLORE58211;
SAT3:IF(AA3>100,100,AA3),COLOR13ABF1;
GX:=MAX(SAT,MAX(SAT2,SAT3));
DX:=MIN(SAT,MIN(SAT2,SAT3));
{股旁网-股票公式网站 www.GupaNG.com}
QSXS:=GX>=REF(GX,1) AND DX>=REF(DX,1) AND CROSS(SAT,98);
↑:CROSS(QSXS,0.5),COLORFFFFFF,POINTDOT,LINETHICK0;
饱和:IF(SAT=SAT2 AND SAT2=SAT3,SAT,50),COLOR0000FF,LINETHICK2;
ZF:=(C/REF(C,1)-1)*100;
BDDZ:=H/REF(C,3)>=1.2 OR H/REF(L,7)>=1.3;
BDGD:=BDDZ AND HHV(H,4)=HHV(H,20) AND COUNT(ZF>=4.9,4)>=2;
起涨:IF(QSXS AND (CROSS(SAT2,70) OR CROSS(SAT3,70)) AND NOT(BDGD),100,0),COLOR00FF00,POINTDOT,LINETHICK0;
登顶:IF((CROSS(SAT3,80) OR COUNT(SAT3>=80,3)>=2) AND BDGD,100,0),COLORFFFF00,POINTDOT,LINETHICK0;
黄金坑:IF(COUNT(NOT(饱和=50),10) AND SAT<50,SAT,50),COLOR00FFFF,POINTDOT,LINETHICK0;
{以下设置副图显示方式}
STICKLINE(SAT>50,SAT,50,4,0),COLORFFB2AD;
STICKLINE(SAT2>50,SAT2,50,4,0),COLOR93FF8E;
STICKLINE(SAT3>50,SAT3,50,4,0),COLORFF00FF;
STICKLINE(黄金坑<50,黄金坑,50,4,0),COLOR00FFFF;
DRAWTEXT(↑,50, '↑'),COLORFFFFFF;
DRAWICON(起涨,50,1);
DRAWICON(登顶,50,2);

通达信一品量能指标公式

 

相关文章