在线检测未来函数

通达信RSI+CCI+KD指标公式

来源:Internet,编辑:股旁网,2011-04-18

TYP := (HIGH + LOW + CLOSE)/3;
CC1:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
DRAWTEXT(ISLASTBAR AND CC1,CC1,'CC1'),COLORFF00FF;
DRAWBAND(CC1,RGB(2,255,2),-100,RGB(255,255,0));
DRAWBAND(100,RGB(0,0,0),-100,RGB(0,0,0));
CC2:(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14)),COLORFF00FF;
LC := REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
RSI:(RSI1-50)*5,LINETHICK2,COLORFFFFFF;
DRAWTEXT(ISLASTBAR AND RSI>REF(RSI,1),RSI,' ↑RSI'),COLORFFFFFF;
DRAWTEXT(ISLASTBAR AND RSI<REF(RSI,1),RSI,' ↓RSI'),COLORFFFFFF;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
K1:(K-50)*5,COLORFF9F00;
{股旁网-股票公式网站 www.GupaNG.com}
DRAWTEXT(ISLASTBAR AND K1>REF(K1,1),K1,' ▲K'),COLORFFFF00;
DRAWTEXT(ISLASTBAR AND K1<REF(K1,1),K1,' ▼K'),COLORFFFF00;
0;
100,POINTDOT;
-100,POINTDOT;
-200,COLORFFFF00;
200,COLORFFFF00;
C1:=SMA(CC1,3,1);
C2:=SMA(C1,3,1);
C3:=3*C1-2*C2;
CB1:=EMA(C3,5);
CB2:=REF(CB1,1);
R1:=SMA(RSI,3,1);
D1:=SMA(R1,3,1);
J1:=3*R1-2*D1;
RR1:=EMA(J1,5);
RR2:=REF(RR1,1);
RR:=RR1>RR2;
K2:=SMA(K1,3,1);
D2:=SMA(K2,3,1);
J2:=3*K2-2*D2;
BB1:=EMA(J2,5);
BB2:=REF(BB1,1);
买入:RR AND NOT(REF(RR,1)) AND (RR1<-100 AND BB1<-100) AND CB1<-100,NODRAW;
DRAWICON(买入,-200,1);
卖出:REF(RR,1)=1 AND NOT(RR) AND CB1>100,NODRAW;
DRAWICON(卖出,200,2);

通达信RSI+CCI+KD指标公式

 

相关文章