在线检测未来函数

通达信选牛箱上上线主图指标公式

来源:Internet,编辑:股旁网,2011-05-05

波浪线:=ZIG(3,15);
沪深换手:="399300$AMOUNT"/1000000/42000,COLORAABBCC,LINETHICK1;
个股换手率:=VOL/CAPITAL*100;
HIGH1:=IF(HIGH<REF(H,1),(H+L)*0.5,HIGH);
HIGH2:=IF(HIGH<(REF(H,2)+REF(H,1))/2,(H+L)*0.5,HIGH);
LOW1:=IF(LOW>REF(L,1),CLOSE,(H+L)*0.5);
LOW2:=IF(LOW>(REF(L,2)+REF(L,1))/2,(H+L)*0.5,LOW);
OPEN1:=IF(OPEN<CLOSE,(H+L)*0.5,OPEN);
CLOSE1:=IF(CLOSE>=OPEN,CLOSE,(H+L)*0.5);
AGJ:=(3*HIGH1+HIGH2+LOW1+OPEN1+CLOSE+LOW)/8;
VARC:=MONTH/VOL/100;
VARE:=SUM(MONTH,6) OR AMOUNT/VARC/100;
CYC6:=DMA(AGJ,VOL/VARE),COLORBB88FF,LINETHICK1;
风向线D:=EMA(EMA(CYC6,10),10),COLOR3848AA,LINETHICK1;
风向线100:=EMA(EMA(CYC6,70),6),POINTDOT,COLORAAAAAA,LINETHICK1;
风向线65:=EMA(CYC6,65),POINTDOT,COLOR8800FF,LINETHICK1;
RSI1:="RSI.RSI1#MONTH";
月RSI2:="RSI.RSI2#MONTH";
月RSI3:="RSI.RSI3#MONTH";
ARSI:="RSI.RSI1#WEEK",COLOR5588AA;
BRSI:="RSI.RSI2#WEEK",COLOR00AACC;
CRSI:="RSI.RSI3#WEEK",COLOR77BB77;
周CK:="KDJ.K#WEEK";
周CD:="KDJ.D#WEEK";
高BB:=HHV(HIGH,200),COLOR660000;
低BB:=LLV(LOW,200),COLOR002366;
牛熊中轴:=(高BB+低BB)*0.5,COLORCC5500,LINETHICK1;
熊箱:=牛熊中轴-(牛熊中轴-低BB)*0.5,COLOR000088;
牛箱:=高BB-(高BB-牛熊中轴)*0.5,COLOR000088;
中轴:=STICKLINE(牛熊中轴,牛熊中轴,牛熊中轴,0.5,1),COLOR777777;
熊箱A:=STICKLINE(熊箱,熊箱,熊箱,0.1,1),COLOR707070;
牛箱A:=STICKLINE(牛箱,牛箱,牛箱,0.1,1),COLOR707070;
VVAR2:=EMA(SLOPE(EMA(CLOSE,13),8)*27+CLOSE,30);
VVAR3:=EMA(VVAR2,3);
VVAR4:=EMA(VVAR3,3);
VVAR5:=EMA(VVAR4,3);
VVAR6:=EMA(VVAR5,3);
VVAR7:=EMA(VVAR6,3);
VVAR8:=EMA(VVAR7,3);
VVAR9:=EMA(VVAR8,3);
VVARA:=BARSLAST(CROSS(CLOSE,VVAR9));
VVARB:=BARSLAST(CROSS(VVAR9,CLOSE));
多头线:=IF(CLOSE>VVAR9 AND CLOSE>REF(CLOSE,VVARA),REF(CLOSE,VVARA)
,REF(CLOSE,VVARA)),COLOR0058AA,LINETHICK2;
临界线:=IF(CLOSE<VVAR9 AND CLOSE<REF(CLOSE,VVARB),REF(CLOSE,VVARB)
,REF(CLOSE,VVARB)),COLOR000096,LINETHICK1;
SAR空:=IF(CLOSE<SAR(4,2,20),SAR(4,2,20),DRAWNULL),CROSSDOT,COLOR34BB34;
箱顶:=PEAK(CLOSE,10,1)*0.98,COLOR808080;
箱底:=TROUGH(CLOSE,10,1)*1.02,COLOR0066AA;
DF:=7*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1)
-3*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1),3,1)
-SMA(SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1)
,3,1),2,1),COLOR00EEFF,LINETHICK1;
KF:=EMA(MA(DF,5),7),COLOR777777,LINETHICK1;
STICKLINE((月RSI1<月RSI3 OR 波浪线<=REF(波浪线,1)) AND CROSS(REF(ZIG(3,15),1),ZIG(3,15)) AND DF<REF(DF,1)
,HHV(HIGH,3),HHV(HIGH,3)*0.991,10,0),COLORBB0000;
波高:=DRAWTEXT(CROSS(REF(ZIG(3,15),1),ZIG(3,15)),H,'波高'),COLOREEEE00;
STICKLINE(CROSS(ZIG(3,15),REF(ZIG(3,15),1)) AND (月RSI1>月RSI3 OR 波浪线>=REF(波浪线,1)),LLV(LOW,8)*1.01,LLV(LOW,8),10,0),COLOR0000AA;
波低:=DRAWTEXT(CROSS(ZIG(3,17),REF(ZIG(3,17),1)),L*0.995,'低'),COLOR0000FF;
AAA:=IF(C>=REF(C,3),1,0);
BBB:=IF(C>=REF(C,4),1,0);
CCC:=IF(C>=REF(C,5),1,0);
DDD:=IF(C>=REF(C,6),1,0);
EEE:=IF(C>=REF(C,7),1,0);
FFF:=IF(C>=REF(C,8),1,0);
GGG:=IF(C>=REF(C,9),1,0);
HHH:=IF(C>=REF(C,10),1,0);
III:=IF(C>=REF(C,11),1,0);
JJJ:=IF(C>=REF(C,12),1,0);
GZ2:=AAA+BBB+CCC+DDD+EEE+FFF+GGG+HHH+III+JJJ;
KK:=REF(GZ2,1)+REF(GZ2,2)+REF(GZ2,3)+REF(GZ2,4);
KKK:=KK/4;
GJ:=IF(CLOSE=CLOSE,(CLOSE+LOW+OPEN+HIGH)/4,AMOUNT/(V+0.001)/100);
明日阻力:=L+(GJ-L)+(C-L);
明日支撑:=L+(C-GJ);
今日阻力:=REF(明日阻力,1);
今日支撑:=REF(明日支撑,1);
ARH:=REF(HHV(今日阻力,2),1);
ARL:=REF(LLV(今日支撑,2),1);
阻支:=(今日阻力+今日支撑)*0.5;
阻支A:=(今日阻力-今日支撑)*0.625+今日支撑;
阻支MA:=(ARH+ARL)*0.5;
阻支HL:=(H+L)*0.5;
KD转向:=IF(ZIG((H+L)*0.5,5)=ZIG(3,5),ZIG(3,5),ZIG((H+L)*0.5,5));
RSV:=(KD转向-LLV(KD转向,8))/(HHV(KD转向,8)-LLV(KD转向,8))*100;
K:=SMA(RSV,3,1),COLOR336688,LINETHICK2;
D:=SMA(K,3,1),COLOR809000,LINETHICK2;
{股旁网-股票公式网站 www.GUpang.com}
STICKLINE((CLOSE<阻支HL OR C<阻支) AND K<REF(K,1) AND ARSI<=CRSI AND C<O,O,C,0.5,0),COLORCC7700;
STICKLINE((CLOSE>=阻支HL OR C>阻支) AND K>REF(K,1) AND ARSI>=CRSI AND C>O,C,O,3,1),COLORFF00FF;
VARLL:=REF(LLV(LOW,90),1);
VARLH:=REF(HHV(HIGH,90),1);
分割低起:=REFDATE(VARLL,DATE),POINTDOT,COLORCC00CC,LINETHICK1;
分割高起:=REFDATE(VARLH,DATE),POINTDOT,COLORCC0000,LINETHICK1;
最低:=REFDATE(低BB,DATE);
最高:=REFDATE(高BB,DATE);
S低:=STICKLINE(分割低起=LOW,H,牛箱,0,1),COLOR000098;
S高:=STICKLINE(分割高起=HIGH,今日阻力,H*0.625,0,1),COLOR777777;
A低:=STICKLINE((CROSS(ZIG(3,17),REF(ZIG(3,17),1)) OR TROUGHBARS(3,15,1)=1 OR TROUGHBARS(3,15,1)=0
OR TROUGHBARS(阻支A,15,1)=1 OR TROUGHBARS(阻支A,15,1)=0) AND 分割低起=LOW OR 最低=LOW,LOW,L*2,0,1);
A高:=STICKLINE((CROSS(REF(ZIG(3,17),1),ZIG(3,17)) OR PEAKBARS(阻支HL,15,1)=0 OR PEAKBARS(阻支HL,15,1)=1
OR PEAKBARS(3,15,1)=0 OR PEAKBARS(3,15,1)=1) AND HHV(H,50)=H OR 最高=HIGH,H,H/1.275,0,1),COLORCCDDEE;
低起点:=DRAWICON(S低 AND CROSS(S低,牛箱),牛箱,1);
高起点:=DRAWICON(S高 AND CROSS(S高,熊箱),熊箱,1);
牛箱压力线:DRAWLINE(A高,H,低起点,牛箱,1),COLORFFAA66,LINETHICK2;
中轴压力线:DRAWLINE(A高,H,低起点,牛熊中轴,0),COLORFFAA55;
熊轴压力线:DRAWLINE(A高,H,低起点,熊箱,0),COLORFFAA55;
分割A:=分割低起*1.129;
分割B:=分割低起*1.275;
分割C:=分割低起*1.5;
分割D:=分割低起*1.625;
分割E:=分割低起*2;
MA1:=MA(HIGH,1);
分割O:=VARLL;
分割OO:=DRAWTEXT(VARLL AND CROSS(波浪线,分割O),分割O,1);
零卡:=DRAWLINE(分割OO,分割O,分割O,分割O,1),POINTDOT,COLOR0088FF,LINETHICK1;
分割AA:=DRAWTEXT(VARLL AND CROSS(波浪线,分割A),分割A,1);
一卡:=DRAWLINE(分割AA,分割A,分割A,分割A,1),POINTDOT,COLOR0088FF,LINETHICK1;
分割BB:=DRAWTEXT(VARLL AND CROSS(波浪线,分割B),分割B,1);
二卡:=DRAWLINE(分割BB,分割B,分割B,分割B,1),POINTDOT,COLOR0088FF,LINETHICK1;
分割CC:=DRAWTEXT(VARLL AND CROSS(波浪线,分割C),分割C,1);
三卡:=DRAWLINE(分割CC,分割C,分割C,分割C,1),POINTDOT,COLOR0088FF,LINETHICK1;
分割DD:=DRAWTEXT(VARLL AND CROSS(波浪线,分割D),分割D,1);
四卡:=DRAWLINE(分割DD,分割D,分割D,分割D,1),POINTDOT,COLOR0088FF,LINETHICK1;
分割EE:=DRAWTEXT(VARLL AND CROSS(波浪线,分割E),分割E,1);
五卡A:=DRAWLINE(分割EE,分割E,分割E,分割E,1),POINTDOT,COLOR0088FF,LINETHICK1;
五卡:=IF(MA1>(四卡+五卡A)/2,五卡A,四卡),POINTDOT,COLOR0088FF,LINETHICK1;
分割L:DRAWTEXT(CROSS(MA1,一卡) OR CROSS(MA1,二卡) OR CROSS(MA1,三卡) OR CROSS(MA1,四卡)
OR CROSS(MA1,五卡A),(H+L)*0.5,' ∈'),COLOR0000BB;
STICKLINE(O>=阻支 AND C>(H+L)*0.5 AND (C-REF(C,1))/REF(C,1)>0.027 AND 波浪线>=REF(波浪线,1)
,(H-L)*0.5+L,O,2.2,0),COLOR0000AA;
DX:=CROSS(DF,6) OR CROSS(RSI,6) OR CROSS(RSI,4) OR CROSS(RSI,2);
超跌A:=DRAWICON(TROUGHBARS(3,15,1)=1 AND HIGH>LOW+0.01 AND (DF<11 OR DX),今日支撑,25);
超跌:DRAWTEXT(DX AND 波浪线>=REF(波浪线,1),LLV(LOW,5),'超跌'),COLOR00BBAA;
周死RK:DRAWTEXT((CROSS("RSI.RSI3#WEEK","RSI.RSI1#WEEK") AND CROSS(周CD,周CK)) OR (CROSS(月RSI3,月RSI1) AND 波浪线<=REF(波浪线,1))
,HHV(HIGH,8),'↓'),COLORFFAA00;
出货:=DRAWTEXT(CROSS("RSI.RSI3#WEEK","RSI.RSI2#WEEK") AND 波浪线<REF(波浪线,1) OR
(波浪线<REF(波浪线,1) AND C<=今日支撑 AND DF>79 AND RSI>79),H,'出'),COLORFFAA00;
劲下:STICKLINE(波高 OR (CROSS("RSI.RSI3#WEEK","RSI.RSI2#WEEK") AND 月RSI3>月RSI1 AND 波浪线<REF(波浪线,1)),C,H,3,1),COLOR67BB57;
劲上:STICKLINE(波低 AND (CROSS("RSI.RSI2#WEEK","RSI.RSI3#WEEK") AND 月RSI3<月RSI1 AND 波浪线>REF(波浪线,1)),C,L,3,1),COLOR00CCDD;
A81:=MA(EMA(CLOSE,12),1);
A82:=MA(EMA(CLOSE,12),3);
A83:=MA(EMA(CLOSE,12),5);
A84:=MA(EMA(CLOSE,12),7);
A85:=MA(EMA(CLOSE,12),9);
A86:=MA(EMA(CLOSE,12),11);
A87:=MA(EMA(CLOSE,12),13);
A88:=MA(EMA(CLOSE,60),1);
A89:=MA(EMA(CLOSE,60),3);
A90:=MA(EMA(CLOSE,60),5);
A91:=MA(EMA(CLOSE,60),7);
A92:=MA(EMA(CLOSE,60),9);
A93:=MA(EMA(CLOSE,60),11);
A94:=MA(EMA(CLOSE,60),13);
多空A:=(A81+A82+A83+A84+A85+A86+A87)/7;
多空B:=(A88+A89+A90+A91+A92+A93+A94)/7;
多空线2:=(多空A+多空B)/2,COLOR0088CC;
GG:=(REF(阻支,1)+REF(阻支,2)+REF(阻支,3))/3;
STICKLINE((CROSS(阻支HL,GG)) OR (CROSS(C,多空线2) AND 多空线2>=REF(多空线2,1)) AND C>(H+L)*0.5
AND VOL/REF(VOL,1)>1.5 AND (C-REF(C,1))/REF(C,1)>0.027,(H+L)*0.5,O,1,0),COLORAA00FF;
HINE1:=98; HINE2:=95;
HINE3:=87; HINE4:=84;
DRAWTEXT((CROSS(HINE1,RSI) OR CROSS(HINE2,DF) OR CROSS(HINE3,DF) OR CROSS(HINE4,DF))
AND 波浪线<REF(波浪线,1),HHV(HIGH,5),'RSI↓'),COLOR00FF00;
HL50:=(高BB-低BB)/2;
新低:=STICKLINE(低BB=LOW,LOW,HL50,0,1),COLORFFBBFF;
新高:=STICKLINE(高BB=HIGH,L*0.995,H*0.871,0,1),COLOR00FF00;
上下13:=低BB+(高BB-低BB)*0.13;
上下27:=低BB+(高BB-低BB)*0.275;
上下38:=低BB+(高BB-低BB)*0.382;
上下50:=低BB+(高BB-低BB)*0.5;
上下62:=低BB+(高BB-低BB)*0.618;
上下72:=低BB+(高BB-低BB)*0.725;
上下87:=低BB+(高BB-低BB)*0.87;
HH87:=DRAWTEXT(新高 AND CROSS(上下87,新高),上下87,2);
支87线:=DRAWLINE(新低,L,HH87,上下87,1),COLOR000077,LINETHICK1;
HH72:=DRAWTEXT(新高 AND CROSS(上下72,新高),上下72,2);
支72线:=DRAWLINE(新低,L,HH72,上下72,1),COLOR0034AA,LINETHICK1;
HH62:=DRAWTEXT(新高 AND CROSS(上下62,新高),上下62,2);
支62线:=DRAWLINE(新低,L,HH62,上下62,1),COLORCC8800,LINETHICK1;
HH50:=DRAWTEXT(新高 AND CROSS(上下50,新高),上下50,2);
支50线:=DRAWLINE(新低,L,HH50,上下50,1),COLORCC8800,LINETHICK1;
HH38:=DRAWTEXT(新高 AND CROSS(上下38,新高),上下38,2);
支38线:=DRAWLINE(新低,L,HH38,上下38,1),COLORCC8800,LINETHICK1;
多空三八:DRAWLINE(S低,L,CROSS(支38线,ARH),支38线,0),CROSSDOT,COLOR0000DD,LINETHICK1;
DRAWTEXT(CROSS(支38线,C) AND 波浪线<REF(波浪线,1) AND ARSI<CRSI,H,'跌破三八线'),COLOR00AABB;
DRAWICON(CROSS(支38线,C) AND 波浪线<REF(波浪线,1) AND ARSI<CRSI,H*1.005,15);
LI38:=DRAWTEXT(新低 AND CROSS(新低,上下38),上下38,1);
压线38:=DRAWLINE(新高,H,LI38,上下38,1),POINTDOT,COLORDDCC00;
LI50:=DRAWTEXT(新低 AND CROSS(新低,上下50),上下50,1);
压线50:=DRAWLINE(新高,H,LI50,上下50,1),POINTDOT,COLORFF0000;
LI62:=DRAWTEXT(新低 AND CROSS(新低,上下62),上下62,1);
压线62:=DRAWLINE(新高,H,LI62,上下62,1),COLORFF0000;
LI72:=DRAWTEXT(新低 AND CROSS(新低,上下72),上下72,1);
压线72:DRAWLINE(新高,H,LI72,上下72,1),COLORFF0000;
LI87:=DRAWTEXT(新低 AND CROSS(新低,上下87),上下87,1);
压线87:=DRAWLINE(新高,H,LI87,上下87,1),COLORFF0000;
穿牛1:STICKLINE((CROSS(C,牛箱压力线) OR CROSS(L,牛箱压力线)) AND C>O AND 波浪线>=REF(波浪线,1),C,O,3.2,0),COLOR1800FF;
穿牛2:STICKLINE((CROSS(C,牛箱压力线) OR CROSS(L,牛箱压力线)) AND C>O AND 个股换手率>沪深换手 AND
波浪线>=REF(波浪线,1),C,O,1.8,0),COLORCC88FF;
穿压3:STICKLINE((CROSS(C,多头线) OR CROSS(C,临界线)) AND C>O AND VOL/REF(VOL,1)>1.1 AND 个股换手率>沪深换手 AND
波浪线>=REF(波浪线,1),C,O,0.1,0),COLORBB66BB;
STICKLINE(CROSS(C,风向线65) AND 波浪线>REF(波浪线,1) AND 个股换手率>沪深换手,C,O,0.1,0),COLOR00CCAA;
H87:=分割高起*0.871;
H72:=分割高起*0.725;
H62:=分割高起*0.625;
Z87:=DRAWLINE(S低,L,高起点,H87,1),POINTDOT,COLOR00AAEE;
Z72:DRAWLINE(S低,L,高起点,H72,1),POINTDOT,COLOR00AAEE;
Z62:DRAWLINE(S低,L,高起点,H62,1),POINTDOT,COLOR00AAEE;
支撑87:=DRAWLINE(S低,L,高起点,上下87,1),POINTDOT,COLOR00AAEE;
支撑72:DRAWLINE(S低,L,高起点,上下72,1),POINTDOT,COLOR00AAEE;
支撑62:DRAWLINE(S低,L,高起点,上下62,1),POINTDOT,COLOR00AAEE;
支撑38:=DRAWLINE(S低,L,高起点,上下38,1),POINTDOT,COLOR00AAEE;
IF(C<支撑87,Z87,支撑87),COLOR0000AA;
IF(C>支撑38,Z72,支撑38),POINTDOT,COLOR00AAEE;
牛箱支撑线:DRAWLINE(S低,L,高起点,牛箱,1),COLOR0058DD;
中轴支撑线:DRAWLINE(S低,L,高起点,牛熊中轴,1),COLOR0068DD;
熊箱支撑线:DRAWLINE(S低,L,高起点,熊箱,1),COLOR0078DD;
获利平均值:=EMA(100*WINNER(C),45),COLOR00AA00,LINETHICK2;
获利转向线:=ZIG(获利平均值,11),COLOR00DDDD,LINETHICK1;
STICKLINE(C>(H+L)*0.5 AND C>=O AND 获利转向线>REF(获利转向线,1),H,L,0,1),COLORDD38EE;
STICKLINE(C<(H+L)*0.5 AND C<阻支,(H+L)*0.5,(H+L)*0.5,1.6,1),COLORFFAA00;
上穿压:STICKLINE(波浪线>=REF(波浪线,1) AND C>阻支HL AND (CROSS(L,压线87) OR CROSS(C,压线87) OR CROSS(C,压线72) OR CROSS(C,压线62) OR
CROSS(C,压线50)),O,C,0,0),COLOR00FFEE;
BOLL:=MA(CLOSE,20);
BOLLZ:=MA(阻支,20);
布林中轨:=((CROSS(C,BOLL) OR CROSS(L,BOLL) OR CROSS(C,BOLLZ) OR CROSS(L,BOLLZ)) AND (BOLL>=REF(BOLL,1) OR BOLLZ>=REF(BOLLZ,1))
AND VOL/REF(VOL,1)>1.1 AND 波浪线>=REF(波浪线,1) AND C>=今日阻力 AND RSI<88);
上中轨:=布林中轨 AND COUNT(布林中轨,8)>=2;
周金RK:DRAWTEXT(CROSS("RSI.RSI1#WEEK","RSI.RSI3#WEEK") AND CROSS(周CK,周CD) AND C>风向线65 AND 个股换手率>沪深换手,L,'RK'),COLOR00FFFF;
出击:=DRAWTEXT((周金RK OR 上中轨) AND 个股换手率>沪深换手,L,' 出击'),COLOR00FFFF;
下支:DRAWICON((CROSS(临界线,C) OR (CROSS(箱顶,C) AND C<=今日支撑) OR CROSS(牛箱支撑线,C) OR CROSS(中轴支撑线,C)
OR CROSS(多头线,C)) AND 波浪线<=REF(波浪线,1),(H-L)*0.871+L,8);
阻支ZGA:=IF(C<=阻支,阻支,今日阻力);
阻支ZGB:=IF(C>阻支,阻支,今日支撑);
STICKLINE(C<=O,阻支ZGA,阻支ZGA,1,0),COLOR87EE00;
STICKLINE(C>今日支撑,阻支ZGB,阻支ZGB,1,1),COLOR0000CC;
STICKLINE( C<=今日阻力,今日阻力,今日阻力,2,2),COLOR778866;
STICKLINE( C>=今日支撑,今日支撑,今日支撑,2,2),COLOR4477AA;
STICKLINE( C<=今日支撑,今日支撑,今日支撑*1.001,2,1),COLOREEFFFF;
STICKLINE( C>=今日阻力,今日阻力,今日阻力,2,1),COLOR00FFEE;
DRAWICON(CROSS(REF(ZIG(3,17),1),ZIG(3,17)) AND PEAKBARS(3,15,1)>=0,H,12);
DRAWICON(CROSS(ZIG(3,15),REF(ZIG(3,15),1)) AND TROUGHBARS(3,15,1)>=0,L,11);

通达信选牛箱上上线主图指标公式

 

相关文章