在线检测未来函数

通达信波段RSI指标公式

来源:Internet,编辑:股旁网,2011-05-05

RMA2:=MA(MA("RSI.RSI2#MONTH",2),2);
RMA3:=MA(MA("RSI.RSI3#MONTH",2),2);
CRSI:"RSI.RSI3#WEEK",COLOR00AA00,LINETHICK1;
BRSI:"RSI.RSI2#WEEK",COLOREE1166,LINETHICK1;
ARSI:"RSI.RSI1#WEEK",COLOR3366CC,LINETHICK1;
突破月R1:=STICKLINE(RMA2>=RMA3,0,VOL,2.8,0);
突破月R2:=STICKLINE(RMA2<RMA3,0,VOL,2.8,0);
月MD:="KDJ.D#MONTH";
月MK:="KDJ.K#MONTH";
周CD:="KDJ.D#WEEK";
周CK:="KDJ.K#WEEK";
月死KD:=MA((月MD,月MK),1);
周死KD:=MA((周CD,周CK),1);
周死RSI:="RSI.RSI2#WEEK"<="RSI.RSI3#WEEK";
月金KD:=MA((月MK,月MD),1);
周金KD:=MA((周CK,周CD),1);
周金RSI:="RSI.RSI2#WEEK">="RSI.RSI3#WEEK"*0.998;
周金R:="RSI.RSI1#WEEK">="RSI.RSI2#WEEK";
死叉RSI:=DRAWICON(CROSS(周CD,周CK) AND 周死RSI,90,2);
转向:=DRAWICON((CROSS(周CK,周CD) AND 周金RSI),25,5);
金叉RSI:=STICKLINE(CROSS("RSI.RSI2#WEEK","RSI.RSI3#WEEK"),0,25,3,0);
月金叉:=月MK>月MD;
月周金叉:=IF(CROSS(周CK,周CD) AND 月金叉,31,0);
AA:=STICKLINE(月死KD && 周死KD && 周死RSI && 突破月R2,95,5,0,1),COLOR807777;
BB:=STICKLINE(月金KD && 周金KD && 周金RSI && 突破月R1,5,95,0,1),COLOR0000BB;
DF:7*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1)
-3*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1),3,1)
-SMA(SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1)
,3,1),2,1),COLOR00EEFF,LINETHICK1;
{股旁网-股票公式网站 www.GUpang.com}
KF:EMA(MA(DF,5),7),COLOR777777,LINETHICK1;
STICKLINE(DF>78 && DF>=KF,78,DF+1,5,0),COLOR00CC00;
STICKLINE(KF<15 && KF<=DF,KF,15,5,0),COLOR00FFEE;
STICKLINE(KF<=DF,KF,DF,0.8,0),COLOR0000FF;
STICKLINE(KF>DF,KF,DF,0.8,0),COLORFFCC00;
STICKLINE(DF>70 AND (PEAKBARS(HHV(RSI,5),17,1)=1 OR PEAKBARS(HHV(RSI,11),11,1)=1
OR PEAKBARS(HHV(RSI,24),15,1)=1 OR PEAKBARS(HHV(DF,24),11,1)=0),80,96,4,0),COLOREEFF00;
低:=STICKLINE(DF<18 AND (TROUGHBARS(LLV(HHV(RSI,1),5),17,1)=0 OR TROUGHBARS(LLV(RSI,24),15,1)=0 OR
TROUGHBARS(LLV(DF,3),17,1)=1 OR TROUGHBARS(LLV(DF,24),15,1)=1),5,20,4,0),COLOR00AACC;
金叉RSI:STICKLINE(CROSS("RSI.RSI2#WEEK","RSI.RSI3#WEEK") AND ("RSI.RSI2#MONTH">="RSI.RSI3#MONTH")
AND ("RSI.RSI1#MONTH">"RSI.RSI2#MONTH"),95,5,1.2,0),COLOR3800FF;
金叉R:DRAWICON(CROSS("RSI.RSI2#WEEK","RSI.RSI3#WEEK"),80,9);
卖:IF(PEAKBARS(3,15,1)=1,64,95),COLOR00FF44,LINETHICK2;
买:IF(TROUGHBARS(3,15,1)=0 AND HIGH>LOW+0.01,38,5),COLORFF00FF,LINETHICK2;
HINE1:=78.89;
HINE2:=85 OR 82;
HINE3:=92 OR 89;
LINE1:=5;
LINE2:=10;
LINE3:=13;
DRAWTEXT(CROSS(HINE1,DF) OR CROSS(HINE2,DF) OR CROSS(HINE3,DF),89,'▼R高▼'),COLOREEFFEE;
DRAWTEXT(CROSS(DF,LINE1) OR CROSS(DF,LINE2) OR CROSS(DF,LINE3),13,'▲低'),COLOR00AAFF;

通达信波段RSI指标公式

 

相关文章