在线检测未来函数

通达信DMI压箱底用法指标公式

来源:Internet,编辑:股旁网,2011-05-18

TTR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),14);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),14);
DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),14);
PDI:DMP*100/TTR,NODRAW;
MDI:DMM*100/TTR,NODRAW;
{股旁网-股票公式网站 www.GUpang.com}
STICKLINE(PDI>MDI,MDI,PDI,1,1),COLORLIRED;
STICKLINE(PDI>30,30,PDI,2,0),COLORRED;
STICKLINE(PDI<=MDI,MDI,PDI,1,1),COLORLIBLUE;
STICKLINE(MDI>30,30,MDI,2,0),COLORBLUE;
STICKLINE(PDI<15,15,PDI,1,0),COLORBLACK;
STICKLINE(MDI<15,15,MDI,1,0),COLORBLACK;
STICKLINE(PDI<15,15,PDI,0.5,0),COLORBLUE;
STICKLINE(MDI<15,15,MDI,0.5,0),COLORRED;
ADX行情指示线:EXPMEMA(ABS(MDI-PDI)/(MDI+PDI)*100,5),NODRAW,COLORGREEN;
确认线:=EXPMEMA(ABS(MDI-PDI)/(MDI+PDI)*100,6),COLORGREEN;
盘整区上轨:30,NODRAW,COLORMAGENTA;
盘整区下轨:15,NODRAW,COLORMAGENTA;
DRAWBAND(ADX行情指示线,RGB(0,255,0),确认线,RGB(255,255,255));
无方向观望区:PDI<30 AND MDI<30 AND PDI>15 AND MDI>15,COLORYELLOW,NODRAW;
STICKLINE(无方向观望区,60,50,0,-1),COLORYELLOW;

通达信DMI压箱底用法指标公式

 

相关文章