在线检测未来函数

通达信黑马赢指标公式

来源:Internet,编辑:股旁网,2011-05-25

V1:=(C*2+H+L)/4*10;
V2:=EMA(V1,11)-EMA(V1,30);
V3:=EMA(V2,5);
V4:=2*(V2-V3)*4;
做空:= IF(V4<=0,V4,0),COLORGREEN;
做多:= IF(V4>=0,V4,0);
V5:=(HHV(INDEXH,8)-INDEXC)/(HHV(INDEXH,8)-LLV(INDEXL,8))*8;
V6:=EMA(3*V5-2*SMA(V5,18,1),5);
V7:=(INDEXC-LLV(INDEXL,8))/(HHV(INDEXH,8)-LLV(INDEXL,8))*10;
V8:=(INDEXC*2+INDEXH+INDEXL)/4;
V9:=EMA(V8,13)-EMA(V8,34);
VA:=EMA(V9,3);VB1:=(V9-VA)/2;
V11:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1),3,1);
趋势线:=EMA(V11,4)*0.99;
超买超卖:趋势线;
V12:=(趋势线-REF(趋势线,1))/REF(趋势线,1)*88;
空仓: STICKLINE(PBX.PBX1(3)<PBX.PBX2(5) AND PBX.PBX2(5)<PBX.PBX3(7) AND PBX.PBX3(7)<PBX.PBX4(9),70,100,5,0),COLORCC9900;
AA:=PBX.PBX1(3)<PBX.PBX2(5) AND PBX.PBX2(5)<PBX.PBX3(7) AND PBX.PBX3(7)<PBX.PBX4(9);
DRAWTEXT (AA,65,'空'),COLORCC9900;
抄底: STICKLINE((DMI.PDI(14,6)<5 AND DMI.ADX(14,6)>70),0,50,4,0),COLORRED;
DRAWTEXT (抄底,55,'抄底'),COLORRED;
头部: STICKLINE((DMI.ADX>70 AND DMI.MDI<5 AND 趋势线>=85) OR (DMI.ADX>68 AND DMI.MDI<6) OR (DMI.PDI>40 AND CROSS(DMI.ADXR,DMI.PDI)) OR (EVERY(趋势线>=90,10) AND CROSS(90,趋势线)) OR (DMI.PDI>50 AND 趋势线>=78 AND CROSS(DMI.ADXR,DMI.PDI)),70,100,4,0),COLORGRAY;
DRAWTEXT(头部>0,62,'头部'),COLORLIGRAY;
EE:=(((SUM(VOL,5)/5<VOL AND CROSS(MACD.MACD,0) OR CROSS(MACD.MACD,1) OR CROSS(MACD.MACD,2)) AND DMI.PDI>DMI.MDI AND CR>CR.MA2),10);
FF:=PBX.PBX1(3)>PBX.PBX2(5) AND PBX.PBX2(5)>PBX.PBX3(7) AND PBX.PBX3(7)>PBX.PBX4(9);
持有:STICKLINE( PBX.PBX1(3)>PBX.PBX2(5) AND PBX.PBX2(5)>PBX.PBX3(7) AND PBX.PBX3(7)>PBX.PBX4(9),0,25,5,0),COLORWHITE;
DRAWTEXT (FF,35,'持'),COLORWHITE;
当日成本:=IF(C>REF(C,1),(3*H+4*C+3*OPEN+2*L)/12,(2*H+4*C+3*OPEN+3*L)/12);
疯牛线:=MA(当日成本,3);
{股旁网-股票公式网站 www.GUpang.com}
VAR1:=(EXPMEMA(当日成本,3)>EXPMEMA(当日成本,5) AND EXPMEMA(当日成本,5)>EXPMEMA(当日成本,7) AND MA(CLOSE,3)>MA(CLOSE,5) AND MA(CLOSE,5)>MA(CLOSE,7));
VAR2:=(REF(VAR1,2)<0.5 AND REF(VAR1,3)<0.5 AND MA(C,5)>REF(MA(C,5),1) AND CROSS(VAR1,0.5) AND FILTER(CROSS(VAR1,0.5),7)) OR ((REF((MA(CLOSE,3)>MA(CLOSE,5) AND MA(CLOSE,5)>MA(CLOSE,7)),3) OR REF((MA(CLOSE,3)>MA(CLOSE,5) AND MA(CLOSE,5)>MA(CLOSE,7)),5) OR REF((MA(CLOSE,3)>MA(CLOSE,5) AND MA(CLOSE,5)>MA(CLOSE,7)),6) OR REF((MA(CLOSE,3)>MA(CLOSE,5) AND MA(CLOSE,5)>MA(CLOSE,7)),4) OR REF((MA(CLOSE,3)>MA(CLOSE,5) AND MA(CLOSE,5)>MA(CLOSE,7)),2)) AND NOT(REF(MA(CLOSE,3)>MA(CLOSE,5) AND MA(CLOSE,5)>MA(CLOSE,7),1)) AND (MA(CLOSE,3)>MA(CLOSE,5) AND MA(CLOSE,5)>MA(CLOSE,7)) AND FILTER((REF((MA(CLOSE,3)>MA(CLOSE,5) AND MA(CLOSE,5)>MA(CLOSE,7)),3) OR REF((MA(CLOSE,3)>MA(CLOSE,5) AND MA(CLOSE,5)>MA(CLOSE,7)),5) OR REF((MA(CLOSE,3)>MA(CLOSE,5) AND MA(CLOSE,5)>MA(CLOSE,7)),6) OR REF((MA(CLOSE,3)>MA(CLOSE,5) AND MA(CLOSE,5)>MA(CLOSE,7)),4) OR REF((MA(CLOSE,3)>MA(CLOSE,5) AND MA(CLOSE,5)>MA(CLOSE,7)),2)) AND NOT(REF(MA(CLOSE,3)>MA(CLOSE,5) AND MA(CLOSE,5)>MA(CLOSE,7),1)) AND (MA(CLOSE,3)>MA(CLOSE,5) AND MA(CLOSE,5)>MA(CLOSE,7)),7) AND 疯牛线>REF(疯牛线,1)) AND MA(VOL,3)>MA(VOL,10) AND V2>=V3;
清仓: STICKLINE((REF(DMI.ADX,1)>REF(DMI.ADXR,1) AND REF(DMI.ADXR,1)>58 AND DMI.PDI>DMI.MDI AND 趋势线>60 AND CROSS(DMI.ADXR,DMI.ADX) AND 趋势线<90) OR (EVERY(REF(趋势线,1)>90,10) AND 趋势线<90),65,100,4,0),COLORGREEN;
DRAWTEXT (清仓,60,'清仓'),COLORGREEN;
杀入: STICKLINE((REF(DMI.ADXR,1)<REF(DMI.ADX,1) AND REF(DMI.ADX,1)>80 AND DMI.PDI<10 AND CROSS(DMI.ADXR,DMI.ADX) AND DMI.MDI>DMI.PDI),0,50,4,0),COLORGREEN;
DRAWTEXT (杀入,55,'杀入'),COLORGREEN;
逃吧: STICKLINE((REF(DMI.ADXR,1)<REF(DMI.ADX,1) AND REF(DMI.ADX,1)>80 AND REF(DMI.MDI,1)<10 AND CROSS(DMI.ADXR,DMI.ADX) AND DMI.MDI<DMI.PDI),65,100,4,0),COLORRED;
DRAWTEXT (逃吧,60,'逃吧'),COLORGREEN;

通达信黑马赢指标公式

 

相关文章